Just nu i M3-nätverket
Gå till innehåll
Monshi

LÖST Kod-taggen äter tecken

Rekommendera Poster

Har kod-taggen ändrats nyligen på något vis? Upplever konstigt beteende, den äter tecken.

 

Kopierar in kod, lägger på kodtag, skickar inlägg och ser att resultatet inte blir det jag vill. Öppnar för redigering och ser att alla tecken som ska vara där är där.

En bild säger allt

post-8996-0-53046200-1433326795.png

 

Taget ur denna tråd

//eforum.idg.se/topic/348987-dataområde-och-sortering-via-knapp/?p=1656014

 

för tusan

Me.Range("a1").Sort key1:=Me.Range("b1"), Header:=xlYes

 

blir efter kod-taggen

 

Me.Range("a1").SortMe.Me.Range("b1eader:=xlYes

 

vad tusan sker?

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Jag tror inte att forumprogrammet har uppdaterats under våren.

 

Däremot ändras webbläsare lite då och då. Det var en större Firefox-uppdatering för några månader sen som gjorde att det plötsligt såg helt annorlunda ut när man aktiverade Källa-knappen. Om det nu skulle vara något sånt som spökar. Har du kollat med flera webbläsare?

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Mmh, är det nya versionen av Firefox som formaterar texten galet.

Kollar Flyfishermans testinlägg, det ser ut som

 

post-8996-0-45425300-1433360200.png

när jag tittar på det.

Öppnar jag det för att redigera det ser det helt annorlunda ut, mer korrekt ut...

 

Vadtusan!

Firefox 38.05 på Win Vista.

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

detta inlägg ser lika illa ut i Chrome, IE och FF,

 

 

//eforum.idg.se/topic/348987-dataområde-och-sortering-via-knapp/?p=1656014

dvs

    Me.Range("A16").Sort Me.Range("a16"), Header:=xlYes

blir till

Me.Range("A16").SortMe.Range(Me.Range("a16eader:=xlYes

 

i alla tre läsarna.

Kanske något dumt tecken som följd med när jag kopierade in texten? mmh

 

Konstigt detta. testade redigera, första omladdning ser allt korrekt ut men vid nästa laddning renderas allt fel igen. För ja, det är webbläsarna som gör något.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Och det är inte enbart inom kod-taggen som tecken försvinner. I alla webbläsare jag testar

 

men

post-8996-0-91215100-1435913390.png

 

och det tycks inte vara kopplat till hur jag kopierar in, går jag via anteckningar blir det samma galna presentation, går jag manuellt genom inlägget och skriver in nya mellanslag/radbyten påverkar inte heller det.

 

Det ovan från tråden

//eforum.idg.se/topic/349171-kopiera-celler-fr%C3%A5n-en-flik-till-en-annan/?do=findComment&comment=1658140

 

och jag har en testtråd

//eforum.idg.se/topic/349265-kod-test/

där felen uppkommer även.

 

Bara jag som drabbas? Bara mina inlägg där jag postar kod?

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Om jag inaktiverar javascript och laddar sidorna så ser det rätt ut. Det stämmer ju ganska bra med beteendet också (att det först ser rätt ut i ett par sekunder när man förhandsgranskar och sedan sunkar till sig). 

 

Alla tecken finns ju i HTML-koden så det borde vara något formateringsbus, Dessutom ser det rätt ut i min Firefox (39). Kan bero på att jag nästan aldrig använder den och alla inställningar är "fabriksstandard".

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Mmh, tar och inspekterar elementen.

Då ser jag att koden har lagts in inom en klass "skimlinks-unlinked"

<span class="skimlinks-unlinked">Me.Range("A16").Sort</span>

som delar upp koden i olika delar.

 

Kan jag vara något på spåret?

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Postad (redigerade)

Vilken webbläsare inspekterade du elementen med?

 

 

Det ligger ingen span class i själva HTML koden, men det finns en länk till ett externt javascript som heter skimlinks.js. Jag tror att det är en "klickräknare" , men det har ju ett samma namn som ditt spanclass och det ligger nästan sist på sidan. Om man laddar om sidan hårt så ser man hur din text skrivs ut korrekt först och sedan förstörs. Det tyder kanske på att det är ett sent javaskript. 

 

Det är ett långt härke till script så jag orkar/klarar inte av att lista ut vad det gör,  men det verkar vara en hel del omstuvningar av text och "b.push("span.skimlinks-unlinked" gör någonting....)

 

Min första gissning var att det var något javascript som skall snygga up text/ skriva smilisar som fått spel.  

Om inte skimlinks hade påstått sig vara en klickräknare skulle jag ha gissat på att du var på rätt spår. Men vem vet, det kanske bara  missar målet?

Det märkliga är att äldre trådar ser bra ut, trots att de verkar hämta samma filer med javascript. Det talar dessutom emot att det skulle vara någon uppdatering av webbläsarna som ställer till det.

 

 

****ED***

Gjöm det jag skrev om att gamla inlägg ser bra ut. Kollade en av dina trådar från februari, det ser ut som rumpa:

//eforum.idg.se/topic/348087-markera-celler-med-specifik-formel/

Redigerad av MH_resurrected

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Japp. Du var på rätt spår. Det är det skriptet.

Enklaste testet:

I internet explorer, Testa att lägga till s.skimresources.com i "icke betrodda platser"

ladda om dina problemsidor.

 

Inte någon bra lösning men IDG får väl trolla bort skriptet om det suger så hårt  (förklarar för övrigt varför det fungerade i firefox hos mig , jag har något slags spår-blockerare aktiverad)

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Sådär, installerat att tillägg till Firefox som kan blockera sidor och vips, lade till

s.skimresources.com

där och nu fungerar det, nu ser koden korrekt ut.

 

 

Man skulle vilja kunna pinga folk här, Cecilia är väl enda som har någon kanal till IDG som kan påtala detta problem.

Ping ping Cecilia :)

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Jag kan försöka men jag har inte fått någon respons på ett mejl som jag skickade för ca 10 dagar sen.

 

Jag tror Javascript från skimresources.com har tillkommit i Eforum i år för jag reagerade för ett tag sen på det i listan som NoScript visar.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×
×
  • Skapa nytt...