Just nu i M3-nätverket
Jump to content

startar eth0 misslyckades


Chribba

Recommended Posts

Hej!

 

Vad krävs för att jag ska kunna intiera nätverkskortet (eth0, under Red Hat 7.1) vid boot med Telia ADSL. Jag har läst en del av vad som skrivits här tidigare men ändå inte lyckats.

 

Jag har dhcp-clientdemonen (/sbin/dhcpcd), /etc/dhcpc/resolv.conf -> /etc/resolv.conf och /etc/resolv.conf innehåller Telias namnservrar. Min /etc/sysconfig/network-scripts/ifcfg-eth0 ser ut så här:

 

DEVICE=eth0

BOOTPROTO=dhcp

ONBOOT=yes

BROADCAST=

NETWORK=

NETMASK=

IPADDR=

USERCTL=no

 

Vad mer krävs för att det ska fungera? Tacksam för hjälp!

Link to comment
Share on other sites

Du har inte skrivit vilket nätverkskort du har. Klarar Linux ditt kort? Behöver du verkligen ange Telias namnservrar. Jag har ComHem och får all konfiguration, inkl namnservrar, via dhcp. Allt jag behövde göra var att ange att konfigurationen ska ske via dhcp. Men det förutsätter ju förstås att Linux känner till kortet.

 

Link to comment
Share on other sites

Jodå, jag får en ip-adress tilldelad till eth0 när jag kör /sbin/dhcpcd manuellt efter boot. Det är egentligen bara vid boot det inte fungerar. Här behöver jag hjälp att felsöka. (Som jag ser det har jag angett att konfigurationen ska ske via dchp i ifcfg-eth0).

 

PS. Håller med om att namnservrarna inte är inblandade i dhcp. DS.

 

Link to comment
Share on other sites

Jodå, jag får en ip-adress tilldelat interfacet eth0 när jag kör /sbin/dhcpcd manuellt efter boot. Det är egentligen bara vid boot som det inte fungerar. Här behöver jag hjälp att felsöka. (Du har rätt i att namnservrarna inte bör vara inblandade i dhcp.)

 

 

 

[inlägget ändrat 2001-09-27 10:04:21 av Chribba]

Link to comment
Share on other sites

Jodå, jag får en ip-adress tilldelad till eth0 när jag kör /sbin/dhcpcd manuellt efter boot. Det är egentligen bara vid boot det inte fungerar. Här behöver jag hjälp att felsöka. (Som jag ser det har jag angett att konfigurationen ska ske via dchp i ifcfg-eth0).

 

PS. Håller med om att namnservrarna inte är inblandade i dhcp. DS.

 

 

 

Link to comment
Share on other sites

Per Erik Stendahl

Är det verkligen /sbin/dhcpcd som är dhcp-klient? Jag kör iofs RH6.2 men när jag tittar i /sbin/ifup så står det där att den använder /sbin/pump som dhcp-klient.

 

Link to comment
Share on other sites

Är det /sbin/ifup som körs vid boot? Använder /sbin/ifup sig av /etc/sysconfig/network-scripts/ifcfg-eth0? (Jag ska kolla närmare när jag kommer hem från jobbet!)

 

 

 

Link to comment
Share on other sites

Per Erik Stendahl

Har bara en RH6.2-burk här på jobbet så jag kan inte kolla hur 7.1 gör. Men i 6.2 så är det scriptet /etc/rc.d/init.d/network som startar alla nätverkgränssnitt. Den kör /sbin/ifup på varje ifcfg-fil i /etc/sysconfig/network-scripts.

 

Men som sagt, det är 6.2. 7.1 kan mycket väl skilja sig.

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...