Just nu i M3-nätverket
Jump to content

Google fungerar inte


maccaddam

Recommended Posts

Det går inte att komma åt google.se  eller google.com från mina tre windows 8.1 datorer vare sig med chrome, firefox eller IE. Från chrome går det inte heller att googla med google. 

 

Det som händer är att sidan inte är tillgänglig eller det blir timeout. 

Link to comment
Share on other sites

Går det att komma åt andra söksidor som bing.com och yahoo.com?

Går det att komma åt antivirusprograms webbplatser, t ex https://www.avast.com/index ?

 

Har något skadligt program upptäckts i någon dator?

Link to comment
Share on other sites

Bing och Yahoo funkar. https://www.avast.com/index och alla adresser når man i Chrome om man skriver hel och rätt adress.

 

Virusprogrammen F-secure, Defenter och McAfee hittar inte någonting vid skanning.

 

Det här gäller alla datorer i huset inklusive Android-telefon. Därför har jag kopplat förbi routern och gått ut direkt via adsl-modemet, men det är lika illa.

 

Har ett par gånger fått upp "update your flash player", virusprogrammet har upptäckt att den är skadlig och åtgärdat.

 

Felet borde alltså vara att modemet är infekterat (om det är i huset) eller? 

Link to comment
Share on other sites

Kommer du in på google.se med IP-numret 216.58.208.3? Kan vara DNS-problem. Kolla även hosts-filen. Skadliga program kan modifiera den filen för att hindra åtkomst till någon tjänst.

Link to comment
Share on other sites

Kommer du in på google.se med IP-numret 216.58.208.3? Kan vara DNS-problem. Kolla även hosts-filen. Skadliga program kan modifiera den filen för att hindra åtkomst till någon tjänst.

216.58.208.3 fungerar, jag får upp google-sök-rutan och kan googla därifrån. Och hur går jag vidare?

Link to comment
Share on other sites

Jag hoppas att du menar att du har F-secure och McAfee i olika datorer, för att ha två antivirusprogram i en dator kan leda till konstiga problem.

 

Nu är jag inte säker på vad det exakt heter i Windows 8 men det borde vara rätt likt Windows 7 och där gör man så här:

Kontrollpanelen - Nätverks- och delningscenter

Ändra inställningar för nätverkskort

Högerklicka på nätverksanslutningen och välj Egenskaper.

Klicka först på "Internet Protocol Version 4 (TCP/IPv4)" och sen på knappen Egenskaper.

 

Om "Erhåll adress till DNS-servern automatiskt" inte är valt så skriv i ditt svar vad för önskade DNS-servrar det står och välj sen "Erhåll adress till DNS-servern automatiskt".

 

Om "Erhåll adress till DNS-servern automatiskt" däremot är valt så välj i stället "Använd följande DNS-serveradresser" och skriv in 208.67.222.222 (som går till OpenDNS).

Spara och starta om datorn.

 

Hur går det nu att nå Google?

Link to comment
Share on other sites

Då är det utanvidare ett DNS problem. Alternativt kan ett skadligt program lagt in ett felaktigt  IP-nummer i hosts-filen. När en adress skall omvandlas till IP-nummer kollar datorn först hosts-filen. Om IP-numret inte finns där så frågar datorn DNS-servern., som vid behov skickar frågan vidare till domänens DNS-server. Hemmaroutrar har en DNS-cache, d.v.s. routern sparar DNS-uppslagningar så att ofta använda IP-nummer inte behöver sökas från nätet. Om Googles IP-nummer har ändrats så kan det vara orsaken.

 

Om du inte gjort några ändringar i hosts-filen skall det förutom kommentarerna endast finnas en rad med IP-numret för localhost (127.0.0.1). Den raden är absolut nödvändig för datorns interna kommunication. Då jag inte använder Windows kan jag inte säga exakt var host-filen ligger. Mappen, som innehåller filen heter etc och ligger i en mapp under system-mappen.

Link to comment
Share on other sites

Jag hoppas att du menar att du har F-secure och McAfee i olika datorer, för att ha två antivirusprogram i en dator kan leda till konstiga problem.

 

Nu är jag inte säker på vad det exakt heter i Windows 8 men det borde vara rätt likt Windows 7 och där gör man så här:

Kontrollpanelen - Nätverks- och delningscenter

Ändra inställningar för nätverkskort

Högerklicka på nätverksanslutningen och välj Egenskaper.

Klicka först på "Internet Protocol Version 4 (TCP/IPv4)" och sen på knappen Egenskaper.

 

Om "Erhåll adress till DNS-servern automatiskt" inte är valt så skriv i ditt svar vad för önskade DNS-servrar det står och välj sen "Erhåll adress till DNS-servern automatiskt".

 

Om "Erhåll adress till DNS-servern automatiskt" däremot är valt så välj i stället "Använd följande DNS-serveradresser" och skriv in 208.67.222.222 (som går till OpenDNS).

Spara och starta om datorn.

 

Hur går det nu att nå Google?

Jag har nu gjort detta och just nu funkar det i alla fall! Tack för nu och god natt!

Link to comment
Share on other sites

Fint!

 

Vad var det för inställning tidigare och vad är det nu?
Jag undrar för att det är möjligt att din router behöver åtgärdas eller att andra kontroller behövs i datorn.

Link to comment
Share on other sites

Fint!

 

Vad var det för inställning tidigare och vad är det nu?

Jag undrar för att det är möjligt att din router behöver åtgärdas eller att andra kontroller behövs i datorn.

Tidigare var inställningen automatisk.

 

Inställningen i adsl-modemet är 

- Obtain DNS server address automatically

x Use the following DNS server addresses

Preferred DNS Server: 63.143.35.66

Alternate DNS Server: 8.8.8.8

och följer jag Preferred så hamnar jag på en sida som vill att jag ska uppdatera flash-player (som alltså är en sida som stoppas av virusprogrammet). Jag ändrar just nu till automatically få se om det fungerar.

 

Borde vara det som är boven eftersom felet drabbar alla enheter i huset. Eftersom att när jag kopplade bort routern (som är en separat enhet) var felet kvar.

Link to comment
Share on other sites

Inställningen i routern (det borde finnas viss router-funktionalitet i det du kallar för modem eftersom ett rent modem inte hanterar DNS) visar att någon har varit inne i den och ändrat. Du behöver ändra inloggningslösenordet till den så att ett skadligt program i en dator inte kan logga in i den. Alternativt så har den ett säkerhetshål så att någon ute på internet kan komma åt dess inställningar. Vad är dess beteckning?

Link to comment
Share on other sites

Modemet är D-Link DSL-320B som man kommer åt via routern ASUS RT-N66U med WPA2-kryptering. Jag har nu ändrat lösenordet till modemet.

Link to comment
Share on other sites

Om du har hårdvaruversion D1 så har det kommit ut en till firmware-version som ska täppa igen ett säkerhetshål.

http://www.dlink.com/se/sv/support/product/dsl-320b-adsl-2-ethernet-modem?revision=deu_revd#downloads

Följ länken "Hur du hittar hårdvaruversion" för att se om du har Z eller D1, och välj sen det du har. I manualen står det hur du uppdaterar firmware.

Link to comment
Share on other sites

Jag har Firmware Version: v1.03 Hardware Version: Z1, där finns det tydligen ingen ny version. Tack för tipset i alla fall!

Link to comment
Share on other sites

Då tycker jag du kontaktar D-links support för att höra dig för om vad de har att säga om vad som hänt, om där finns säkerhetshål som de inte har brytt sig om att åtgärda mm.

http://www.digitalmunition.me/2015/02/popular-dsl-wireless-router-model-d-link-allegedly-vulnerable-software-bug/

 

Sen kan det ju vara bra att kolla det andra alternativet, dvs att det finns eller har funnits ett skadligt program i någon dator som har loggat in på modemet eftersom det programmet troligen gör annat också.

Link to comment
Share on other sites

  • 5 weeks later...

D-link svarar så här:

Det finns en uppdatering. Länk till firmware se nedan.

 

ftp://dlinktemp:dlinktemp@194.117.170.198/DSL/DSL-320B/HW_Z1/DSL-320B_v1.07.zip

 

Har du en router som du kopplar efter den? Ifall så, då ska du ställa modemet i bridge läge, se till att vpi är 8 och vci 35 och efter detta går du in på LAN SETUP och ställer DHCP Mode i läge disable, längst ut till vänster av de 3 alternativen(disable, enable, dns relay).

 

När den är i bridge mode så erhåller routern eller om du kopplar direkt till datorn, all information från din isp(bahnhof), dvs. ip adress, nätmask, gateway adress och dns adresser.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...