Just nu i M3-nätverket
Gå till innehåll

.htaccess fungerar inte!


Niss3

Rekommendera Poster

Jag har försökt få igång .htaccess på min apache 2.4 server, men lyckas inte.

 

Har följt denna "guide": http://askubuntu.com/questions/429869/is-this-a-correct-way-to-enable-htaccess-in-apache-2-4-7-on-ubuntu-12-04

 

Hur kan jag felsöka vad det är som inte fungerar?

 

Tack för all hjälp!

Med vänliga hälsninsgar,

Simon Nilsson

 

 

EDIT:

Jag kör windows 8.

Länk till inlägg
Dela på andra webbplatser

Vad är det du försöker att göra?

 

Vad är det för mappar som du inte vill att någon ska komma åt?

 

Tex:

 

var/www/godis/password

var/www/godis/username

Länk till inlägg
Dela på andra webbplatser

Jag vill först och främst ha en 404 sida.

 

Försöker du gå till adressen.se/ensidasomintefinns så ska du hamna på 404.php och inte något default webbrowser "sidan finns inte" sida..

 

 

Allt jag har i min .htaccess fil:

 

ErrorDocument 404 /404.php

 

 

Eftersom .htaccess inte fungerar får jag bara:

fae2c49f33.png

Länk till inlägg
Dela på andra webbplatser

Jag vill först och främst ha en 404 sida.

 

Försöker du gå till adressen.se/ensidasomintefinns så ska du hamna på 404.php och inte något default webbrowser "sidan finns inte" sida..

 

 

Allt jag har i min .htaccess fil:

 

ErrorDocument 404 /404.php

 

 

Eftersom .htaccess inte fungerar får jag bara:

fae2c49f33.png

Har du gjort en fil som heter "404.php"

 

Om den inte hitta sidan så går den till "var/www/godis/404.php"

 

Jag får det att funka för mig.

 

Prova det här.

ErrorDocument 404 https://google.se/

Så om något går fel så kommer jag till Google var en bra testing.

Länk till inlägg
Dela på andra webbplatser
ErrorDocument 404 https://google.se/

Fungerar inte.

 

Jag är ganska säker på att det är .htaccess som inte är rätt aktiverat på min apache server.

 

 

Från början stod det såhär:

#<Directory />
#    AllowOverride none
#    Require all denied
#</Directory>
Jag ändrade till:
<Directory "c:/www">
AllowOverride All
</Directory>

Men det verkar vara här det är något som är fel..

 

-edit-

 

Jag hittade precis felet..

 

Tog bort <directory> helt och använde bara AllowOvveride så fungerade det.

 

Vet inte varför det inte fungerar med directory..

Länk till inlägg
Dela på andra webbplatser

Arkiverat

Det här ämnet är nu arkiverat och är stängt för ytterligare svar.



×
×
  • Skapa nytt...