Just nu i M3-nätverket
Gå till innehåll
MrNemo

Ta bort dubbletter automatiskt?

Rekommendera Poster

MrNemo

Jag håller på att skapa en rapport som förhoppningsvis inte behöver så mycket med underhåll. I en kolumn i ett blad (Blad1) förekommer det värden som kan bestå av både siffror och bokstäver. Samma värde kan förekomma på flera rader. Dessa värden vill jag få in på ett nytt blad (Blad2) utan dubbletter per automatik. Om en användare lägger till ett nytt värde på Blad1 ska värdet komma upp i en kolumn på Blad2. Går detta att lösa med formler?

Jag använder Office 2010. Exempelbild bifogat.

 

post-136067-0-15230100-1422437763.jpg

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Monshi

Det går med en radda formler (eller kod). Formler ska det vara så...

 

Utmed dina data, eller på annan plats går iofs bra även, skriver du

=OM(OCH(A2<>"";ANTAL.OM($A$1:A1;A2)=0);RAD();"")

Givet att dina data står i kolumn A och rad 1 är en rubrikrad, tom eller med text..

 

Kopiera ned så många rader som dina data räcker

 

Där du vill ha din kopia med unika tal, skriv i första kolumn, på rad 2:

=MINSTA(B2:B9;RAD()-1)

och kopiera ned. ja om du vill skriv

=OMFEL(MINSTA(B2:B9;RAD()-1))

givet att formeln ovan står i B2:B9

 

Och i nästa kolumn

=INDEX(A1:A9;F2)

eller

=OM(F2<>"";INDEX(A1:A9;F2);"")

 

Kolumner du inte vill se, bara att dölja.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
MrNemo

Tack för snabbt svar! Får inte riktigt ihop det med dina instruktioner. Gjorde en del små justeringar i koden men alla referenserna kommer inte med och några kommer med två gånger i sammanställningen. Kan du se vad jag gör fel? Steg 2 är att den ska sammanställa referenser från fler blad men det löser jag kanske själv om jag får koden för ett blad att fungera korrekt. Kom också på att filen måste vara kompatibel med Excel 97 då en användare kör det.

Test.xls

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Monshi

två saker

=OM(OCH(Blad1!E2<>"";ANTAL.OM(Blad1!$E$1:Blad1!E1;Blad1!E2)=0);RAD();"")

 

samt

=OM(B2<>"";INDEX(Blad1!E$1:Blad1!E$999;B2);"")

 

helt enkelt ett litet fel i referenserna.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
MrNemo

Jättestort tack! Nu ska jag se om jag kan få restan att fungera också =)

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
MrNemo

Jag kommer tyvärr inte på hur jag ska lösa att den hämtar från flera blad så jag får blotta min okunskap och fåga efter hjälp igen.

 

Den bifogade filen har upprättad kod så att den hämtar data korrekt från Blad1, kan jag bygga vidare på koden så att den även hämtar från Blad2?

Test.xls

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Monshi

Ojoj, vill du att den ska hämta unika värden från blad2 baserade på de värden som finns på Blad1? 

 

vad komplext du gör det!

Då rekommenderar jag nästan en tvåstegsraket. Du tar helt enkelt och sammanställer alla unika värden från blad1 i en kolumn, från blad2 i en kolumn och sedan på detta blad tar ut de unika ur dessa två kolumner. 

 

Eller vad menar du? 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
MrNemo

Jag vill hämta unika värden från både Blad1 och Blad2.

 

Håller med om att dokumentet blir komplext men målet är att det ska vara enkelt för de som fyller i Blad1, Blad2 osv...

 

Hade själv en tanke på att göra en tvåstegsvariant då jag misstänker att det annars blir väldigt lång kod.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Monshi

det går att lösa med en kod...

 

på blad 1, kör koden som tidigare.

På blad 2, kör samma kod som på blad 1 fast två gånger plus varandra. Ena formeln söker igenom kolumnen på blad 1 och andra kolumnen på blad 2.

 

Och på bladet där du letar upp med.

ta två kolumner med MINSTA()

när första ger felvärde, då tar andra kolumnen vid.

Och med en liten OM-sats väljer du sedan vilken INDEX som ska användas, den som hämtar från Blad 1 eller Blad 2.

 

allt går...

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×
×
  • Skapa nytt...