Just nu i M3-nätverket
Gå till innehåll
kikotte

LÖST Försöker mount Windows 7 partition men den hitta inte den.

Rekommendera Poster

kikotte
Postad (redigerade)

Tja,

 

 

Har lite problem den vill inte mount Windows 7 partition har försök med mycket men inget funkar någon som har en ide eller fler?

 

Den dyker inte upp i #df eller #fdisk

 

Edit:

 

Den kan inte hitta den men det kommer igång när man boot upp Windows 7 så den finns där men Linux kan inte hitta den skumt.

Redigerad av kikotte

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
kikotte

Jag kan starta upp Windows 7 men när jag starta Linux så hitta den inte Windows 7 partition hur ska jag göra då för att hitta den partition?

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
.M

Har du mer än en fysisk disk i datorn? Kan det vara så att du kollar partitionerna på fel disk?

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Mikael63

Så fdisk -l listar bara den disk/partition som Linux finns på?

 

Är det möjligen så att, som .M är inne på, att Linux finns på en disk men att Windows ligger på diskar som är i RAID0 ?

 

Inte alla Linux-distar som hittar RAID0. (Mint gör det)

 

Hur växlar du mellan dessa operativsystem?

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
fagerja

Programmet fdisk stöder inte GPT-diskar. För att hitta Windowspartitionen använd kommandot blkid elle gå in i /dev/disk/. Kommandot lshw visar också hårddiskarna och hur de är partitionerade. Både blkid och lshw måste köras som root eller med sudo. De ingår inte som standard i alla distributioner men finns i föråden.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
kikotte
Postad (redigerade)

Jag kör Windows 7 på min virtual server och jag boot upp Linux från live cd som är iso.

 

Jag har provat med fdisk den hitta bara Linux.

 

Den ligger på en SSD som är RAID 0.

Redigerad av kikotte

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
fagerja

Jag kör Windows 7 på min virtual server och jag boot upp Linux från live cd som är iso.

 

Jag har provat med fdisk den hitta bara Linux.

 

Den ligger på en SSD som är RAID 0.

RAID 0 på en (1) SSD är en omöjlighet. För RAID måste du ha minst 2 enheter. RAID-array heter md0, md1 o.s.v. i linux. Information om dem får du med kommandot: cat  /proc/mdstat.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
kikotte
Postad (redigerade)

RAID 0 på en (1) SSD är en omöjlighet. För RAID måste du ha minst 2 enheter. RAID-array heter md0, md1 o.s.v. i linux. Information om dem får du med kommandot: cat  /proc/mdstat.

Jag har två SSD som kör RAID 1. Jag prova det som du skriv man den hitta inte filen.

Redigerad av kikotte

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Mikael63

 

 

Jag kör Windows 7 på min virtual server

 

Osäker på vad du menar med detta.. ?

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
kikotte

Osäker på vad du menar med detta.. ?

Jag kör med virtual machine som kör Windows 7 (körs i virtual).

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Mikael63

Jag kör med virtual machine som kör Windows 7 (körs i virtual).

Okej.. tror jag.. du använder VirtualBox eller VMware-Player eller liknande?

Är det Windows 7 som är värddator?

Kör du en live-cd (fast som iso) med Linux som gäst?

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
kikotte

Okej.. tror jag.. du använder VirtualBox eller VMware-Player eller liknande?

Är det Windows 7 som är värddator?

Kör du en live-cd (fast som iso) med Linux som gäst?

Jag kör med vmware esxi så allt är virtual i server dator.

Jag kör iso från store så fort jag kommer in på  Linux så gör jag mig root.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Mikael63

Jag känner inte till den produkten, VMware ESXI men då antar jag att vi kan skippa vilket operativ som är värd.

 

Som gäst har du då en VM-machine med Windows 7 på.

Den maskinens CD/DVD innehåller en ISO med Linux på, och den är satt till att vara connected vid start, så att det är Linux Live som bootar.

 

Korrekt?

 

Tror jag skulle kunna testa liknande förhållanden då..

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
kikotte

Jag känner inte till den produkten, VMware ESXI men då antar jag att vi kan skippa vilket operativ som är värd.

 

Som gäst har du då en VM-machine med Windows 7 på.

Den maskinens CD/DVD innehåller en ISO med Linux på, och den är satt till att vara connected vid start, så att det är Linux Live som bootar.

 

Korrekt?

 

Tror jag skulle kunna testa liknande förhållanden då..

Ja det stämmer.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Mikael63

Okej, jag har liknande förhållanden:

VMware Player

Windows XP som VM-machine

Linux Mint 17 som ISO

 

När jag bootar med Linux får jag i terminalen detta:

 

post-52940-0-81732700-1412710303_thumb.png

 

Då har jag en disk enligt:

 

post-52940-0-07271900-1412710314_thumb.png

 

Som redan påpekat ser en del Linux-distar, liksom Grub, inte RAID0 och OM då dessa distar har svårt att se virtuella diskar känner jag inte till.

Om det alltså är så att du har "fel" Linux.

 

Om du har annan virtuell disk än den SCSI jag har kan ju det spela roll.

 

Vilken dist och vilken typ av disk har du?

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
kikotte

Jag får det här.

 

post-73763-0-11117700-1412711250_thumb.png

 

Så här ser disken ut.

 

post-73763-0-66790700-1412711270_thumb.png

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Mikael63
Postad (redigerade)

Jag får det här.

Hittar alltså inte ens "sig själv". Konstigt.

Ja då har jag inga fler uppslag.

 

Edit:

Jo, testa med Linux Mint...

Redigerad av Mikael63

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
fagerja

I din live-dist ingår inte blkid, så därför får du inget resultat. Men titta efter vad du hittar i /dev/disk/by-uuid. VM-ware kan begränsa vilka diskar/partitioner du får tillgång till.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
kikotte

I din live-dist ingår inte blkid, så därför får du inget resultat. Men titta efter vad du hittar i /dev/disk/by-uuid. VM-ware kan begränsa vilka diskar/partitioner du får tillgång till.

Det här är allt som jag hittar.

 

post-73763-0-42066900-1412719393_thumb.png

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
kikotte

Vilken dist. använder du?

Hur menar du vilken disk? Så här ser min disk ut #16

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Mikael63

Jag kör med live cd och Linux ophcrack.

 

Eh? Jaha.. om du testar med en mer "vanlig" dist. då?

 (Varför ophcrack?)

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
m3johan

Jag hänger inte med riktigt. Försöker du mounta din (lösa?) windows-disk i en dator som är startad med en linux-live-iso i en virtuell maskin?

Varför inte bara installera på riktigt? Låter som att det är bäddat för trubbel det där.

Redigerad av m3johan

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×
×
  • Skapa nytt...