Just nu i M3-nätverket
Jump to content

Försöker mount Windows 7 partition men den hitta inte den.


kikotte

Recommended Posts

Tja,

 

 

Har lite problem den vill inte mount Windows 7 partition har försök med mycket men inget funkar någon som har en ide eller fler?

 

Den dyker inte upp i #df eller #fdisk

 

Edit:

 

Den kan inte hitta den men det kommer igång när man boot upp Windows 7 så den finns där men Linux kan inte hitta den skumt.

Link to comment
Share on other sites

Jag kan starta upp Windows 7 men när jag starta Linux så hitta den inte Windows 7 partition hur ska jag göra då för att hitta den partition?

Link to comment
Share on other sites

Så fdisk -l listar bara den disk/partition som Linux finns på?

 

Är det möjligen så att, som .M är inne på, att Linux finns på en disk men att Windows ligger på diskar som är i RAID0 ?

 

Inte alla Linux-distar som hittar RAID0. (Mint gör det)

 

Hur växlar du mellan dessa operativsystem?

Link to comment
Share on other sites

Programmet fdisk stöder inte GPT-diskar. För att hitta Windowspartitionen använd kommandot blkid elle gå in i /dev/disk/. Kommandot lshw visar också hårddiskarna och hur de är partitionerade. Både blkid och lshw måste köras som root eller med sudo. De ingår inte som standard i alla distributioner men finns i föråden.

Link to comment
Share on other sites

Jag kör Windows 7 på min virtual server och jag boot upp Linux från live cd som är iso.

 

Jag har provat med fdisk den hitta bara Linux.

 

Den ligger på en SSD som är RAID 0.

Link to comment
Share on other sites

Jag kör Windows 7 på min virtual server och jag boot upp Linux från live cd som är iso.

 

Jag har provat med fdisk den hitta bara Linux.

 

Den ligger på en SSD som är RAID 0.

RAID 0 på en (1) SSD är en omöjlighet. För RAID måste du ha minst 2 enheter. RAID-array heter md0, md1 o.s.v. i linux. Information om dem får du med kommandot: cat  /proc/mdstat.

Link to comment
Share on other sites

RAID 0 på en (1) SSD är en omöjlighet. För RAID måste du ha minst 2 enheter. RAID-array heter md0, md1 o.s.v. i linux. Information om dem får du med kommandot: cat  /proc/mdstat.

Jag har två SSD som kör RAID 1. Jag prova det som du skriv man den hitta inte filen.

Link to comment
Share on other sites

Jag kör med virtual machine som kör Windows 7 (körs i virtual).

Okej.. tror jag.. du använder VirtualBox eller VMware-Player eller liknande?

Är det Windows 7 som är värddator?

Kör du en live-cd (fast som iso) med Linux som gäst?

Link to comment
Share on other sites

Okej.. tror jag.. du använder VirtualBox eller VMware-Player eller liknande?

Är det Windows 7 som är värddator?

Kör du en live-cd (fast som iso) med Linux som gäst?

Jag kör med vmware esxi så allt är virtual i server dator.

Jag kör iso från store så fort jag kommer in på  Linux så gör jag mig root.

Link to comment
Share on other sites

Jag känner inte till den produkten, VMware ESXI men då antar jag att vi kan skippa vilket operativ som är värd.

 

Som gäst har du då en VM-machine med Windows 7 på.

Den maskinens CD/DVD innehåller en ISO med Linux på, och den är satt till att vara connected vid start, så att det är Linux Live som bootar.

 

Korrekt?

 

Tror jag skulle kunna testa liknande förhållanden då..

Link to comment
Share on other sites

Jag känner inte till den produkten, VMware ESXI men då antar jag att vi kan skippa vilket operativ som är värd.

 

Som gäst har du då en VM-machine med Windows 7 på.

Den maskinens CD/DVD innehåller en ISO med Linux på, och den är satt till att vara connected vid start, så att det är Linux Live som bootar.

 

Korrekt?

 

Tror jag skulle kunna testa liknande förhållanden då..

Ja det stämmer.

Link to comment
Share on other sites

Okej, jag har liknande förhållanden:

VMware Player

Windows XP som VM-machine

Linux Mint 17 som ISO

 

När jag bootar med Linux får jag i terminalen detta:

 

post-52940-0-81732700-1412710303_thumb.png

 

Då har jag en disk enligt:

 

post-52940-0-07271900-1412710314_thumb.png

 

Som redan påpekat ser en del Linux-distar, liksom Grub, inte RAID0 och OM då dessa distar har svårt att se virtuella diskar känner jag inte till.

Om det alltså är så att du har "fel" Linux.

 

Om du har annan virtuell disk än den SCSI jag har kan ju det spela roll.

 

Vilken dist och vilken typ av disk har du?

Link to comment
Share on other sites

I din live-dist ingår inte blkid, så därför får du inget resultat. Men titta efter vad du hittar i /dev/disk/by-uuid. VM-ware kan begränsa vilka diskar/partitioner du får tillgång till.

Link to comment
Share on other sites

I din live-dist ingår inte blkid, så därför får du inget resultat. Men titta efter vad du hittar i /dev/disk/by-uuid. VM-ware kan begränsa vilka diskar/partitioner du får tillgång till.

Det här är allt som jag hittar.

 

post-73763-0-42066900-1412719393_thumb.png

Link to comment
Share on other sites

  • 2 weeks later...

Jag hänger inte med riktigt. Försöker du mounta din (lösa?) windows-disk i en dator som är startad med en linux-live-iso i en virtuell maskin?

Varför inte bara installera på riktigt? Låter som att det är bäddat för trubbel det där.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...