Just nu i M3-nätverket
Gå till innehåll
vurpis

Excel senast registrerade datum

Rekommendera Poster

Hej

 

Jag har en lång lista med personal och deras loggar till ett system, dessa loggar daterar alla händelser som personalen gör. Nu vill jag skapa en flik som ständigt uppdaterar med senaste loggningen för den anställde. 

 

Jag behöver alltså en formel som letar efter alla registerarade poster(anställnings-ID) som är bokförda på den anställde i kolumn A, sedan att formeln letar upp det högsta/senaste registrerade datumet i kolumn B

 

 

Leta efter alla gånger X förekommer i kolumn A, hitta sedan högsta värdet av dessa tillfällen i kolumn B

 

 

Misstänker att jag ska använda en komination av letarad/passa/index/max, men är tacksam för svar

 

/tack på förhand

Viktor

 

Redigerad av vurpis

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Först notera att med formler blir det inte en dynamisk lösning, dvs du behöver så många rader med formler som du tror att du någonsin kan behöva eller begränsat antal som du efter hand manuellt ökar på antalet av.

 

 

Du har en lista,,,

mmh

X finns i A

i B finns ett värde

Hitta max

=PRODUKTSUMMA(MAX((A1:A8=D3)*(B1:B8)))

där du i D3 skriver det ID som det ska sökas efter.

 

 

Eller använd en pivotabell.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Först notera att med formler blir det inte en dynamisk lösning, dvs du behöver så många rader med formler som du tror att du någonsin kan behöva eller begränsat antal som du efter hand manuellt ökar på antalet av.

 

 

Du har en lista,,,

mmh

X finns i A

i B finns ett värde

Hitta max

=PRODUKTSUMMA(MAX((A1:A8=D3)*(B1:B8)))

där du i D3 skriver det ID som det ska sökas efter.

 

 

Eller använd en pivotabell.

Tackar det där kommer lösa mina problem, nu har jag bara problemet att datumet i tabellen som skapas genererars i textform. 20140918

 

Tror du att man kan baka in "=TEXTNUM(VÄNSTER(A1;4)&"-"&EXTEXT(A1;5;2)&"-"&EXTEXT(A1;7;2))" i denna formel? eller måste jag göra en kolumn som löser detta? vore tacksam om det gick att lösa i samma formel.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Nä, de där behöver en egen cell/kolumn för att fungera. Långt ifrån alla formler fungerar i matrisformat.

 

 

Du kan nog skriva

=PRODUKTSUMMA(MAX((A1:A8=D3)*(B1:B8*1)))

 

borde fungera.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×
×
  • Skapa nytt...