Just nu i M3-nätverket
Jump to content

Star Wars Battlefront 2


Trollet85

Recommended Posts

Hej!

Jag har ett spel som heter Star Wars Battlefront 2, och jag installerade det på min förra installation av Windows 7, men sen installerade jag om datorn och nu när jag har installerat det igen så funkar det inte, launchern startas upp, jag trycker på " Start Game" och sen när spelet startas så flickar min sekundära skärm till lite, men min primära skärm blir svart och efter 1-1,5 sekunder så återkommer jag till skrivbordet, jag hör inga ljud i bakgrunden förutom min dators fläkt, och nu kommer det konstiga, när jag klickar på programmet i Aktivitetfältet så stängs den ner. 

 

Någon som vet hur jag ska gå vidare? Jag har testat och kört spelet i kompatiblitetsläge för Windows XP men det funkar ändå inte.

 

// Trollet85

Link to comment
Share on other sites

Flyfisherman

Lite snabbsökning ger att det kan vara problem med ljudkonfigurationen eller hantering av ljudenheterna.

 

Tex.

http://forums.lucasarts.com/thread.jspa?messageID=3514204

 

http://steamcommunity.com/app/6060/discussions/0/864947149145363444/#p2

I was getting the same, so I looked into it and it seems to be an audio driver issue with windows 7.

Now, there are a few options depending on your set up. If you have Realtek audio, you can download the latest driver, then right click the sound icon on your quickbar and go to "recording devices", right click on the main box and click "show disabled devices" and enable stereo mix. You should be all set.

If you don't have Realtek audio, like me, then there are a few other options...

1. You can plug a pair of headphones into your microphone jack, and by some sort of jedi magic everything just works, full audio and everything. You might have to go into your audio settings to make sure the mic is enabled (for some reason mine wasn't) I tried unplugging it in the middle of a game and it crashed out to windows again, so I guess you have to leave them in.

2. If that doesn't work for some reason and you're really desperate, you can go into the game audio settings and disable software mix... meaning, no in game audio. Sucks, I know, but it works.

I also hear using usb headphones works as well, but I haven't tried this.

 

 

 

Koppla in en mikrofon http://www.tomshardware.co.uk/forum/113623-13-star-wars-battlefront-help

This is a very weird fix but trust me:
Plug a mic into the mic jack and all problems will be solved! For some reason maps wont load battle front 2 crashes at map load on windows 7. BUT, if u plug in a mic, everything works perfect!!!!!!!!!

 

 

 

http://www.techsupportforum.com/forums/f219/solved-star-wars-battlefront-2-crash-fix-661814.html

Fix

The game appears to have an issue with sound cards in general, I've been looking in ther Internet for some fixes and these are the ones I've found so far:

1.) Plug a heaphones and/or a mic in the headphones and/or mic port.

2.) Disabling sound

3.) Go to Control panel > hardware and sound > sound > manage audio devices > recording tab > right click an open area under mic and line in > mark a tick next to show disabled devices > right click on the stereo mix icon that appears and click enable

PS: If you don't manage to find the hardware and sound section in the control panel, just go in start and type sound in the search section.

Hopefully with all these three fixes you should run the game.

PS: You might experience crash in multiplayer

 

 

 

http://answers.microsoft.com/en-us/windows/forum/windows_7-gaming/why-doesnt-star-wars-battlefront-2-work-on-my/6b932942-d18d-4127-ad3f-086f67e63224?page=2

Here's what I did that worked:
  1. Inserted the SWBF II PC DVD ROM Software into my DVD drive.
  2. Exited out of the menu that popped up.
  3. Clicked on Start.
  4. Clicked on My Computer.
  5. Right  clicked on SWBF II.
  6. Clicked on Explore.
  7. Clicked on GameData.
  8. In this folder there should be a folder called "setupBF2.exe" or SetUp. Select this folder and this installation process will begin (after you put in the SWBF II game code, choose to install Xfire, GameSpy, etc...)
No Download, Free, and Works!

 

 

 

Samt patch uppdatering http://www.lucasarts.com/support/update/Battlefront2.html

Och http://forums.lucasarts.com/thread.jspa?threadID=139849&tstart=0

 

Hoppas att något löser problemet.

Mvh :huh:

Link to comment
Share on other sites

  • 4 months later...

Tack!

Förlåt om jag inte har svarat förrän nu, jag har inte haft tid att kolla på det, och så har jag glömt bort, men jag hittade ett sätt. Jag kollade runt lite i Egenskaperna för spelet, jag testade att välja "Kör i : Maximerat". Det löste problemet, nu funkar det som det ska!!!

 

// Trollet85

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...