Just nu i M3-nätverket
Gå till innehåll
Nirak

Formel som kan leta fram text, sök?

Rekommendera Poster

Nirak

Hej!

 

Jag skulle vilja söka fram ord i en text, 3 ord - antar att man bör kunna kombinera formeln sök men jag kommer inte på hur. 

 

Om det t ex står i så här:

 

Mors lilla olle i skogen gick - jag vill ha fram ordet lilla men vill även att den söker på blåbär, om något av orden finns ska formeln returnera detta i cellen. Orden jag söker på förekommer aldrig på samma rad samtidigt, två ord behöver inte returneras. 

 

Någon som kan ge tips på en formel?

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Monshi

ja, det här blir en nästling av OM, SÖK och ÄRFEL

Typ

 

=OM(ICKE(ÄRFEL(SÖK("lilla";A1)));"lilla";OM(ICKE(ÄRFEL(SÖK("blåbär";A1)));"blåbär";""))

Om många ord kan man med fördel dela upp detta i flera celler/kolumner.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Nirak

Tack detta fungerar bra - jag har 4-5 ord som är yrkeskategorier. Det blir en väldigt lång formel, kanske bättre att söka ett ord per kolumn ändå? 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Monshi

Tack detta fungerar bra - jag har 4-5 ord som är yrkeskategorier. Det blir en väldigt lång formel, kanske bättre att söka ett ord per kolumn ändå? 

Precis, formeln blir annars ganska lång och svår att förstå sig på.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×
×
  • Skapa nytt...