Just nu i M3-nätverket
Gå till innehåll
Hankki

LÖST Inskriven text syns inte i vissa PDF filer i acrobat XI

Rekommendera Poster

Hankki

Hej, lite konstig rubrik men jag ska förklara.

Jag har gjort ett antal service dokument för maskinerna vi tillverkar och det dokumenten har gemensamt är att alla textfält och knappar är inplockade med Nitro Pro 7.

Jag testar ibland med olika läsare som Nitro reader, foxit reader och acrobat reader för att se att allt fungerar.

Mitt senaste dokument visar inte vad man skriver i om man använder acrobat reader XI men nog i X och när man sparar och öppnar det sparade ifyllda dokumentet i t ex foxit reader så visar det vad som skrevs i acrobat XI, hoppas ni hängde med :-)

Enda skillnaden mellan det som fungerar och inte fungerar i XI är en font som inte finns med i dokumentegenskaperna men det är inte fonten i textfältet.

Jag har numera Nitro Pro 9 som jag använder och gör jag ett nytt dokument med ett textfält så kommer ingen text i acrobat reader XI.

 

Det är inget stort problem i sig men just det som inte fungerar är ett dokument som är tänkt att skickas till kunder och användas vid garantiärenden så då ska man inte behöva kräva att de har en viss läsare för att det ska fungera.

 

Hoppas att någon har något tips.

 

 

Ett exempel på en textruta som inte fungerar i acrobat reader XI men nog i foxit reader.

test1.pdf

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Flyfisherman
Postad (redigerade)

Hej,

 

Hur har du sparat din pdf-fil, vilken pdf-standard har du använt?

Se detta från Adobe ang. olika pdf-standarder http://www.adobe.com/se/products/acrobat/iso-pdf-x-32000-standards.html

Samt detta en lista över dom olika pdf-standarderna http://acroeng.adobe.com/wp/?page_id=303

 

Kanske är det så enkelt att du skall spara om dokumentet till ett annat pdf-format?

 

Spara en standardiserad PDF-fil:

  1. Adobe Acrobat välj  Arkiv > Spara som
  2. Välj PDF/A eller PDF/E alt. PDF/X
  3. Skriv filnamn och klicka på Spara.
  4. Prova om det fungerar bättre med någon av dessa.

 

[Edit] Jag kan för övrigt nämna att din pdf-fil ser tom ut (ja en tom rektangulär ruta syns) i Okular PDF-reader som jag kör i Linux Mint.

Redigerad av Flyfisherman

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Flyfisherman

Ett exempel på en textruta som inte fungerar i acrobat reader XI men nog i foxit reader.

Jodå, textrutan fungerar i Adobe Reader XI och i Adobe Acrobat X Pro

Dvs. den blå delen är aktiv, men har inget innehåll.

post-73434-0-81552100-1395422306.png

Men som sagt inte i min andra webbläsare där det endast visas en tom ruta.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Hankki

Nej den har inget innehåll men ser du texten du skriver in?

Jag kollade versionerna på mina dokument och det var blandat v1.4 och v1.7 men jag har fungerande versioner av båda.

Obs! När jag skriver "inte fungerar" så är det just att text man skriver in i de blå fälten som inte syns om man gör det i acrobat reader XI men sparar man dokumentet i AR XI och öppnar i AR X eller Foxit så syns texten man skrev i AR XI.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Flyfisherman

Hej igen och ursäkta att jag varit sen med svaret pga. olika orsaker.

 

Men nu har jag haft möjlighet att testa lite mer och jag kan verkligen inte förstå vad som spökar, men jag har i alla fall skapat en kopia av ditt original som jag laddar upp och där har jag med Adobe Acrobat 10 Pro lagt till ytterligare två textboxar - vilka fungerar utmärkt.

 

Det som sker är att när man matar in text i din ruta (gäller hos mig: Adobe Acrobat 10 samt Adobe Reader 11 och även Okular PDF-reader i Linux) så ser man ju att "cursorn" förflyttar sig, vilket innebär att text matas in i boxen - men inget syns.

Varför?

 

Jag har skapat två nya boxar men bytt ut ditt typsnitt Myriad Pro Italic (vilket jag aldrig hört talas om) mot två andra vanligare och då verkar det fungera.

 

Det vore bra om fler provar att skriva text i dessa rutor och kommentera huruvida det fungerar, samt med vilken pdf-läsare som används..

test2.pdf

 

I så fall kanske den enkla lösningen är att du helt enkelt byter typsnitt i textboxen, fast otillfredställande om man inte vet rotorsaken förstås.

 

Såvida du inte redan löst allt, då vore det bra med info om hur.

Mvh :unsure:

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Flyfisherman

Ok. Jag har nu kommit fram till följande vad som orsakat problemet.

 

Du har använt ett ovanligt typsnitt: Myriad Pro Italic och detta typsnitt finns inte som standard i Windows typsnittmapp

C:\Windows\Fonts

 

Och dessutom typsnittet Myriad Pro Italic kostar c:a 35$US att köpa http://store1.adobe.com/cfusion/store/html/index.cfm?store=OLS-US&event=displayFontPackage&code=1706

Vilket få datoranvändare har installerat skulle jag gissa...

 

Det skulle då vara förklaringen till att man ser textmarkören förflytta sig efterhand man skriver i textboxen, men utan att någon text blir synlig.

Som sagt, byt typsnitt till ett mer vanligt och normalt och sen skall det inte vara några problem.

 

Fast om vi fortsätter lite vidare på hur du beskrivit det hela; så säger du att det fungerar med Foxit Reader?

Denna har jag jag nyss installerat temporärt och där fungerar som du säger din textbox med Myriad Pro Italic - vilket jag tycker är märkligt.

Här kan jag bara ge en gissning och det är att på något sett att inbäddad font importeras i Foxit Reader och därför syns dessa när man skriver, men detta är som sagt bara ren gissning och om så skulle vara fallet, så har Foxit något avtal med hur man har rättigheterna till att använda dessa fonter som ju dom flesta är upphovsrättsskyddade.

Rena spekulationer här nu... :wacko:

 

Andra kan kanske ge en bättre förklaring, men jag säger bara som slutsats; byt font.

Mvh :)

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Mikael63

Kan bekräfta att  det blir fel även med Acrobat Reader X.

Med AcroPlot Matrix 2014 fungerar det bra.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Flyfisherman

Kan bekräfta att  det blir fel även med Acrobat Reader X.

Med AcroPlot Matrix 2014 fungerar det bra.

Men fungerar det med dom andra textboxarna jag skapade enligt inlägg #5?

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Hankki

 

Andra kan kanske ge en bättre förklaring, men jag säger bara som slutsats; byt font.

Mvh :)

Jag testade att byta font men den var också en som inte fanns i Adobe reader.

Jag fick samma problem idag när jag fortsatte på projektet och när jag lät standard fonten i nitro, helvetica, vara så syns texten i adobe reader.

Tack för alla svar.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Flyfisherman

Festligt att en gammal tråd återupplivas med nån typ av lösning. :)

 

I PDF https://en.wikipedia.org/wiki/Portable_Document_Format#Fonts

 

Standard Type 1 Fonts (Standard 14 Fonts)

Fourteen typefaces, known as the standard 14 fonts, have a special significance in PDF documents:

  • Times (v3) (in regular, italic, bold, and bold italic)
  • Courier (in regular, oblique, bold and bold oblique)
  • Helvetica (v3) (in regular, oblique, bold and bold oblique)
  • Symbol
  • Zapf Dingbats

    These fonts are sometimes called the base fourteen fonts.[55] These fonts, or suitable substitute fonts with the same metrics, must always be available in all PDF readers and so need not be embedded in a PDF.[56] PDF viewers must know about the metrics of these fonts. Other fonts may be substituted if they are not embedded in a PDF.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×
×
  • Skapa nytt...