Just nu i M3-nätverket
Gå till innehåll
Kalle Dator1

LÖST Live webcam-bild via VLC Media Player

Rekommendera Poster

Hej !

Från min webbkamera, med utsikt från 11:e vån. i det höghus där jag bor, kan jag fånga bilden i VLC Media Player.
Men hur går jag vidare och bäddar in bilden på  min hemsida, för att visa den på internet ?

Tidigare har jag använt Vindows Media Encoder, med diverse krångel och diskutabelt resultat. Men jag fick ändå ut en bild, när det fungerade. Då använde jag en föreslagen port , 1755 !

Jag har nu testat flera förslag med VLC, som jag hittat m h a Google, men inget av dem verkar fungera särskilt bra = inte alls .
I min router har jag öppnat en port, 8080, vilken verkar vara något gemensamt för alla förslagen.
Men det måste vara ytterligare någonting som fattas, eftersom bilden inte går ut, ens så att jag kan se den på hemsidan lokalt - bara direkt i VLC Media Player..

Kan någon ge mig ett tips på hur det ska se ut hela vägen från kamera och till hemsidans 'embedding' via VLC, Windows brandvägg och Norton Internet Security.
Har öppnat i Windows brandvägg för programmet VLC Media Player, och lagt in VLC Media Player i NIS programregler för Tillåt !

Det senaste försöket ser ut som nedan:

<embed type="application/x-vlc-plugin" pluginspage="http://www.videolan.org" version="VideoLAN.VLCPlugin.2"  width="450" height="345" id="vlc" loop="yes" autoplay="yes" target="http://192.168.0.5:8080/" ></embed>

Då har jag ändrat target mellan ovanstående och DNS för hemsidan "http://karlerik39.no-ip.org:8080/". Jag får bara en tom ruta eller en svart sådan. Men ingen live bild !

Med vänlig hälsning

/Kalle

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Hej!

 

Vi är osäkra på var ditt problem ligger men jag flyttade din fråga så länge från Nätverket - Programvara eftersom du inte kan använda en lokal IP-adress som 192.168.0.5 om alla ska kunna se kameran utifrån internet.

 

Eftersom Norton Internet Security innehåller en brandvägg är det viktigt att Windows-brandväggen är avstängd. Att ha två brandväggar igång kan leda till många konstiga problem samt sänkt säkerhet om man har otur.

 

Cecilia

Moderator

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Hej Cecilia, Mikael63, och tack för era svar !

 

Jag är medveten om att det inte går att använda den lokala ip-adressen när man ska visa - i det här fallet webbkameran - på hemsidan

Som jag skrev, provade jag med att växla mellan den lokala och DNS för att se om det blev någon avgörande förbättring, men jag såg ingen skillnad.... Dvs inget resultat alls  !

 

Har just undrat över detta med NIS och Windows brandvägg.

När jag installerat NIS tidigare, har Windows brandvägg automatiskt (?) stängts av. Men nu efter installationen av NIS på Windows7, kom aldrig några alternativ upp, och brandväggen förblev aktiverad..

 

Jag har tidigare använt Windows Media Encoder i flera år.

Men den krånglar från och till, påstår ibland att där ingen webbkamera finns, att den saknar drivrutin eller är ogiltig med mera.... Dessemellan fungerar den bra !

 

Läste så att det skulle kunna gå bra att använda VLC som både encoder och spelare, vilket jag tyckte lät intressant och började forska.

Tyvärr fanns det bara knapphändiga instruktioner att få tag på via internet, mer eller mindre ofullständiga, som om författarna inte riktigt visste vad de sysslade med. Därför mitt frågeinlägg på IDG !

 

Egna försök med VLC-spelaren fick just inga bra resultat, andra än kraschad spelare, så jag börjar tvivla på att det verkligen är något att bygga på !

Så nej - Mikael63 - VLC-lösning är inte ett måste !

 

Har tillfälligt återgått till WME och hittat ett nytt script, som jag lagt in och ändå verkar fungera lokalt. Osäkert dock om det fungerar via internet, vilket jag själv inte kan verifiera p g a spärren för tillbakakoll på egen server !

Kolla gärna !

 

/Kalle

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Tack Mikael63 !

 

Kollade tråden som hastigast, och ska titta lite grundligare i morgon, tisdag !

 

Det är just så där grundlig som jag önskar att flera instruktioner skulle vara.

Steg för steg utan att utelämna stora luckor, där man får gissa sig till resten.

Författarna måhända vet exakt, men har inte förmågan att förmedla den - för dem - enkla kunskapen satt på pränt...

 

Känner igen en del av beteckningarna i tråden. Återkommer alltså sedan jag har kollat igenom instruktionerna !

 

/Kalle

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Det gick nu utmärkt att se en utsikt på http://karlerik39.no-ip.org/Videogalleri/Videogalleri.htm så det verkar vara löst.

 

Om jag uppfattar det rätt så verkar lösningen ha varit att du ändrade något i sidans HTML-kod. I så fall är det trevligt om du kan presentera lösningen här utifall att någon annan skulle undra samma sak i framtiden.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Tack Cecilia för kollen !

 

Gläder mig åt att webbkameran kan ses från andra datorer på internet, något som jag inte själv kan kolla tillbaka från egen server !

 

Detta är ju en del av lösningen, men fortfarande har jag det ursprungliga problemet kvar, med nyckfullheten hos Windows Media Encoder.

Ett återkommande budskap på loggen är "Det angivna nätverket är inte längre tillgängligt". Som jag tidigare nämnt så får jag ibland veta att webbkameran inte finns, eller att drivrutin saknas. Då vet jag ju inte längre om funktionen är kvar....

Dessa meddelanden bara dyker upp utan att jag har gjort några ändringar, annat än att jag bryter webbkameran för natten, då det egentligen inte är något att visa till utsikt....

 

Jag delar gärna med mig av det nyinsatta scriptet, som jag hittade på internet:

<!--- BEGIN PLAYER --->
<!-- webbot bot="HTMLMarkup" startspan ---->
<object ID="MediaPlayer" WIDTH="450" HEIGHT="345" CLASSID="CLSID:22D6f312-B0F6-11D0-94AB-0080C74C7E95" STANDBY="Loading Windows Media Player components..." TYPE="application/x-oleobject" CODEBASE="http://activex.microsoft.com/activex/controls/mplayer/en/nsmp2inf.cab#Version=6,4,7,1112">

<param name="autoStart" value="True">
<param name="filename" value="http://karlerik39.no-ip.org:1755">
<param NAME="ShowControls" VALUE="False">
<param NAME="ShowStatusBar" VALUE="False">
<embed TYPE="application/x-mplayer2" SRC="http://karlerik39.no-ip.org:1755" NAME="MediaPlayer" WIDTH="450" HEIGHT="345" autostart="1" showcontrols="0"></embed></object>
<!-- webbot bot="HTMLMarkup" endspan ---->
<!--- end PLAYER --->

Med vänlig hälsning

 

/Kalle

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×
×
  • Skapa nytt...