Just nu i M3-nätverket
Jump to content

Index och passa


Tom Düring

Recommended Posts

Hej,

Har kört fast totalt med följande formel:

 

=OM(ÄRSAKNAD(PASSA($E72;SOC_KSKATT!$A1:$O1;0));0;INDEX(SOC_KSKATT!A20:O20;PASSA($E72;SOC_KSKATT!$A1:$O1;0);1))

 

Under fliken "Soc_Kskatt" används  kolumnerna  A t.o.m. O. På rad 1 finns en unik benämning på varje kolumn fr.o.m. "D" som heter "Man_1";  kol E heter således "Man_2" o.s.v. t.o.m. Man_12.

 

När jag knackar in "Man_1" i ruta E72 så vill jag att formeln skall returnera ett värde som ligger i kolumn D från rad 20.under fliken Soc_Kskatt i den ruta som formeln är placerad.

 

Tacksam för all hjälp jag kan få.

 

//T

Link to comment
Share on other sites

ja, du då får vi skriva på lite annat vis.

Grundformeln blir

=INDEX(A1:C5;PASSA(F5;INDEX(A1:C5;;PASSA(F4;A1:C1;0));0);PASSA(F4;A1:C1;0))

 

Där du har i

A1:C5 din tabell.

F5 namnet på den post/den rad du vill hitta

F4 namnet på den kolumn du vill hitta.

 

PASSA(F4;A1:C1;0)

letar reda på rätt kolumn.

INDEX(A1:C5;;PASSA(F4;A1:C1;0))

returnerar en referens till den kolumnen (inom den referens som givits, A1:C5)

PASSA söker sedan i den referensen efter rätt rad.

Link to comment
Share on other sites

Hej!

tack för hjälpen, har kommit ett bra stycke på väg men det saknas ännu lite. Bifogar en fil med mina försök.

Observera att in- och utresultatet på kommer att ligga på en annan flik i verkligheten och alltså inte på samma flik som tabellen.

 

Tacksam för all hjälp jag kan få. Har lärt mig mycket denna väg om excel.

 

//T

Link to comment
Share on other sites

Ingen fil... om makron i den (helst inte) måste du zippa den för att Eforum ska gilla den.

 

Spelar ingen roll om tabellen du söker i ligger i annan flik eller ej. När jag skapar ett exempel är det mycket enklare att hålla mig på ett blad, blir kortare formler.

Bara att ändra referenserna så att de pekar på rätt område så ska det fungera för dig hoppas jag.

Link to comment
Share on other sites

test soc_Kskatt.xlsx

Ingen fil... om makron i den (helst inte) måste du zippa den för att Eforum ska gilla den.

 

Spelar ingen roll om tabellen du söker i ligger i annan flik eller ej. När jag skapar ett exempel är det mycket enklare att hålla mig på ett blad, blir kortare formler.

Bara att ändra referenserna så att de pekar på rätt område så ska det fungera för dig hoppas jag.

 

Hoppas att det fungerar nu.

//t

Link to comment
Share on other sites

Jaha, var det så du menade....

=INDEX(A4:O9;2;PASSA(G12;A4:O4;0))

Trodde du skulle söka efter värde i den kolumn du hittade.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...