Just nu i M3-nätverket
Jump to content

Android x86 bootar inte korrekt


Kranis-97

Recommended Posts

Efter ett flertal försök har jag lyckats installera Android-x86 4.3 på en PC (DELL Latitude D600). Dock finns nu ett ganska start problem. När jag startar datorn poppar GRUB Boot Manager upp. Jag väljer då att på vanligt sätt starta Android-x86. Det visas då lite info på skärmen bl.a. Booting kernel... Detecting Android... found at /dev/sda1. Sedan står det ANDROID, i ren text inte grafiskt. Därefter står det root@x86:/ # som om jag skulle hamnat i en terminal, inte långt senare rensas skärmen och endast ett vitt streck blinkar. Testar bara att skriva ett enkelt kommando som ls, och den listar alla mappar på root. Några få sekunder senare rensas skärmen och den blir tom igen. Längre en så här kommer den inte.

 

Jag har testat att köra alla debug alternativ som man kan välja vid Grub. Dock kommer inte uppstarten något mycket längre för det, och informationen som visas säger inte mig särskilt mycket. Jag har också testat starta Android från Live-CD:n, gick inte bättre där. Det konstiga är att jag har för mig att jag på samma dator tidigare, från samma skiva, testat att köra Android och att det har fungerat.

 

Är det någon som har någon aning om hur jag kan få igång det?? :unsure:

Link to comment
Share on other sites

Är det denna?

android-x86-4.3-20130725.iso

 

Tänkte testa jag med men det är ju dumt om jag prövar med en annan ISO..

Ja det är samma ISO som jag använder. Jag fick dock problem med det medföljande partionsverktyget på skivan, så jag partionerade disken först med GParted.

Link to comment
Share on other sites

Okej, jag har bara testat i VMware Player och där bootar det upp som det ska.

Ska, senare, testa att lägga över detta på ett USB-minne.

Link to comment
Share on other sites

 

 

Jag har också testat starta Android från Live-CD:n, gick inte bättre där. Det konstiga är att jag har för mig att jag på samma dator tidigare, från samma skiva, testat att köra Android och att det har fungerat.

 

Kom på en sak ang. ovanstående:

Är du säker på att det verkligen är LiveCD,n som bootar när du testar detta igen?

Link to comment
Share on other sites

Kom på en sak ang. ovanstående:

Är du säker på att det verkligen är LiveCD,n som bootar när du testar detta igen?

Ja, jag är säker.

Link to comment
Share on other sites

När man hamnar i detta läge i Windowsmiljö kan det ju bero på USB-anslutna enheter.. testat att plocka bort allt sådant?

Link to comment
Share on other sites

När man hamnar i detta läge i Windowsmiljö kan det ju bero på USB-anslutna enheter.. testat att plocka bort allt sådant?

Har inga USB-enheter anslutana, endast nätadapter ansluten

Link to comment
Share on other sites

För väl inte ämnet framåt men när jag testar att boota på ett USB-minne så fungerar det inget vidare. Ska testa lite andra vägar..

Link to comment
Share on other sites

Så. Med hjälp av Rufus (för att lägga över på USB) gick det bättre. Måste välja läge "VESA" för att det ska fungera men sedan rullar det på. Skriver från webbläsaren i Android nu.

Detta är ju också klen tröst när det inte fungerar för dig men kan det vara två av varandra oberoende felorsaker att det varken fungerar med LiveCD eller från HDD?

Kanske börja om, och likt mig åter skapa en USB att boota med? Bara för att se...

Link to comment
Share on other sites

Hm.. men när det fungerade på just den datorn, var det också exakt samma ISO?

Eller en äldre?

Tänkte att om det fungerar med en äldre men inte en nyare kanske man kan klura ut vad som skiljer?

 

Ex. så fungerar inte Linux Mint 15 på alla datorer där Linux Mint 13 körs..

Link to comment
Share on other sites

Hm.. men när det fungerade på just den datorn, var det också exakt samma ISO?

Eller en äldre?

Tänkte att om det fungerar med en äldre men inte en nyare kanske man kan klura ut vad som skiljer?

 

Ex. så fungerar inte Linux Mint 15 på alla datorer där Linux Mint 13 körs..

Det är samma iso jag hela tiden använt. Kommer inte ihåg exakt när, kanske slutet av sommaren. Antingen får jag väl testa med en gammal iso eller installera något annat os på den.

Link to comment
Share on other sites

 

 

eller installera något annat os på den

 

Får man fråga vad tanken är med detta? Bara för att se om det funkar eller något speciellt?

Link to comment
Share on other sites

Får man fråga vad tanken är med detta? Bara för att se om det funkar eller något speciellt?

Just denna dator har tidigare använts som "resedator". Nu när den ersatts av en nyare burk och rensats tänkte jag använda denna lite som "experimentdator" eller liknande. Såg det som lite kul att köra Android på den, men då jag inte får igång det lägger jag nog in någon Linux-dist.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...