Just nu i M3-nätverket
Gå till innehåll
DePhaz

Funderingar om Debian - Kan inte intstallera starthanterare (Vet felet)

Rekommendera Poster

DePhaz
Postad (redigerade)

Jag har säkert missat något viktigt här men jag tycker hur som hels att det hela är märkligt. Här en tillbakablick:

 

Det finns många olika operativsystem och jag tänkte att efter Ubuntu och Mint så kanske man skulle testa Debian. Sagt och gjort, jag laddade ner Debian 7.0 (Wheezy) från Debian.org och efter en stund lyckades jag få den på USB sticka med Unetbootin. Startade så och tyckte att det såg väl OK ut. Hade en gammal hårddisk liggande och tänkte att jag lägger väl in operativsystemet på den. På disken fanns ett icke bootbart windows men skulle (enligt "Disc utility" under Mint) vara OK sånär som på en skadad sektor. Detta skrämde inte mig, körde första Ubuntu installationen på en disk med 190 skadade sektorer och det fungerade bra. Och 20 GB skulle tydligen räcka till.

 

Men, jag kunde inte installera innifrån Debian utan fick starta om. Valde "graphical install" och fick upp en 4 färgs installation som var tydlig. Allt gick bra tills Starthanteraren Grub skulle installeras. Det blev tvärstopp på 50%. OK, tänkte jag, jag kanske skulle koppla disken direkt och inte via HDD docka. Men inte heller en korrekt koppling fungerade. Satarthanteraren Grub gick inte att installera till mer än 50%.

 

Det gick ett par dagar och sedan brände jag ISO filens inehåll på DVD (+RW) skiva. Nytt försök med installationen. Nu blev installationen mycket snyggare men tog slut på exakt samma ställe som de föregående försöken. Starthanteraren Grub gick inte att installera. Inte heller Satarthanteraren Lilo gick att installera men installationen av systemet slutfördes. Men nu kan jag ju inte starta Debian.

 

Vad är problemet här? Starthanterare ska väl ändå ingå i ISO'n? Letade runt och såg att det fanns skivor att köpa på LinuxShopen.nu men deras hemsida fungerar inte. Skrot. Har sagt upp mitt fasta internet och ladda ner över 500MB trådlöst känns inte så lockande. Så om det finns en möjlighet att komma vidare med det matiel jag så är det ju en fördel. Detta är inget som direkt brådskar men det är intressant. Tips mottages varmt.

Redigerad av DePhaz

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
fagerja

Det kan vara den skadade sektorn som hindrar att Grub-installationen. Disktillverkarens diagnosprogram kan ersätta skadade sektorer med reservsektorer. Bootloaderkoden måste ligga på ett bestämt ställe på disken för annars hittar inte BIOS den.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
DePhaz

Verkligen? Det visste inte jag. Trodde bara att installationsprogrammet hoppade över trasiga sektorer men jag är inte så insatt. Nå, då kanske jag får skaffa en ny disk istället. Tack för informationen. (Det var i så fall därför som windows inte heller gick att starta).

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
jannejanne

Hade du endast en hårddisk i datorn => fel på hårddisken

Hade du mer än en hårddisk i datorn => Debian gillade inte vad du ville göra

Debian har höga krav på hårdvaran. Operativet ska kunna användas på servrar.

 

Så det förvånar mig inte ett smack det strulade för dig.

För det har det gjort för mig med Debian.

man måste (i varje fall då i slutet på 90-talet) göra allt som Debian tänkt sig...

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Mikael63

Finns ju annars en Debianversion av Linux Mint också.. (kör med den nu)

Löser ju dock inte problem med skadade sektorer,

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
DePhaz

Hade du endast en hårddisk i datorn => fel på hårddisken

Hade du mer än en hårddisk i datorn => Debian gillade inte vad du ville göra

Debian har höga krav på hårdvaran. Operativet ska kunna användas på servrar.

 

Så det förvånar mig inte ett smack det strulade för dig.

För det har det gjort för mig med Debian.

man måste (i varje fall då i slutet på 90-talet) göra allt som Debian tänkt sig...

 

Jo, så är det säkert, det känner du till bättre än jag. Nå, det var ett test att installera på denna hårddisk så jag får nöja mig med dessa svar. Lade in Ubuntu 10 för att se om den accepterade det och den installationen lyckades. Har dock inte kört systemet mer än en kort stund så jag vet inte om det är fler fel på den. Nå, det återstår att se. Tack för hjälpen.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×
×
  • Skapa nytt...