Just nu i M3-nätverket
Gå till innehåll
Martassen

Ibland fler slutparanteser?

Rekommendera Poster

Postad (redigerade)

Ibland tycker jag att formler i Excel saknar logik eller så är det jag som inte förstår:

Om man kapslar och kör 2 funktioner så ska formeln avslutas med 2 paranteser:

 

=OM(B13>C13;"Olle är bäst";OM(C13>B13;"Anna är bäst";"Lika bra"))

 

Här använder jag 2 funktioner men här används EJ dubbelparantes i slutet:

=OMFEL(LETARAD(A7;A14:B18;2;0);"Ej i listan”)

 

Här använder jag 2 funktioner och här används 2 paranteser i slutet:

=INITIAL(VÄNST(A29;5))

 

Här kör jag 2 vänster och här använder man inte 2 paranteser i slutet:

=VÄNSTER(A24;1)&" "&VÄNSTER(B24;1)

 

När använder man samma antal slutparanteser som funktioner i en formel och när använder man det inte?

 

 

En annan fråga:

Vad är logiken att det är citationstecken runt villkoret när man använder AntalOM?:

=ANTAL.OM(C4:C12;"<0")

 

Här har vi inga citationstecken förutom runt det som ska returneras:

=OM(B13>C13;"Olle är bäst"

Redigerad av Martassen

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Det är inte antalet slutparenteser som räknas utan antalet höger- respektive vänsterparenteser i formeln som måste ha lika antal, ovasett placeringen i formeln

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Precis som i vanliga språket. Öppnar du med en parentes måste du även stänga stänga med en parentes.

Inte svårare än

Antal högerparenteser == antalet vänsterparenteser.

 

Antal.om

Där har du citationstecken runt andra argumentet eftersom det är en sträng och inte rena nummer.

Du kan skriva

ANTAL.OM(A1:A10;1)

för att få ut celler med värdet ett

eller

ANTAL.OM(A1:A10;"=1")

för att definiera exakt vad du är ute efter.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Postad (redigerade)

Ok. Jag har alltid tänkt ju fler funktioner du blandar in i varandra desto fler paranteser i slutet. Antar att Om funkar så iallfall?

Funktionerna nedan har helt enkelt olika uppbyggnad?

 

Formel1:

formeln har 2 vänsterparanteser som ni sa och därför 2 i slutet.

=OM(B13>C13;"Olle är bäst";OM(C13>B13;"Anna är bäst";"Lika bra"))

 

Formel2:

Här sluter vi letarad innan "Ej i lista" och därför inga dubbla paranteser?

=OMFEL(LETARAD(A7;A14:B18;2;0);"Ej i listan”)

 

Formel3

Här kör man 2 vänster som sluts och slås ihop:

=VÄNSTER(A24;1)&" "&VÄNSTER(B24;1)

 

Formel3

=INITIAL(VÄNST(A29;5))

Redigerad av Martassen

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Martassen, om du räknar antalet höger- resp vänsterparenteser ser du att det stämmer.

 

Om du ställer dig formelfältet färgar Excel snällt parenteserna och indikerar vilka som hör ihop.

Inget konstigt alls egentligen.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×
×
  • Skapa nytt...