Just nu i M3-nätverket
Gå till innehåll
Mikael63

[löst] Lång tid stänga av + avstängt ljud

Rekommendera Poster

Mikael63
Postad (redigerade)

När jag hade Linux Mint 11 tog det sex sekunder från det att jag valde "Stäng av" tills dess att datorn "slocknade" helt.

 

Nu med Linux Mint 14 tar det betydligt längre tid.

Gör ju egentligen inget men är nyfiken på om detta är något man kan justera? Alltså tiden?

 

Det är som att det hela väntar en stund enligt bild post-52940-0-46659600-1357250143_thumb.jpg

 

Texten visar ju login, inte logout. Är detta något läge där man så att säga har chansen att ångra sig och logga in igen?

 

Fyller på med en undran som rör ljud, eller snarare volym.

I en annan Linuxburk (med LMDE) så är ljudet alltid avstängt vid omstart. Var sparar man inställningarna för detta?

Redigerad av Mikael63

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
NoWin

Förmodligen har du några processer aktiva som tar tid att ta ner. Kan tex vara NFS-monterade diskar med RPC-strul pga fel i /etc/fstab. Har för mig att async/sync i /etc/fstab kan påverka, men inte helt säker

 

När det gäller LMDE så var det likadant för mig, jag såg inte det som ett problem, tangetbordsknappen för ljud på/av fungerade så det var bara att slå på ljudet.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
fagerja

Det är ett läge där du kan ångra avstängningen. En orsak till att tiden för avstängningen förlängts kan vara att säkerställa att hårddiskarna hinner skriva färdigt före strömmen bryts. Modärna hårddiskar har en stor cache så det kan ta en stund innan allt är skrivet till disken. Disken meddelar inte OS:et när den skrivit klart utan bara att ordern och datat är mottaget.

Ljudinställningen sparas i min distribution (Mageia 2) i filen /usr/share/alsa/init/default.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Mikael63

Förmodligen har du några processer aktiva som tar tid att ta ner. Kan tex vara NFS-monterade diskar med RPC-strul pga fel i /etc/fstab. Har för mig att async/sync i /etc/fstab kan påverka, men inte helt säker

 

När det gäller LMDE så var det likadant för mig, jag såg inte det som ett problem, tangetbordsknappen för ljud på/av fungerade så det var bara att slå på ljudet.

 

Ska kolla om det blir skillnad med monterade diskar eller ej.

 

Ljudet - nä inget problem egentligen, annat än om man vill ha inloggningsljud. Mest handlar det om att lära mig.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Mikael63

Det är ett läge där du kan ångra avstängningen. En orsak till att tiden för avstängningen förlängts kan vara att säkerställa att hårddiskarna hinner skriva färdigt före strömmen bryts. Modärna hårddiskar har en stor cache så det kan ta en stund innan allt är skrivet till disken. Disken meddelar inte OS:et när den skrivit klart utan bara att ordern och datat är mottaget.

Ljudinställningen sparas i min distribution (Mageia 2) i filen /usr/share/alsa/init/default.

 

Nu blir jag ju osäker på om detta har att göra med att Windowsdisken är bytt, att denna "långa" tid uppstod även i Mint 11, efter diskbytet.

 

Mint 14 ligger också på en annan disk än den som Mint 11 låg på men dessa båda ska vara av samma typ.

 

Jodå, jag har en default i samma sökväg.

I den står bl.a. "Default ALSA volume levels and setting when initialization database fails."

 

Om det inte "failar" - var hämtas inställningarna ifrån då tro?

I samma sökväg finns en 00main:

# This is toplevel configuration for for 'alsactl init'.
# See 'man alsactl_init' for syntax.

# set root device directory in sysfs for soundcard for ATTR{} command
CONFIG{sysfs_device}="/class/sound/card$cardinfo{card}/device"
ACCESS!="$sysfsroot$config{sysfs_device}", \
CONFIG{sysfs_device}="/class/sound/controlC$cardinfo{card}/device"

# test for extra commands
ENV{CMD}=="help", INCLUDE="help", GOTO="00main_end"
ENV{CMD}=="info", INCLUDE="info", GOTO="00main_end"
ENV{CMD}=="default", INCLUDE="default", GOTO="00main_end"
ENV{CMD}=="test", INCLUDE="test", GOTO="00main_end"
ENV{CMD}=="*", ERROR="Unknown command '$env{CMD}'\n", GOTO="00main_end"

# include files with real configuration
#
# steps are:
#   1) look for preinit subdirectory and parse all files in it
#   2) if RESULT=="skip", skip ALSA standard configuration files
#   3) do ALSA standard configuration
#   4) look for postinit subdirectory and parse all files in it
#   5) if RESULT!="true", initialize hardware using a guess method,
#      print an error message and return with exit code 99
#   6) return with exit code 0 (success)
#

RESULT="unknown"
ACCESS=="preinit", INCLUDE="preinit"
RESULT=="skip", GOTO="init_end"

# real ALSA configuration database
CARDINFO{driver}=="HDA-Intel", INCLUDE="hda", GOTO="init_end"
CARDINFO{driver}=="CA0106", INCLUDE="ca0106", GOTO="init_end"
CARDINFO{driver}=="Test", INCLUDE="test", GOTO="init_end"

LABEL="init_end"
ACCESS=="postinit", INCLUDE="postinit"
RESULT=="true", GOTO="00_mainend"
ERROR="Found hardware: \"$cardinfo{driver}\" \"$cardinfo{mixername}\" \"$cardinfo{components}\" \"$attr{subsystem_vendor}\" \"$attr{subsystem_device}\"\n"
ERROR="Hardware is initialized using a generic method\n"
INCLUDE="default"
EXIT="99"

#
# label identifying end of main file
#

LABEL="00main_end"

 

Det finns även en hda:

# Configuration for HDA Intel driver (High Definition Audio - Azalia)

CARDINFO{mixername}=="Realtek ALC880", \
 ATTR{subsystem_vendor}=="0x1025", ATTR{subsystem_device}=="0x0070", \
 GOTO="Acer Travelmate 8100"
CARDINFO{mixername}=="Analog Devices AD1984", \
 ATTR{subsystem_vendor}=="0x17aa", ATTR{subsystem_device}=="0x20ac", \
 GOTO="Lenovo T61"
RESULT="false", EXIT="return"

LABEL="Acer Travelmate 8100"
# playback
CTL{reset}="mixer"
CTL{name}="Master Playback Volume", CTL{value}="-21dB"
CTL{name}="Master Playback Switch", CTL{value}="on"
CTL{name}="Headphone Playback Switch", CTL{value}="on,on"
CTL{name}="Front Playback Volume", CTL{value}="-29dB,-29dB"
CTL{name}="Front Playback Switch", CTL{value}="on,on"
CTL{name}="PCM Playback Volume", CTL{value}="0dB,0dB"
# capture
CTL{name}="Input Source", CTL{value}="Mic"
CTL{name}="Capture Volume", CTL{value}="20dB,20dB"
CTL{name}="Capture Switch", CTL{value}="on,on"
RESULT="true", EXIT="return"

LABEL="Lenovo T61"
# playback
CTL{reset}="mixer"
CTL{name}="Master Playback Volume", CTL{value}="-13.5dB"
CTL{name}="Master Playback Switch", CTL{value}="on"
CTL{name}="Headphone Playback Switch", CTL{value}="on,on"
CTL{name}="Speaker Playback Switch", CTL{value}="on,on"
CTL{name}="PCM Playback Volume", CTL{value}="0dB,0dB"
# capture
CTL{name}="Input Source", CTL{value}="Internal Mic"
CTL{name}="Internal Mic Boost", CTL{value}="1"
CTL{name}="Capture Volume", CTL{value}="9dB,9dB"
CTL{name}="Capture Switch", CTL{value}="on,on"
RESULT="true", EXIT="return"

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Mikael63

Mer fakta i fallet med avstängningen:

 

De förra diskarna (Raid 0) hade 8 MB Cache och den nya 16 MB.

Borde väl inte orsaka 42 sekunders längre avstängning?

 

Samma tid med omonterade enheter.

 

Tiden enligt bild ca 34 sekunder.

Denna tid torde väl vara inställbar någonstans?

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Flyfisherman

Intressant och jag kan meddela att detta fenomen även uppträder på Mint 13 laptopen.

Tycker av någon anledning också att tiden ökat för att göra en avstängning jmfrt. med när systemet var relativt nyinstallerat, möjligen beroende på nån uppgradering eller annat?

 

Texten visar ju login...

Ja precis samma här och denna kan jag inte komma på att den dök upp förr.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Mikael63
Ja precis samma här och denna kan jag inte komma på att den dök upp förr.

Kan ju ha funnits men att den visades så kort tid att man inte hann med att läsa..

 

Detta är ju inget större problem egentligen men liksom ljudbekymret vill jag lära mig.

Har man bråttom iväg någonstans och vill stoppa ner den bärbara i en väska vill man ju vara säker på att den är avstängd för att inte bli överhettad..

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
fagerja

Tryck på ESC-tangenten genast efter att du påbörjat avstängningen. Då visas vad som sker på skärmen i textläge. Fungerar även under uppstart. Även filen /var/log/messages kan innehålla intressant data. Avslutar du alla program före avstängning? I katalogen /etc/rc0.d ser du länkar till vilka skript och tjänster, som körs vid avstängning och i vilken ordning. Ordningen avgörs av numret. K betyder att tjänsten avslutas och S att den startas/körs. Skripten finns i /etc/init.d (skriptspråket är bash). Du kan vinna någon sekund genom att ta bort de som gäller tjänster som inte är installerade (t.ex. apache). Spara vilka ändringar du gjort och skripten i en katalog (lämpligen under /root/) så att du vid behov kan återställa. Motsvarande skript för andra körnivåer finns i /etc/rcN.d där N är siffran för körnivå. 0=avstängning, 1=felsäkert läge, 2=multiuser utan nät, 3= multiuser med nät, 4 eller 5= GUI eller användardefinerad (varierar mellan olika distributioner) och 6=reboot. Du kan byta körnivå som root med kommandot init körnivå.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Flyfisherman

Det en sak ang. väntetiderna som jag funderade på och det är att inte bara avstängningen numera tar avsevärt längre tid, utan även uppstart av systemet.

 

En tanke som slog mig nu; undrar om inte jag tycks minnas att detta blev mer märkbart efter installationen av Kaspersky Endpoint Security 8?

 

Jag kan iof. leva med detta på min gamla laptop, man får helt enkelt ha lite tålamod, men visst helt klart tar det betydligt längre tid att stänga av och starta upp datorn nu än tidigare - rejält längre tid.

 

Är det något som kan vara lika mellan våra maskiner så kanske det är detta som spökar?

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Mikael63

Jag har ingen /var/log/messages men en /var/log/syslog vars enda rader kring tidpunkt för avstängning är:

[log]Jan 4 18:09:41 mint-Dell-DXP051 kernel: Kernel logging (proc) stopped. Jan 4 18:09:41 mint-Dell-DXP051 rsyslogd: [origin software=rsyslogd" swVersion="5.8.6" x-pid="650" x-info="http://www.rsyslog.com] exiting on signal 15.[/log]

 

rc0.d

post-52940-0-55633100-1357321126_thumb.png

 

Har inte lyckats trycka på ESC i rätt läge, får inte fram någon text.

 

Ja Kaspersky Endpoint Security 8 kan vara gemensam faktor. Har den i aktuell dator men hade inte det i Mint 11 och inte i en annan dator med Mint 14 där avstängningstiden är ca 12 sekunder.

I en dator med LMDE och utan Kaspersky är tiden ca 10 sekunder.

 

Om det nu är Kaspersky som är "boven" kan jag också leva med det, då har jag ju en "giltig" förklaring.

Men det skulle vara "kul" om man kunde se detta på något vis(?)

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
fagerja

Du kan försöka med att stänga av som root från en virtuell terminal i textläge. Då borde visas vad som pågår. Du kommer till en virtuell terminal med tangentkombinationen: ALT + CTRL + Fx där x=1 - 6 för CLI och 7 -12 för GUI. VT1 är normalt upptagen av X-servern. GUI körs normalt på VT7. Logga in som root på VT2 eller VT3. Med kommandot sudo su -blir du äkta root utan att ha rootlösenord satt. Kör sedan kommandot: shutdown -h 0. Du och andra användare kan vara inloggad på flera virtuella terminaler samtidigt.

Själv har jag både /var/log/syslog och /var/log/message. De innehåller delvis samma information. Messages är mera omfattande. Vad som loggas styrs av filen /etc/syslog.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Mikael63

Hm..

Om jag använder Alt + CTRL + F2 uppmanas jag skriva användarnamn och lösen, vilket jag gör, och

därefter skriver jag sudo su så uppmanas jag ange lösenord, vilket jag gör.

Om jag då skriver shutdown -h 0 så sker exakt samma som enligt första inlägget. Varken mer eller mindre.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Mikael63
I stället för

shutdown -h 0

shutdown -h now

Vad händer då?

Precis samma sak.

Datorn stängs av efter att det sett ut som på bilden i inlägg #1

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Anaeorob
Postad (redigerade)

Ljudet låter som att alsaconf buggar på något sätt

 

prova alsamixer som root / su

avsluta programmet med Esc knappen

 

----

 

Dina andra inställningar bör ligga i Inittaben eller

/etc/init.d

 

Är inte säker dock men det är det min dist använder...

Redigerad av Anaeorob

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Mikael63

Lång avstängningstid = Kaspersky Endpoint Security 8.

Testade att avinstallera och då sker hela nerstängningen på ca 10 sekunder.

Om det är något fel ändå eller om det körs någon kontroll vid avstängning vet jag inte men nu vet jag vad orsaken är.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Mikael63
Postad (redigerade)

Ljud = Fixade detta genom att i Uppstartprogram lägga till amixer -c 0 -- sset Master playback -4dB

 

Vet dock inte än om inloggningsljudet funkar men det kan kvitta..

Edit: lade till ljud också, i Uppstartshanteraren

Redigerad av Mikael63

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Flyfisherman

Lång avstängningstid = Kaspersky Endpoint Security 8.

Testade att avinstallera och då sker hela nerstängningen på ca 10 sekunder.

Om det är något fel ändå eller om det körs någon kontroll vid avstängning vet jag inte men nu vet jag vad orsaken är.

Den biten var bra att få verifierad och då stämde ju mina misstankar.B)

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×
×
  • Skapa nytt...