Just nu i M3-nätverket
Gå till innehåll
Mikael63

Ansluta till en NAS med bara lösenord

Rekommendera Poster

Mikael63

Har tillgång till en (Netgear Ready)NAS som har en del "share" som använder den "lägsta" säkerhetsprincipen med bara ett lösenord.

På datorer med XP går det bra att ansluta till dessa via ex. Utforskarens Anslut Nätverksenhet.

På datorer med Vista/W7 fungerar inte det utan man får då använda NET USE.

Raden kan se ut så här: NET USE U: \\10.160.106.202\migr lösenord

Detta fungerar alltså bra.

 

När jag så vill ansluta med en Linuxdator så går det bra att komma åt några "slask-share" utan lösen men försöker jag ansluta mot en "share" med lösen måste jag fylla i en dialogruta som kräver inmatning i alla fält, likt Vista/W7.

 

post-52940-0-52073900-1353453812_thumb.png

 

Hur kan jag kringgå detta i Linuxmiljön?

Finns det något tecken som ignoreras och som jag kan använda i de två fälten som ska vara tomma?

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Mikael63

"borde"??

 

Jag vill inte ansluta till den NAS,en automatiskt då jag bara behöver komma åt den ca 1 gång i månaden, som max, och då via en VPN-tunnel.

 

Om man googlar ser man att fler är intresserad av motsvarigheten till NET USE i Linux men alla får svar på något annat än det spm efterfrågats.. :angry:

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Mikael63

Googlande gav resultatet att jag skulle installera paketet smbclient.

När jag så körde kommandot smbclient \\\\10.160.106.202\\migr fick jag felmeddelande som ledde till bl.a. denna http://lists.debian.org/debian-user/2012/01/msg00853.html

Efter lite pill i smb.conf (som jag trodde bara behövdes om man hade egna utdelningar) kommer jag nu aningen längre.

Nu står "bara" tree connect failed: NT_STATUS_WRONG_PASSWORD

 

Detta står även om jag lägger till lösenordet (som fungerar i Windows) med eller utan -N

 

Där är jag alltså nu..

Redigerad av Mikael63

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Mikael63

Hm.. lösenordet är satt med en webläsare i Windowsmiljö.

Är, lite ändrat: PC03006

Jag har möjlighet att ändra lösenordet (det är jag som satt det en gång i tiden)

 

Problemen med Vista/Windows7 har varit att själva dialogen (verkar det som) kräver ett användarnamn medan kommandot NET USE inte gör det.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Mikael63

Märkligt att Windows ska kunna "slå" Linux i denna fråga.. :thumbsdown:

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
fagerja

Märkligt att Windows ska kunna "slå" Linux i denna fråga.. :thumbsdown:

Varför använda Samba och inte nfs när du ansluter från Linux? http://en.wikipedia.org/wiki/Network_File_System För att komma åt en katalog måste den monteras. Det gäller både Windows och Linux. NET USE U: \\10.160.106.202\migr lösenord kommandot monterar katalogen på U:. Monteringen kan göras automatiskt eller manuellt i Linux. Enklast i Linux är att lägga in i /etc/fstab med optionen -noauto om du inte vill att katalogen monteras automatiskt vid uppstart. Ett annat bra och säkert alternativ är SFTP och SSHFS. https://help.ubuntu.com/community/SSHFS

Om du skall synkronisera NASen så är rsync lämpligast program.

 

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Mikael63

Jo, men frågan gäller ju hur man i Linux skriver motsvarande

NET USE U: \\10.160.106.202\migr lösenord

 

Om det så är i terminalen eller en skriptfil eller i /etc/fstab eller någon annanstans..

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
fagerja

För samba kan du använda antingen kommandot mount eller smbmount i terminalen. Kommandot kan läggas i ett skriptAnvänder du mount blir kommandot: sudo mount -t smbfs //10.160.106.202\migr /mnt/nas -o username=mikael63, dmask=777,\fmask=777 lösenord. Lägger du in utdelningen i /etc/fstab med optionerna noauto och user och räcker kommandot: mount /mnt/nas lösenord. /mnt/nas kan du naturligtvis ersätta med en annan katalog. För avmontering: umount /mnt/nas. Läs: man mount och man fstab

Men varför använda Samba för att dela ut en katalog i linux till en linuxklient? NASen har stöd för nfs. Samba är avsett för FAT och NTFS utdelningar i Windows till Linux och linux filsystem till windowsklienter.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Mikael63

Kommandot

sudo mount -t smbfs //10.160.106.202\migr /mnt/nas -o username=mikael63, dmask=777,\fmask=777 lösenord

fungerar inte i terminalen, det som händer i terminalen är samma som om jag bara skrivit mount

Jag byter ut lösenord mot det riktiga.

username=mikael63 vet jag inte vad jag ska ersätta med. Något användarnamn finns ju inte.

 

Men varför använda Samba för att dela ut en katalog i linux till en linuxklient? NASen har stöd för nfs. Samba är avsett för FAT och NTFS utdelningar i Windows till Linux och linux filsystem till windowsklienter.

NAS,en är ju som den är den. Det normala är att dess "sharer" är åtkomliga från Windowsdatorer.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
fagerja

Om det inte finns något användarnamn så skall det utelämnas. Får du något felmeddelande? Finns katalogen /mnt/nas? Om inte måste du ersätta den med en existerande katalog eller skapa den. Annars är det mycket möjligt att NASens utdelningar sker i både Samba och nfs. Även apple använder nfs som standard. I filen /etc/exports på NASen ser du vilka nfs-utdelningar finns. Filen är en vanlig textfil. En utdelning per rad. Se man exports. Filen läses in med kommandot: exportfs -r.

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Mikael63

Här har jag utelämnat användarnamn, men username= finns kvar.

 

mint@mint-LIFEBOOK-E751 ~ $ sudo mount -t smbfs //10.160.106.202\migr /mnt/nas -o username=, dmask=777,\fmask=777 PC06003

[sudo] password for mint:

Användning: mount -V : visa version

mount -h : visa denna hjälptext

mount : visa monterade filsystem

mount -l : samma, inklusive volymetiketter

Det var den informativa delen. Nu kommer vi till montering.

Kommandot är "mount [-t filsystemstyp] någonting här".

Detaljer som kan hittas i /etc/fstab kan utelämnas.

mount -a [-t|-O] ... : montera allt i /etc/fstab

mount enhet : montera enhet på den kända platsen

mount katalog : montera känd enhet här

mount -t typ enhet kat : vanligt monteringskommando

Observera att man egentligen inte monterar en enhet, utan ett

filsystem (av angiven typ) som finns på enheten.

Man kan också montera ett redan synligt katalogträd någon annanstans:

mount --bind gammalkatalog nykatalog

eller flytta ett underträd:

mount --move gammalkatalog nykatalog

Man kan ändra monteringstypen som innehåller katalogen "katalog":

mount --make-shared katalog

mount --make-slave katalog

mount --make-private katalog

mount --make-unbindable katalog

Man kan ändra typen för alla monteringarna i ett monteringsunderträd

som innehåller katalogen "katalog":

mount --make-rshared katalog

mount --make-rslave katalog

mount --make-rprivate katalog

mount --make-runbindable katalog

En enhet kan anges med namn, exempelvis /dev/hda1 eller /dev/cdrom,

eller med etikett, genom att använda -L etikett eller med uuid,

genom att använda -U uuid.

Andra flaggor: [-nfFrsvw] [-o flaggor] [-p lösenordfd].

Ange man 8 mount för ytterligare detaljer.

 

Jag får samma resultat om jag även tar bort username= och skriver

sudo mount -t smbfs //10.160.106.202\migr /mnt/nas -o , dmask=777,\fmask=777 PC06003

 

Ja, nu har jag skapat mappen nas i /mnt/

 

Loggade in via webbgränssnittet på NAS,en:

 

post-52940-0-86817200-1364555571_thumb.png

 

CIFS är valt.

FTP skulle ju kunna funka men... jag vill ju även lära mig detta, inte bara kringgå problemet..

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
fagerja

Felet kan ligga här: //10.160.106.202\migr. Ersätt \ med /. Förlåt att jag kopierade din sökväg direkt utan att kolla att den var i POSIX-format (/ och inte \ som avskiljare mellan kataloger).

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Mikael63

Ja, jag har testat även detta men det blir samma sak.

Tänkte försöka "sudda" från slutet för att få ev. felmeddelande och:

 

sudo mount -t smbfs //10.160.106.202/migr /mnt/nas

mount: okänd filsystemstyp "smbfs"

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Mikael63

Detta verkar fungera, fast jag får skriva lösen då.. ska testa vidare med dina optioner.

Måste avmontera på något sätt också..

 

mint@mint-LIFEBOOK-E751 ~ $ sudo mount -t cifs //10.160.106.202/migr /mnt/nas

Password:

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Mikael63

Torde vara löst nu :)

sudo mount -t cifs //10.160.106.202/migr /mnt/nas/migr -o password=PC06003

 

Ska försöka utöka skriptet med andra enheter också.

 

Stort tack!

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
fagerja

Avmonteringen sker med kommandot umount. Som parameter till umount anger du antingen enheten ( //10.160.106.202/migr /mnt/nas/migr) eller monteringspunkten /mnt/nas/migr. Lägger du in i /etc/fstab så räcker det med mount och enhet eller monteringspunkt.

Jag visste inte att Mint använder beteckningen cifs för Sambas filsystem. Många distributioner använder smbfs. Men det är samma filsystem och stöd för det ingår inte om man väljer bort Samba.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Mikael63

Okej, tack!

 

Jag hade klurat ut umount med //10. osv. men det kanske är säkrare med bara /mnt/nas osv ifall jag skulle tappa VPN-uppkopplingen?

Jag har valt att ha en skriptfil, på skrivbordet, med numera sex rader med enheter jag "mappar upp" samt en till där jag kan avmontera. Dessa har jag kopierat tll Dropbox mappen så att jag kan använda dessa oavsett dator (med Linux).

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Mikael63
Postad (redigerade)

Måste köra detta ytterligare...

Efter att ha fixat skript så att jag kunde montera en del enheter via VPN fixade jag ett annat skript som monterade några utdelningar på en egen hemmaserver (XPP).

Dessa skript, och "avmonteringsskript", kördes flera gånger och detta fungerade bra på en dator med Linux Mint 14.

När jag nu ska köra exakt samma skriptfiler på Linux Mint Debian Edition fungerar det inte lika bra.

Jag har samma sökvägar, har skapat katalogerna osv.

 

mint@gamla_jobbardatorn:~$ sudo -s

[sudo] password for mint:

root@gamla_jobbardatorn:/home/mint# mount -t cifs //192.168.1.11/Y_FILM /mnt/hemmaserver/Y_FILM -o password=

mount: wrong fs type, bad option, bad superblock on //192.168.1.11/Y_FILM,

missing codepage or helper program, or other error

(for several filesystems (e.g. nfs, cifs) you might

need a /sbin/mount.<type> helper program)

In some cases useful info is found in syslog - try

dmesg | tail or so

 

(mount via VPN fungerar inte heller)

Redigerad av Mikael63

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Mikael63

Hm.. testade på chans att installera cifs-utils och nu fungerar det igen.

Dock måste jag stänga brandväggen (eller klura ut en policy) för att det ska fungera via VPN-uppkopplingan..

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
fagerja
Postad (redigerade)

Antar att du mena Linux-datorns brandvägg.

iptables -I INPUT -s $REMOTE-IP -p TCP -j ACCEPT

iptables -I OUTPUT -d $REMOTE-IP -p TCP -j ACCEPT

De här kommandona öppnar för trafik med TCP från och till fjärrdatorn. Du skall ersätta variabeln $REMOTE-IP med fjärrdatorns IP-nummer eller definiera den i ett skript.

Om du vet vlka portar VPN använder kan du lägga in portnumrena: --sport xx --dport yy

Du kan ta bort reglerna genom att ersätta -I (insert) med -D (delete)-s betyder source och -d destination, -p betyder protokoll, -j betyder jump.

Redigerad av fagerja

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×
×
  • Skapa nytt...