Just nu i M3-nätverket
Gå till innehåll
pajjen

Hackig streamad film trots 30/30 Mbit!

Rekommendera Poster

pajjen

Jag har en 30/30 Mbit-anslutning till internet som verkar funka bra - utom när det gäller streamad film. Till exempel på YouTube och Svt Play blir uppspelningen frustrerande hackig.

 

Nu vore det kul att se lite OS i Svt Play, så jag har försökt lösa problemet, men utan att lyckas.

 

När jag kör standardtesten i TP-test så stoppar den med felmeddelande "2005" (se bifogad bild) när den ska ta emot UDP, så jag misstänker att det är här felet ligger, alltså att streamad film kanske sänds med UDP-protokoll.

 

Men hur får man i så fall sprutt på UDP-mottagningen? Har inte hittat något i Windows (XP SP3) som styr detta. Och brandväggen (F-Secure Internet Security 2011) har säkerhetsnivå "Normal", vilket väl inte borde strypa streamad film.

 

Är jag inne på fel spår?

post-42451-0-98032900-1343490085_thumb.gif

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Cecilia

Streamad film sänds med UDP mycket rikigt.

Hur går det på bredbandskollen.se?

Har det fungerat förut?

Har du annat igång som använder internet, t ex Spotify eller Voddler?

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
pajjen
Postad (redigerade)

Streamad film sänds med UDP mycket rikigt.

Okej, då är det väl UDP-mottagningen som är felet.

 

Hur går det på bredbandskollen.se?

Bredbandskollen visar inget separat resultat för TCP och UDP, men siffrorna jag får där är okej, i snitt drygt 30 Mbit/s in, och knappt 30 ut. (Lite lustigt dock att det är omvänt förhållande i TP-tests TCP-resultat, där går det snabbare att skicka än att ta emot.)

 

Har det fungerat förut?

Nej. De få gånger jag tidigare velat se streamad film under de ca två år jag haft nuvarande uppkoppling, så har det också varit hackigt. Jag är alltså ingen storkonsument av streamad film, så jag har inte brytt mig. Men nu vore det som sagt trevligt att se lite OS.

 

Har du annat igång som använder internet, t ex Spotify eller Voddler?

Nej, jag har inget annat igång som använder internet, bara FireFox med ca åtta flikar med "statiska" webbsidor.

Redigerad av pajjen

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
pajjen

Kan också nämna att jag har kört TCP Optimizer, som trimmar registerposter för bättre sprutt på internet, men nix, det blev inte bättre.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
pajjen

Se om detta hjälper: https://www.flashback.org/t461073 inlägg 5

Tack för tipset Cecilia!

 

Visserligen känns det något långsökt att en inställning på nätverkskortet skulle kunna påverka bara UDP-mottagningen, men jag har testat:

 

"100Base Tx Full Duplex" = Ingen skillnad.

"1000Base T Full Duplex" = Går ej att komma ut på nätet alls!

 

("Auto-Negotiation" var default, och är nu återställd till det.)

post-42451-0-44178100-1344098084_thumb.gif

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Cecilia

Se vad som händer när du väljer någon av de två "Half Duplex" eftersom det ju står i länken:

"Ändra nu denna till 100 MB-Full Duplex, Detta kan dock krångla ifall man har ett dålig nätverkskort, testa annars 100MB-Half Duplex".

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
pajjen

Har nu testat de övriga tre anslutningstyperna. Det blev ingen förbättring, men försämring vid 10Base-varianterna, de begränsar hastigheten till under 10 Mbit/s.

 

Intressanta saker hände dock när jag testade "enbart sändning" och "enbart mottagning". De visar att UDP-testen ballar ur vid PÅGÅENDE riktning (in eller ut), inte vid försök att starta nästa/motsatt riktning.

 

Att TP-test trots detta visar ett resultat för pågående riktning när den precis ser ut att vara avslutad, fick mig förstås att tro att den ballar ur vid start av nästa riktning, när jag testade både sändning och mottagning i samma test (någon som fattar vad jag skriver?).

 

Slutsats: UDP funkar både in och ut, men klarar inte alla de hastighetsnivåer som ingår i varje riktnings test. Riktig slutsats?

post-42451-0-23865800-1344286270_thumb.gif

post-42451-0-51876800-1344286286_thumb.gif

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Cecilia

Det låter nog mest som att det är programmet som inte fungerar bra, dels är 3.1 en mycket gammal version och det har kommit ett antal nyare, se http://www.bredbandskollen.se/tptest.php?sektion=1

och dels verkar programmet välja en för stor paketstorlek, se http://www.bredbandskollen.se/tptest.php?sektion=3 avsnitt 5.2.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
pajjen

Tack Cecilia!

 

Okej, jag ska testa en senare version, men jag har läst nånstans att 3.12 (som jag har) är den senaste som funkar korrekt i ett så "uråldrigt" OS som XP - men kombinationen 3.12 och 30/30-anslutning kanske är mindre lyckad. Ska också kolla närmare på paketstorlekar.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Cecilia

Okej, 3.12 är ju en annan sak, men pröva med 5.02 för säkerhets skull.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
pajjen

Oj,oj, det här har blivit en segdragen historia nu, som jag tyvärr bara har tid att ägna mig åt ibland, men så här är läget:

 

Jag har testat "allt". Vilket bland annat visat att jag har långa svarstider (uppåt 300 ms). Min bredbandsleverantör tror det är orsaken till att streamad film hackar.

 

Nu har jag kört PingPlotter och skickat resultaten till bredbandsleverantören för utvärdering. Så nu väntar jag på den utvärderingen. Svarstiden via mejl från bredbandsleverantören brukar vara ca 518400000 ms :-o

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
pajjen

Svaret från bredbandsleverantören har äntligen kommit:

 

"Hej!

Vår teknikavdelning kan ej hitta något relaterat till ert problem.

Vänligen meddela oss om problem kvarstår.

Ha en bra dag!"

 

Ja, jättebra dag, tack, tack! Ärligt talat så orkar jag snart inte bry mig i det här längre.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Cecilia

Har du möjlighet att pröva med en annan dator på din bredbandsanslutning (t ex en kompis) för att utesluta att det är problem i din dator?

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Cecilia

Jag ser i din andra tråd att du har F-secure. Du skulle ju temporärt kunna avinstallera det för att bli säker på att det inte är någon inställning i dess brandvägg som ställer till det.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
pajjen

Tack Cecilia för din välvilja att fortsätta ge råd!

 

Dock har jag lagt ner allt trixande med detta tillsvidare. Jag har inte tid - och det är ju faktiskt fyra år till nästa sommar-OS ;-)

 

Förövrigt har bredbandsleverantören - efter att jag ställt mig frågande till deras knapphändiga standardsvar (det jag citerade i mitt förra inlägg) - kommit med nytt svar. Och jag har svarat på det osv. Allt citerat nedan, om någon vill/orkar läsa.

 

 

Bredbandsleverantörens nya svar:

"Hej,

Jag får be om ursäkt om det senaste mailet du fick var lite otydligt.

Jag kollade själv på de pingplotterfiler du skickade och de visar absolut inga långa svarstider, utan tvärt om visar dom extremt låga (1-3ms) svarstider. Normalt ligger man på det tiodubbla och kör du t.ex. mobilt bredband kan svarstiderna vara flera 100ms, utan att det påverkar en videoström. 100ms är fortfarande bara en tiondels sekund, så det handlar mer om bandbredd när man strömmar film.

 

Pingplottrarna visar heller inga sporadiska avbrott utan stabiliteten är också bra.

 

Jag ser även att du tidigare gjort hastighetsmätningar som visade stabil och bra hastighet.

 

Vi kan inte hitta något som tyder på att felet ligger i nätet. Har du testat med någon annan dator, för att utesluta problem där?

 

Med vänlig hälsning ..."

 

 

Mitt svar:

"Hej, och tack för ett seriöst svar!

 

Har inte testat med någon annan dator, men ska försöka ordna det. Innan dess vore jag tacksam för svar på några frågor:

 

1. Jag tolkar ditt svar som att min uppkoppling inte kan vara orsaken till att streamad film hackar. Korrekt?

 

2. Är det Pingplotter-resultatet man ska förlita sig på, och inte Bredbandskollens (som visar ca 100 gånger längre svarstider!)?

 

3. Någon idé om var jag ska felsöka för att få flyt på streamad film?

 

Bifogar Bredbandskollens resultat igen.

 

 

Vänligen, ..."

 

 

Bredbandsleverantörens svar:

"Hej,

1. I det mätningar vi kunnat göra så är det ingenting som tyder på att det är bredbandet.

 

2. Pingplotter gör ju en mätning mot just den sidan du har problem med, och visar då din verkliga svarstid mot just det målet. Det är också ett program designat just för ändamålet, så det bör rimligtvis vara mer exakt.

Bredbandskollen gör en mätning mot en testserver och visar ju egentligen ingenting om hur det fungerar 'på riktigt', det är mest en uppskattning. Det är dessutom främst ett hastighetstest, även om de även visar svarstiden sedan ett par år. Just bredbandskollens test har också visat sig var extremt känsligt beroende på webbläsare. Ibland kan man få höga svarstider och låga hastigheter i en webbläsare, och bra i en annan.

 

Med det sagt skall 300ms inte heller vara något problem för strömmad film så det borde inte vara orsaken hur som.

 

3. Det är svårt att ge några generella råd. Man får undersöka del för del, och se vilket det är som strular. Personligen hade mitt nästa steg vara att testa en annan dator. Då utesluter man allt från webbläsare, till krånglande plugin, till dåliga nätverksdrivrutiner och byter man även kabel så har man i princip uteslutit allt man behöver. Funkar det då kan man gå tillbaka till den strulande datorn och kolla del för del tills man hittar problemet.

 

Jag hoppas du hittar en lösning. Lycka till, och ha en bra dag!

 

Med vänlig hälsning ..."

 

 

Mitt svar:

"Hej igen

 

Stort tack för det informativa svaret som rätar ut en del frågetecken.

 

Jag har som sagt inte testat med någon annan dator ännu, men ska göra det som nästa steg i felsökningen. Förr eller senare hittar jag väl felet, förhoppningsvis innan nästa sommar-OS - som var en ren sportslig prestation att klara av att titta på i SvTplay i år ;-)

 

Vänligen, ..."

post-42451-0-45942200-1346764717_thumb.gif

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×
×
  • Skapa nytt...