Just nu i M3-nätverket
Gå till innehåll
virtuosen2

Använd alla kärnor vid boot!

Rekommendera Poster

Win7 bootar i default bara med en kärna. Har man en CPU med fler kärnor, kan man få win7 att boota snabbare genom att sätta antalet aktiva kärnor till antalet man har i CPU. I mitt fall har jag satt antalet kärnor till 4. (Jag har en i5-750 med 4 kärnor).

 

Man hittar inställningen i msconfig, i systemstart, under "avancerade alternativ".

Ändra "defaultettan" till det antal kärnor (processorer) som datorn har.

Glad Påsk!

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Fundering:

Är det inte så att som standars sköter Windows detta automagiskt.

Ett om du har fyra kärnor, då nyttjar Windows dessa fyra.

 

Om du går in där och ändrar blir det ingen ändring. Enda som kan hända är att du sätter en begränsning, att Windows bara får använda, säg, en kärna vid boot.

 

Men visst, det skadar inte, det ändrar inget, att sätta det till det antal kärnor din processor har. Enda skillnaden är att du får en selektiv start som MSDefender kan ha en åsikt om.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Jag har lagt ett liknande inlägg här på Eforum och fick då svar från flera här på forumet att det inte stämmer eftersom behovet av antal kärnor vid boot styrs automatiskt ej är beroende av vilken inställning som valts under antal kärnor. Detta är en bara en myt eller missuppfattning eftersom inställningar är till för testning för att kunna simulera hur datorer med färre kärnor fungerar.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Jag vill minnas att när jag skaffade min dator för två år sedan fick jag ändra i registret för att den skulle använda hela CPU-kapaciteten.

Det är en Intel Core i7-870 CPU som har 4 kärnor plus ytterligare 4 virtuella kärnor. För att resursövervakaren skulle visa CPU 0 t o m 7

fick jag öka antalet aktiva kärnor i registret från fyra till åtta.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Vad jag vet så är det som Monshi säger, detta sköts med automatik, ändrar man själv, så händer ingenting.

Har testat själv på en burk här, men uppfattade ingen förändring, en kallboot tog lika lång tid, oavsett vad.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Jag har lagt ett liknande inlägg här på Eforum och fick då svar från flera här på forumet att det inte stämmer eftersom behovet av antal kärnor vid boot styrs automatiskt ej är beroende av vilken inställning som valts under antal kärnor. Detta är en bara en myt eller missuppfattning eftersom inställningar är till för testning för att kunna simulera hur datorer med färre kärnor fungerar.

Ja precis, se inlägg # 4 //eforum.idg.se/topic/333367-lost-timeout-i-systemstart-vad-gor-denna/page__p__1563891__fromsearch__1#entry1563891

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Fundering:

Är det inte så att som standars sköter Windows detta automagiskt.

Ett om du har fyra kärnor, då nyttjar Windows dessa fyra.

 

Om du går in där och ändrar blir det ingen ändring. Enda som kan hända är att du sätter en begränsning, att Windows bara får använda, säg, en kärna vid boot.

 

Men visst, det skadar inte, det ändrar inget, att sätta det till det antal kärnor din processor har. Enda skillnaden är att du får en selektiv start som MSDefender kan ha en åsikt om.

 

Nä, defender har inte gnällt. Eftersom jag har SSD och en överklockad 750, så bootar burken snabbt ändå. (oavsett)

Jag fick tipset under veckan, följde det, och såg ju "med egna ögon" att win7 hade en processor (kärna) som defaultinställning vid boot. Är du säker på att win använder alla CPU-kärnorna vid boot även om det står "1" som i defaultläge? Är det enbart en "begränsningsfunktion" i msconfig, om du förstår var jag menar..? Ettan står ju där som "default"!?

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Vad jag vet så är det som Monshi säger, detta sköts med automatik, ändrar man själv, så händer ingenting.

Har testat själv på en burk här, men uppfattade ingen förändring, en kallboot tog lika lång tid, oavsett vad.

 

Jag har inte märkt någon större skillnad själv heller. Men det kan bero på att jag tidigare har tagit bort den största flaskhalsen (HDD) och ersatt den med en SSD. Numera så filar jag på enstaka sekunder i boot, och då måste jag ha stoppklocka för att märka skillnaden.. Och det är mer än vad jag "orkar".. ;-)

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Postad (redigerade)

Efter att ha "forskat" med hjälp av Google tycker jag mig ha förstått att det är bäst att inte ändra något under "Antal processorer" i Systemstart.

Om man låter det stå som Default (alltså inte väljer något antal) används samtliga processorer vid systemstart:

http://windows.micro...m-Configuration

Möjligheten att ändra antalet är där för att man ska kunna begränsa antalet processorer under systemstart - inte öka antalet eftersom det alltså ändå alltid är maximalt.

 

Däremot tror jag att man kan bli tvungen att sätta ValueMax (det högsta antalet kärnor som kan försättas i viloläge) till 0 via Regedit i powercfg eftersom default inte alla kärnor är igång.

Jag blev tvungen att ändra för att se samtliga åtta kärnor i min Quad Core i7-870. Verkar som man från början låter hälften av kärnorna vara i viloläge som en åtgärd att spara energi.

För att de virtuella kärnorna ska bli aktiva måste man dessutom ha hyperthreading aktiverat i BIOS.

 

Här är en video som beskriver hur man aktiverar alla kärnor på en processor som stöder "Core Parking":

Och i text:

http://ipkonfig.com/...pu-core-parking

Redigerad av Anguli

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Postad (redigerade)

Kan säga att på min i7 2600K cpu med 4 hårda samt 4 virtuella kärnor så är alla igång utan att jag behövt ändra någon inställning i Windows 7.

4 cores and 8 threads.

Moderkort AUS P8Z68 Deluxe

Hyperthreading och Turboboost aktiverat i BIOS.

CPU:n är moderat överklockad till 4,2GHz (CPU ratio=42 Bus speed=100MHz) men i idle mode tex. nu när jag skriver detta så kör den på 1600MHz och först när den belastas så hoppar den direkt upp till 4,2GHz.

Redigerad av Flyfisherman

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Kan säga att på min i7 2600K cpu med 4 hårda samt 4 virtuella kärnor så är alla igång utan att jag behövt ändra någon inställning i Windows 7.

4 cores and 8 threads.

Moderkort AUS P8Z68 Deluxe

Hyperthreading och Turboboost aktiverat i BIOS.

CPU:n är moderat överklockad till 4,2GHz (CPU ratio=42 Bus speed=100MHz) men i idle mode tex. nu när jag skriver detta så kör den på 1600MHz och först när den belastas så hoppar den direkt upp till 4,2GHz.

Intressant. Undrar om du ändå stängt av "core parking" eller om det har med överklockningen att göra...

Jag uppdaterade mitt inlägg ovan med en länk till en video som visar hur man stänger av "core parking".

 

Vad har du för ValueMax och ValueMin i registret för

0cc5b647-c1df-4637-891a-dec35c318583

på din dator med i7-2600K ?

"Core parking" är avstängd om bägge värdena är 0.

(ValueMax anger det högsta värdet i % för kärnor som kan sättas i viloläge och är default hex 64 dvs 100).

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Postad (redigerade)

Hmm nu blev det lite OT i tråden, får hoppas inte virtousen2 misstycker.;)

 

Först kanske jag skall förtydliga lite om min CPU i7 2600K (upplåst) och mitt moderkort, Turbo Boost är egentligen att den drar på mer kräm från standard max 3,4GHz till max 3,8GHz utan överklockning och om man har aktiverat XMP profilen för minnena i BIOS.

 

När klockfrekvensen ökar när behovet finns, för att genast gå ned när det är mindre belastning på CPU, så heter detta på Intels processorer Speed step.

http://en.wikipedia.org/wiki/SpeedStep

 

I mitt fall efter att ha satt CPU ratio=42 så hoppar den som sagt upp till 4,2GHz och att jag valt just 42 är för att vid den moderata överklockningen behöver jag inte manuellt ändra på några övriga värden som tex. Vcore etc. det sköter den om själv.

post-73434-0-68077300-1333885101_thumb.png

 

post-73434-0-55224100-1333885334_thumb.png

 

0cc5b647-c1df-4637-891a-dec35c318583

post-73434-0-70716400-1333885934_thumb.png

Kan tillägga att jag inte haft några som helst problem med vare sig 'tung' videoredigering, CAD/Cam eller krävande spel.

CPU:n hoppar snabbt som attan upp till maxfart (Intel Speed Step) vid belastning och kör i den farten så länge behovet finns.

Dessutom så drar den mindre ström och utvecklar mindre värme när den går ned till lägre hastighet.

 

[Edit] Givetvis bör man köra en stresstest för att säkerställa att allting fungerar efter man ändrat värdena, ja egentligen alltid vid nybyggnad också. Tex. Intel Linpack stresstest inlägg #3

Redigerad av Flyfisherman

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Hmm nu blev det lite OT i tråden, får hoppas inte virtousen2 misstycker.;)

 

Först kanske jag skall förtydliga lite om min CPU i7 2600K (upplåst) och mitt moderkort, Turbo Boost är egentligen att den drar på mer kräm från standard max 3,4GHz till max 3,8GHz utan överklockning och om man har aktiverat XMP profilen för minnena i BIOS.

 

När klockfrekvensen ökar när behovet finns, för att genast gå ned när det är mindre belastning på CPU, så heter detta på Intels processorer Speed step.

http://en.wikipedia.org/wiki/SpeedStep

 

I mitt fall efter att ha satt CPU ratio=42 så hoppar den som sagt upp till 4,2GHz och att jag valt just 42 är för att vid den moderata överklockningen behöver jag inte manuellt ändra på några övriga värden som tex. Vcore etc. det sköter den om själv.

post-73434-0-68077300-1333885101_thumb.png

 

post-73434-0-55224100-1333885334_thumb.png

 

0cc5b647-c1df-4637-891a-dec35c318583

post-73434-0-70716400-1333885934_thumb.png

Kan tillägga att jag inte haft några som helst problem med vare sig 'tung' videoredigering, CAD/Cam eller krävande spel.

CPU:n hoppar snabbt som attan upp till maxfart (Intel Speed Step) vid belastning och kör i den farten så länge behovet finns.

Dessutom så drar den mindre ström och utvecklar mindre värme när den går ned till lägre hastighet.

 

[Edit] Givetvis bör man köra en stresstest för att säkerställa att allting fungerar efter man ändrat värdena, ja egentligen alltid vid nybyggnad också. Tex. Intel Linpack stresstest inlägg #3

 

Varför skulle jag misstycka, detta är ju intressant!

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Postad (redigerade)

Varför skulle jag misstycka, detta är ju intressant!

:thumbsup:

 

En sak som är intressant med Core Parking är ju i artikeln som länkas till av Anguli, om det där stämmer vill säga http://ipkonfig.com/...pu-core-parking

Citat:

 

By disabling this feature the operating system will load balance across the CPU cores without turning cores off/on when needed. Instead all cores will be enabled regardless of what the operating system tells the CPU and allow games and other applications to continue using all cores

 

Orginalartikeln är denna: http://blogs.technet...coalescing.aspx

 

Då kan man se detta själv och hur det utnyttjas:

Start > i sökfältet skriv resurs > i listan som kommer upp klicka på Resursövervakaren > fliken Processor => till höger ser man denna lista

 

CPU Idle på 1600MHz på min maskin just nu när jag skriver detta:

 

post-73434-0-60720900-1334180744_thumb.png

 

CPU 1, 3, 5 och 7 parkerad. Dessa är ju dom 4 virtuella kärnorna.

Övriga fyra "riktiga" kärnorna CPU 0, 2, 4 och 6 kör ju som vanligt.

post-73434-0-66299500-1334180573_thumb.png

 

Denna visar när jag kör lite belastning på CPU med Linpack stresstest (länkat till tidigare) så alla kärnorna belastas i 4,2GHz inga är parkerade och CPU stack iväg direkt till fullfart.

Man kan också se hur CPU spänningen (VID) ökat till 1,3411V

Detta är också i början av stresstesten, skall man köra denna så är det mycket viktigt att ha koll på temperaturerna när kärnorna belastas ända upp till 100% och med max minne i testen - vilket inte sker här.

post-73434-0-83998900-1334181266_thumb.pngpost-73434-0-58783000-1334181266_thumb.png

 

Så jag har svårt att se vitsen med att koppla bort Core Parking?

Vad är det man skulle tjäna egentligen, för i mitt fall så sticker allting iväg direkt, på nån klockcykel, till fullfart när behovet infinner sig.

Mvh :rolleyes:

 

[Edit] CoreTemp gadgeten visar dom fyra riktiga kärnorna som alltså alltid är igång oavsett.

Redigerad av Flyfisherman

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Själv har jag en annan "religion": En bra dator ska oftast gå på "tomgång".

Om ni fattar vad jag menar... (Om ni inte förstår, säg till, så utvecklar jag gärna!)

:)

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×
×
  • Skapa nytt...