Just nu i M3-nätverket
Gå till innehåll
Mikael63

LÖST Hitta förekomster av tre lika cellvärden

Rekommendera Poster

1. Har inte än testat att hitta en lösning på egen hand, även om jag kanske skulle klara av det.

 

2. I bifogad fil skulle jag vilja kontrollera om ett cellvärde förekommer på tre ställen, eller fler, i samma blad.

Samma värde får alltså förekomma på max två ställen.

 

Resultatet kan se ut hur som helst, vara var som helst i bladet.

söka3.xlsx

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Hur har du tänkt dig detta egentligen?

Alla värden på bladet, värden som kan finnas varsomhelst på bladet eller är det värdena i en viss kolumn?

 

Om du nöjer dig med färgsätta, skapa då ett villkorsstyrt format med följande regel

=ANTAL.OM($A:$B;A1)>2

och ge formatet en färg. Då färgas alla som förekommer mer än två gånger.

Men formler, på bladet, blir det lite svårare.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Hur har du tänkt dig detta egentligen?

Ja, nästan inte alls!

 

Alla värden på bladet, värden som kan finnas varsomhelst på bladet eller är det värdena i en viss kolumn?
Varsomhelst.

 

Om du nöjer dig med färgsätta, skapa då ett villkorsstyrt format med följande regel

=ANTAL.OM($A:$B;A1)>2

och ge formatet en färg. Då färgas alla som förekommer mer än två gånger.

Duger finfint. Tack!

 

Om man nu tänker sig en utökad kontroll där man bara ska kolla förekomst i A och visa dessa med annan färg, kan man då lägga in detta som utökat villkor eller blir det krock då?

Finns värdet två gånger i A och totalt tre gånger så..

 

Jag kan annars ha ett blad för vardera kontrollen.

Filen är bara en temporär fil där värden klistras in från annan applikation enbart för denna kontroll.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Postad (redigerade)

Bara lägga till en till liknande regel.

Typ

=ANTAL.OM($A:$A;A1)>1

med en annan färg.

 

Fast det är klart, om båda villkoren är uppfyllda, båda reglerna, kommer den sista att vara den som bestämmer och båda ger samma egenskap. Du kan sätta den andra att lägga på ett mönster istället för färg eller kanske lägga till en tredje regel som kolla båda och då ger en speciell färg.

Redigerad av Monshi

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Bara lägga till en till liknande regel.

Typ

=ANTAL.OM($A:$A;A1)>1

med en annan färg.

 

Fast det är klart, om båda villkoren är uppfyllda, båda reglerna, kommer den sista att vara den som bestämmer och båda ger samma egenskap. Du kan sätta den andra att lägga på ett mönster istället för färg eller kanske lägga till en tredje regel som kolla båda och då ger en speciell färg.

Funkar också finfint!

Jag satte ordningen så att det "allvarligaste" felet visas i första hand.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Väcker denna tråd till liv igen.

Använder fortfarande denna lösning men undrar nu om det skulle gå att skilja på ex. 113 och 0113?

Jag kan ha två förekomster av 0113, vilket är okej, samt en eller två förekomster av 113 vilket också är okej.

Dessa räknas dock samman så att jag får "varningsfärg", att det finns tre, eller fler, förekomster.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Cellerna är formaterade som text och/men jag får en liten grön pil i cellens övre vänstra hörn när jag testar att skriva in värden.

 

 

 

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Det visar Excel eftersom den tycker att det du skriver in ser ut som tal.

En liten varning att det blir bättre, tycker Excel, om de sparas som tal men då kan du inte skriva in 001.

 

fast nu blev jag tvungen att testa och Excel anser visst att texten 01 och 1 är samma.

matrisformeln

{ =SUMMA(OM($A$1:$A$6=A1;1;0)) }

fungerar dock men den blir tung om många rader.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Nu är jag som vanligt inte med..

 

Jag har denna som regel 1

=ANTAL.OM($A:$B;A1)>2

och denna som regel 2

=ANTAL.OM($A:$B;A1)>1

 

Var ska jag sätta in matrisformeln?

Jag har data i A1 till A100 och B1 till B100

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Nej, över en hel kolumn skriver man inte en matrisformel om man inte vill gå och dricka kaffe efter varje knapptryck i bladet.

 

men i princip skulle det bli

{  = SUMMA(OM($A:$B=A1;1;0)) >2 }

Måsvingarna skriver du inte in, de ger Excel när du matar in formeln som en matrisformel.

Det borde dock finnas en bättre lösning på detta!

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Ctrl+Shift+Enter fungerar inte i fältet för regeln.

 

Jag har möjlighet att sortera mina data (det spelar ingen roll var de ligger, inbördes) och manuellt ta bort alla som inte börjar på 0

Helt enkelt skippa dessa i kontrollen.

 

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Det har du rätt i, den formeln fungerar inte i en cell så då får man dela den i två om man vill ha den. men men man kan även strula till det med:

I granncell till din lista skriv:

=A1+LÄNGD(A1)/1000

och räkna sedan antal.om på den kolumnen.

Då blir det rätt.

 

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Postad (redigerade)

"Det finns ett problem med den här formeln" ?

 

Hm, jag behöver lägga in formeln som text, sedan ändra formatet till allmänt...

 

Redigerad av Mikael63
??

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Blir svårt att utvärdera detta, behövs väl en eller två OM här?

 

Tillägg: 015 behöver kollas upp, den är gul, men försvinner i mängden av andra gula som inte utgör fel.

(det här var ett skarpt exempel och 015 var fel på ett ställe där data hämtades från)

 

ndj1IMu5cW.thumb.png.566c2ea09a148905df0c5346a5ae8778.png

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Du kan skippa hjälpkolumnen om du vill. Vid en vanlig celljämförelse hanterar "textsiffror" som text. Det betyder att även en "hemmagjord" antal.om med hjälp av Produktsumma hanterar "textsiffror" som text, så du kan köra din originallösning med produktsumma istället för ANTAL.OM:

 

=PRODUKTSUMMA(($A$1:$B$1000=A1)*1)>2

 

en jobbig detalj är att alla tomma celler kommer att räknas som identiska och bli gula. Det kan lösas genom att addera villkoret att de måste ha innehåll

=OCH(A1<>"";PRODUKTSUMMA(($A$1:$B$1000=A1)*1)>2)

 

Obs att det blir en ganska stor beräkning för varje cell, På en slö dator och i beräkningstunga datablad så kommer det att märkas.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×
×
  • Skapa nytt...