Just nu i M3-nätverket
Jump to content

byt ut del av text mot ny?


cagi00

Recommended Posts

Hej

Behöver hjälp..

I mitt excelark har jag i en av kolumnerna olika textsträngar, kan se ut enligt nedan:

023/NED TRUNKLEDN

018 Ned

08-md110-laa-ned

08-1 MULTI-Ned

FB SXLIN Ned

08-md110-laa-ned

Ned Normal

 

Jag vill i en ny kolumn ta ut ordet ned, är det möjligt?

Jag har försökt med olika formler men hittar inte nån lösning som fungerar :(

/Carolina

Link to comment
Share on other sites

=BYT.UT(A1;"ned";"")

 

duger inte den?

eller var det inte det du ville? Att ta bort ordet ned?

men notera att denna tar bort alla förekomster av denna teckenföljd, oavsett om den står ensam eller som del av ord.

Link to comment
Share on other sites

njae..jag vill ur olika textsträngar sortera ut enbart ordet ned i en egen kolumn, dvs ta bort allt annat som står framför eller bakom ordet.

 

Jag är ute efter en formel så jag slipper använda mig av "sök och ersätt" funktionen:

Sök efter: *Ned*

Ersätt med: Ned

 

Jag har ungefär 7000 rader med olika varianter på fritext..

Link to comment
Share on other sites

Du får nog skriva något i stil med

=EXTEXT(A1;HITTA("ned";A1);3)

men antar att det finns celler denna text inte finns med i?

=OM(ÄRFEL(HITTA("ned";A1));"";=EXTEXT(A1;HITTA("ned";A1);3))

 

om Excel 2010 använder du givetvis OMFEL istället.

Sedan om du vill "låsa" dessa värden, ta bort formeln, kopiera då resultatet och klistra in enbart värdena.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...