Just nu i M3-nätverket
Jump to content

Intervall av Datrumvärde i en kolumn för att räkna summan i en en annan kolumns samma rader


Flyckten

Recommended Posts

Hej,

 

Jag har värden i Kolumn A från 2011-01-01 tom 2011-04-01. I kolumn B har jag tal (pengar).

 

Jag vill ha en formel eller lösning som tittar i kolumn A och tar samtliga värden i kolumn B som är inmatade inom en viss tidsperiod (kolumn A), t ex januari och ger mig summan av dessa värden.

 

Ex:

 

A1 = 2011-01-01 B1 = 1

A2 = 2011-01-07 B2 = 2

A3 = 2011-01-13 B3 = 3

A4 = 2011-01-20 B4 = 4

A5 = 2011-02-03 B5 = 5

A6 = 2011-02-17 B6 = 6

A7 = 2011-03-18 B7 = 7

 

Då skulle formeln returnera summan av A1:A4, Dvs 10 i detta fallet. Samma formel skall gå att använda för februari och då returnera värdet 11. Och då för mars = 7.

 

 

 

 

Tacksam för svar!

 

 

 

/Alexander

Link to comment
Share on other sites

Hej,

 

Beroende på hur dynamisk din indata är och vad du ska göra med resultatet finns (minst) två lösningar:

  1. Pivottabell, grupperad månadsvis.
  2. Följande formel beräknar summan för en period given av datum i C1 och D1:
    =PRODUKTSUMMA((A1:A7>=C1)*(A1:A7<D1)*B1:B7)

Hälsningar

/Johan

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...