Just nu i M3-nätverket
Jump to content

om är tal


dedacia81

Recommended Posts

Hej.

Jag hittade den här funktionen i en annan tråd.

 

=OM(OCH(ÄRTAL(A1);A1<>0);"Jajamensan!";"nehe")

 

//eforum.idg.se/topic/327569-om-ar-tal/

 

 

Jag försöker skapa en liknande funktion fast med flera celler. t ex A1 till A22

Jag testade att skriva:

=OM(OCH(ÄRTAL(A1:A22);A1:A22>0);"Jajamensan!";"nehe")

Men jag fick det inte att fungera

 

Jag vill altså ha en funktion där en text publiceras i en separat cell om värdet i alla 22 celler överstiger värdet 0

 

MVH

D

 

 

 

Link to comment
Share on other sites

=OM(OCH(ÄRTAL(A1:A22);A1:A22>0);"Jajamensan!";"nehe")

När man arbetar med områden och vill utvärdera enskilda celler får man ange formler som matrisformler genom att trycka Ctrl+Shift+Enter vid inmatningen. Matrisformler visas som {=...}. Det är inte alla funktioner som kan användas i matrisformler, men i ditt fall fungerar det.

 

Hälsningar

/Johan

Link to comment
Share on other sites

Varför göra det svårare än:

=OM(ANTAL.OM(A1:A5;">22")=5;"ja";"nej")

Borde det inte bli, typ:

 

=OM(OCH(ÄRTAL(A1:A22);ANTAL.OM(A1:A22;">0")=ANTAL(A1:A22));"ja";"nej")

 

för att säkerställa att alla cellerna innehåller tal större än 0.

 

/Johan

Link to comment
Share on other sites

Borde det inte bli, typ:

 

=OM(OCH(ÄRTAL(A1:A22);ANTAL.OM(A1:A22;">0")=ANTAL(A1:A22));"ja";"nej")

 

för att säkerställa att alla cellerna innehåller tal större än 0.

 

/Johan

Hej

Nu börjar det likna någon.

jag stötte på et skumt fel dock.

Jag lade koden i cell M27 (för det är där den ska vara) då fungerar det inte.

 

Om jag dock lägger koden i samma radområde (någonstans mellan 1 - 22) fungerar koden perfekt.

kan man komma runt detta?

jag kör excel 2003

Link to comment
Share on other sites

vad är det för krav du har?

Att alla celler inom området ska vara över noll? Då fungerar antal.om som jag skrivit den.

 

Om du har celler inom området som inte är tal men att alla celler som ska vara tal ska vara över noll då får vi skriva lite annorlunda:

=OM(ANTAL(A1:A5)=ANTAL.OM(A1:A5;">0");"ja";"nej")

Då räknas antal celler med tal och jämförs med celler med värde över noll.

 

jag tror inte ÄRTAL fungerar som matrisformel.

Link to comment
Share on other sites

Ibland är Excels vägar outrundliga. Efter lite testande verkar det som att:

  • =ÄRTAL(A1:A22) kollar värdet i motsvarande rad som formeln står, dvs står formeln i rad 5 kollas A5
  • {=ÄRTAL(A1:A22)} (matrisvarianten) kollar bara värdet i A1

Dock

  • {=OCH(ÄRTAL(A1:A22))} fungerar. Dvs, ger bara sant om alla celler är tal!

Vilket betyder att:

 

{=OM(OCH(ÄRTAL(A1:A22);(A1:A22>0));"ja";"nej")}

 

ger det förväntade resultatet.

 

/Johan

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...