Just nu i M3-nätverket
Jump to content

Underformulär beter sig som låst


ottarpslisa

Recommended Posts

ottarpslisa

Hej,

jag har problem med ett underformulär som inte vill ta emot data. Det är liksom lite meningen med ett formulär att det gör det så jag hoppas att någon har haft samma problem och hittat felet.

 

Det är en liten databas skapad i Access 2007 och i huvudformuläret har jag inga problem att ändra information i.

 

Det beter sig likadant som om det var låst men ingen av kontrollerna eller formulären är låsta.

 

Jag har testat att sätta Inmatning till ja på huvudformuläret men då försvinner underformuläret helt.

 

Några förslag vad jag ska testa?

 

MVH

Lisa

 

PS: den bifogade filen är en rarfil (men uppackad en accdb fil)

Samtalsbas110409.txt

Link to comment
Share on other sites

Cege Anderson

Hej hej

 

Vet ju inte riktigt hur kopplingen är gjord MEN om jag hade gjort detta så hade jag skapat en undefråga som underformuläret bygger på. Har du gjort på det sättet så kolla att köra bara själva frågan och se om du får samma problem.

 

Kanske är det något i relationerna mellan de tabeller som ingår som gör att när underformuläret öpnnas så kan du inte ändra i det.

 

Vet inte hur det är om det är känslig information men annars kan du maila mig databasen så kan jag se om det jag klura ut vad felet är.

 

// Cege

Link to comment
Share on other sites

ottarpslisa

hm ja det har du rätt i, frågan har samma problem som formuläret.

 

I huvudtabellen går det däremot att ändra data om man lägger till ett underdatablad så någonstans mellan fråga och svar är kopplingen fel. Ska leta mer där.

 

Lisa

Link to comment
Share on other sites

ottarpslisa

Har testat att ta bort tabellen Fråga från underformuläret men fortfarande är något fel trasigt.

 

Lisa

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...