Just nu i M3-nätverket
Gå till innehåll
moaro

Summa inom en viss kategori

Rekommendera Poster

Jag har en fil där det i en kolumn A står vilken kategori en person tillhör(exempelvis "gröna laget", "blå laget"), och i kolumn F står ett numeriskt värde. Hur kan jag göra en formel för att få fram summa eller medelvärden på kolumn F, givet att personen ingår i blå laget?

 

Jag har excel 2003, och har alltså inte tillgång till antal.om-funktionerna. Jag försökte med letarad, men fick inte riktigt till det.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Hej,

 

Använd PRODUKTSUMMA, typ:

=PRODUKTSUMMA((A1:A5="grön")*1;F1:F5)

 

Denna formel ger summan av alla tal i F1:F5 där motsvarande rad i A1:A5 innehåller "grön". Multiplikationen med 1 är ett trick för att omvandla jämförelsen till ett tal (0/1). Viktigt också att de bägge matriserna (det går att multiplicera på fler om man vill) har samma storlek.

 

Hälsningar

/Johan

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

fast Pejo - med en enkel regel som detta torde SUMMA.OM vara nog och därmed enklare.

 

Om flera villkor, då är PRODUKTSUMMA det som krävs (om man inte har Excel 2007/2010)

 

Ditt exempel kan man enkelt skriva som

=SUMMA.OM(A1:A5;"grön";F1:F5)

 

En sak jag inte förstår i första inlägget är

Jag har excel 2003, och har alltså inte tillgång till antal.om-funktionerna.

Antal.Om ska finnas i Excel 2003

=ANTAL.OM(A1:A5;"Grön")

ger antal som är med i gröna laget.

Vill du ha medel så har du nu alla siffror du behöver.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Hej, och tack för hjälpen!

 

Det var antal.omf som jag saknade, helt korrekt.

 

En fråga till: Hur gör jag för att hänga på en till antal.om-funktion på den första, dvs. av dem som tillhör gröna laget vill jag veta hur många som dessutom har ett Ja i kolumn b?

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×
×
  • Skapa nytt...