Just nu i M3-nätverket
Jump to content

Procentsummering blir värdefel


Diskus

Recommended Posts

för att du har en tom sträng i A12. Skriv noll där istället och se att det fungerar. En tom sträng är inte ett värde.

Link to comment
Share on other sites

för att du har en tom sträng i A12. Skriv noll där istället och se att det fungerar. En tom sträng är inte ett värde.

 

Det var för att få en tom cell som jag såg i en annan fora. Det kanske inte går att kombinera ?

Link to comment
Share on other sites

Du kan alltid anpassa formeln

=OM(SUMMA(B1:B11)=0;"";SUMMA(B12*25%)+SUMMA(A1:A11))

eller

=OM(SUMMA(B1:B11)=0;"";SUMMA(B12*25%)+OM(A12="";0;A12))

 

Annars finns andra vägar att gå för att dölja nollvärden

1: Ställa in Excel att dölja nollvärden. Gäller bara för aktivt blad, görs i centrala inställningarna.

2: Använda villkorsstyrd formatering, sätta textens färg till samma som bakgrunden om noll

Link to comment
Share on other sites

Du kan alltid anpassa formeln

=OM(SUMMA(B1:B11)=0;"";SUMMA(B12*25%)+SUMMA(A1:A11))

eller

=OM(SUMMA(B1:B11)=0;"";SUMMA(B12*25%)+OM(A12="";0;A12))

 

Formellösning verkar bäst verkar bäst.

Men står det något i kolumn A försvinner allt.

 

Kanske skrev jag formeln fel från början ?

När något skrivs i antingen A eller B ska det summeras .

Och sedan ska A12 och B12 summeras i F13, där B12 ska summeras med endast 25% .

Link to comment
Share on other sites

Okej..

 

En dummy-formel då...

=OMFEL(A12*1;0)+OMFEL(B12*0,25;0)

Om du inte vill att det ska stå noll i cellen när inget står där

=OM(OCH(A12="";B12="");"";OMFEL(....))

typ

Ett alternativ, finns fler... exempelvis

=OM(SUMMA(A1:B11) =0;"";SUMMA(A1:A11)+SUMMA(B1:B11)*0,25)

 

ja du, detta borde du kunna lösa :)

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...