Just nu i M3-nätverket
Jump to content

[Löst] Ingen åtkomst till delade mappar


Mikael63

Recommended Posts

Kanske kommer denna tråd att höra hemma på annan plats men det är i Linuxmiljö jag upplever problemet.

 

Jag har på en PC med XPH, endast en användare, delat ut sju mappar m.h.a. Net Share.

Så har jag gjort under flera år.

Har kommit åt dessa mappar från andra enheter, PC (XP & Vista), Mac (10.6), Linux (Mint 8), Wii(4.1E) osv. utan några särskilda inställningar. Mja, ibland kan nån Vista-burk ha klagat men..

Har alltså inte behövt nyttja någon särskild användare eller använda något lösenord överhuvudtaget. Finns inget lösen på den XP som delar ut heller.

 

På en burk som nyligen fått Linux Mint 10 installerad:

Om jag bläddrar på nätverket så kan jag öppna/montera sex av dessa sju mappar.

På Linuxburken har jag också installerat XBMC. Inifrån den (under Video) kan jag bläddra fram två av dessa sju mappar och jag kan även spela upp innehållet. Inifrån XBMC (Musik eller Bilder) kommer jag inte åt någon av de andra mapparna. Jag ser dem men ett användarnamn och ett lösenord efterfrågas.

 

Egenskaperna för dessa sju mappar ser likadana ut.

Den mapp jag inte kan öppna/montera är C:\Documents and Settings\User\Mina dokument.

 

Varför har jag ingen åtkomst alls till den mappen?

 

Varför efterfrågas användarnamn & lösen på en del mappar men inte andra? Eller vad ska jag ange för namn & lösen, när jag inte har något lösen?

Jag borde iofs. ha ett Adminkonto (på den utdelande burken)men det har jag aldrig någonsin behövt nyttja.

Link to comment
Share on other sites

Hurudan är din smb.conf fil? Är null passwords = No? Ändra i såfall till Yes.

/etc/samba/smb.conf

Hittar inte exakt den raden, men en hel del ang. password som har Yes.

Bifogar filen, omdöpt.

Men det är ju inte på Linuxburken jag delar ut något(?)

 

Jag har märkt en annan sak och som säkert hänger samman med mitt problem i XBMC.

Jag kan i Linux bara montera/öppna två Windowsutdelade mappar åt gången.

Alltså om jag bläddrar på nätverket, letar rätt på en utdelad mapp och dubbelklickar där så öppnas ju "fönstret" så att jag ser innehållet. Samtidigt hamnar den mappen som en monterad "enhet" till vänster. Om jag i fönstret klickar på tillbakapilen så kan kommer jag tillbaks och kan dubbelklicka på en annan mapp och samma sak händer. Då har jag två enheter monterade. Om jag gör om detta, backar och försöker öppna en tredje mapp så dyker en ruta upp där jag ska ange lösen. Efter klick på Avbryt dyker rutan upp igen och efter ytterligare ett klick på Avbryt stängs den.

Avmonterar jag en(1) enhet kan jag öppna den tredje, om jag avmonterar båda kan jag öppna två nya.

 

Här undrar jag om "det bara är så", eller om man kan ändra antalet?

 

I XBMC så har jag "Add Source" för två utdelade mappar.

Om jag försöker göra en till "Add Source" så uppmanas jag ange lösen. Min egen gissning är att XBMC hanterar, eller agerar, på samma sätt som filbläddraren.

 

Mappen Mina Dokument är jag nekad åtkomst helt till men det ska jag testa lite annat för.

smb.conf.txt

Link to comment
Share on other sites

Eeh.. det hela verkar ha löst sig, oklart varför..

 

Den mapp som jag inte hade någon åtkomst till, den under Documents and.., ändrade jag, eller rättare tog bort utdelningen. Jag delade i stället ut Mina Bilder och då använde jag Dela ut genom högerklick osv. och inte via ett Net Share kommando (om det nu har betydelse?)

Efter detta kommer jag åt den och jag har inga problem med att öppna flera mappar än två.

Men varför - det vet jag inte...

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...