Just nu i M3-nätverket
Jump to content

Summa.omf med villkor kopplad till relativ referens. Omöjligt?


Leumas

Recommended Posts

Hur tydlig den rubriken blev vet jag inte. Men nu har jag suttit och slitit med en funktion ett bra tag som jag egentligen tycker borde vara busenkel att få till. Jag har en kolumn B med ett antal tusen värden och kolumn C som anger datum för varje värde. Jag försöker summera värdena för respektive år sedan 1965 och framåt och tycker jag kom på ett smart sätt att hantera det på, se de gulmarkerade cellerna i arket. Det verkar dock inte gå att kombinera Summa.omf med ett villkor som är "<värdet i en cellreferens". Någon som vet hur jag kan lösa det på ett effektivt sätt?

 

Mvh,

Samuel

Problemfil.xlsx

Link to comment
Share on other sites

Hur tydlig den rubriken blev vet jag inte. Men nu har jag suttit och slitit med en funktion ett bra tag som jag egentligen tycker borde vara busenkel att få till. Jag har en kolumn B med ett antal tusen värden och kolumn C som anger datum för varje värde. Jag försöker summera värdena för respektive år sedan 1965 och framåt och tycker jag kom på ett smart sätt att hantera det på, se de gulmarkerade cellerna i arket. Det verkar dock inte gå att kombinera Summa.omf med ett villkor som är "<värdet i en cellreferens". Någon som vet hur jag kan lösa det på ett effektivt sätt?

 

Mvh,

Samuel

 

 

Du får ta en omväg, för Excel klarar inte att tolka cellreferensen inom citationstecknen.

Skriv om årtalen i F kolumnen till >1966-01-01,>1967-01-01, o.s.v.

Skriv om formeln i G till =SUMMA.OMF($B$3:$B$54;$C$3:$C$54;F9)-SUMMA.OMF($B$3:$B$54;$C$3:$C$54;F10).

 

/Pär B

Link to comment
Share on other sites

Hej,

 

(Du får ursäkta PerboMan, men även här kan det göras lite effektivare ... ;).)

 

Det går att konvertera årtal till en sträng direkt i formeln.

Antingen med SAMMANFOGA("<";F10) eller bara "<"&F10

 

Borde inte formeln i cell G9 förresten vara?

=SUMMA.OMF($B$3:$B$54;$C$3:$C$54;"<"&F10)-SUMMA.OMF($B$3:$B$54;$C$3:$C$54;"<"&F9)

 

Hursomhelst, om inte Monshi redan har hunnit säga det får jag väl göra det. "Det går precis lika bra med en Pivot-tabell." Och det är förmodligen det mest beräkningseffektiva sättet om vi börjar prata större mängder data. Dessutom behöver du inte hålla reda på vilka år som finns i tabellen. Se bifogad fil.

 

Hälsningar

/Johan

Problemfil-löst.xlsx

Link to comment
Share on other sites

Hej,

 

(Du får ursäkta PerboMan, men även här kan det göras lite effektivare ... ;).)

 

Det går att konvertera årtal till en sträng direkt i formeln.

Antingen med SAMMANFOGA("<";F10) eller bara "<"&F10

 

Borde inte formeln i cell G9 förresten vara?

=SUMMA.OMF($B$3:$B$54;$C$3:$C$54;"<"&F10)-SUMMA.OMF($B$3:$B$54;$C$3:$C$54;"<"&F9)

 

Hursomhelst, om inte Monshi redan har hunnit säga det får jag väl göra det. "Det går precis lika bra med en Pivot-tabell." Och det är förmodligen det mest beräkningseffektiva sättet om vi börjar prata större mängder data. Dessutom behöver du inte hålla reda på vilka år som finns i tabellen. Se bifogad fil.

 

 

Helt korrekt!

 

Dessutom kan man lösa det genom att lägga till en kolumn D med =ÅR(C1). Då kan summeringen förenklas genom att F-kolumnen bara innehåller årtal och summeringsformeln blir:

=SUMMA.OMF($B$3:$B$54;$D$3:$D$54;F10)

 

/Pär B

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...