Just nu i M3-nätverket
Jump to content

VILLKORSSTYRD FORMATERING


lebn

Recommended Posts

Hej,

Jag har Office 2003, XP.

I en kolumn vill jag mha villkorsstyrd formatering ta fram minsta och näst minsta tal,

och färga dessa. Men jag vill inte att talet noll (0) ska räknas som minsta. Hur skriver

jag formeln så att inte nollan blir minsta talet.

Tacksam för tips!

Leif

Link to comment
Share on other sites

Du får nog skriva något i stil med

=OM(A1<>0;(MINSTA($A$1:$A$6;ANTAL.OM($A$1:$A$6;0)+3)>=A1);FALSKT)

givet att dina formateringar börjar i A1.

 

Det finns en fallgrop, det är om serien i A1:A6 innehåller färre än tre värden blir det fel

Link to comment
Share on other sites

Hej och tack för snabbt svar.

Satt och prövade och till slut fick jag fram den här varianten. Tror att den

funkar oavsett hur många eller få värden jag har i kolumnen. För minsta värdet (utom noll):

=A1=STÖRSTA($A$1:$A$10;ANTAL.OM($A$1:$A$10;">0"))

Och näst minsta värde blir då:

=A1=STÖRSTA($A$1:$A$10;ANTAL.OM($A$1:$A$10;">1"))

Jag har inte testat med decimaltal, eftersom det är inte aktuellt för min del.

Tack ändå!

Leif

Link to comment
Share on other sites

Var det inte de minsta värdena du skulle ha? Det där ger väl det största värdena...

men är du nöjd är jag nöjd

Link to comment
Share on other sites

Jag hade fel, men efter fortsatt arbete har jag nu äntligen fått fram en fungerande

kod:

Minsta tal (utom noll)

=A1=MINSTA($A$1:$A$10;ANTAL.OM($A$1:$A$10;0)+1)

Näst minsta tal (utom noll)

=A1=MINSTA($A$1:$A$10;ANTAL.OM($A$1:$A$10;0)+2)

 

Nu fungerar det, oavsett hur många värden det är i kolumnen, och oavsett om kolumnen

har dolda celler (= noll) eller inte.

Och nu är jag nöjd. Hoppas nån mer än jag har glädje av detta.

Leif

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...