Just nu i M3-nätverket
Jump to content

COM-port fungerar inte vid nystartad dator


tomashag

Recommended Posts

Jag har ett program för att visa inkommande data på serieporten. Om jag försöker öppna COM1 inne i programmet så svarar det att COM-porten är upptagen. För att få igång det hela måste jag gå in i enhetshanteraren, avaktivera porten och sedan aktivera den igen - då funkar allt som det ska. Vad kan det bero på? Jag ska också fråga tillverkaren av programmet (Eltima) men då måste jag veta vad enhetshanteraren heter på engelska. Någon som vet?

 

TIA,

Tomas

Link to comment
Share on other sites

Vad har du för dator och modellbeteckning?

Operativsystem?

Externa enheter inkopplade?

 

Enhetshanteraren= Device manager

Inga markeringar i den som indikerar att någon enhet inte fungerar som den skall?

Link to comment
Share on other sites

Vad har du för dator och modellbeteckning?

Operativsystem?

Externa enheter inkopplade?

 

Enhetshanteraren= Device manager

Inga markeringar i den som indikerar att någon enhet inte fungerar som den skall?

 

Datorn är ett "hembygge" med ett Gigabyte EP45-UD3LR moderkort, operativsystem Win 7 Ultimate 32 bitars. Inga externa enheter är inkopplade (utom en USB-disk och PS/2-mus och tangentbord). Jag får felindikering på Microsoft ISATAP Adapter och Microsoft Teredo Tunneling Adapter. Vet inte vad det är för något.

 

/Tomas

Link to comment
Share on other sites

The Intra-Site Automatic Tunnel Addressing Protocol (ISATAP)

Har med ipv6 att göra. Hänger nog ihop Teredo adaptern.

 

Använder du ipv6?

Vad står det om du öppnar kommandotolken och skriver: ipconfig /all

 

Inaktivera vissa IPv6-komponenter Microsoft har ju Fix it i på den sidan, men innan du följer instruktionerna i den länken, bör du förvissa dig vilken lösning som är aktuell i ditt fall. Normalt används endast ipv4.

 

Det finns nog andra som är bättre att svara på detta.

Mvh

Link to comment
Share on other sites

I Windows 7 lär det vara bäst att ha IP v6 aktiverat. Det lär vara ett antal funktioner som förväntar sig att IP v6 är igång.

Link to comment
Share on other sites

I Windows 7 lär det vara bäst att ha IP v6 aktiverat. Det lär vara ett antal funktioner som förväntar sig att IP v6 är igång.

 

Jag använder inte IPV6 om det inte ligger dolt någonstans i operativet som Cecilia tror.

Jag provade med att avaktivera de drivrutiner som larmade enligt ovan men det hjälpte inte. Vad gäller vad som ipconfig/all visar så är det väl så att man inte ska visa det i ett publikt forum. Är det något särskilt du vill veta? Jag har vidare för mig att jag hade ett liknade fel för länge sedan, jag tror att jag fick "Apro exception" och det hjälpte också då med att inaktivera/aktivera COM-porten. Kan detta vara till någon hjälp?

 

/Tomas

Link to comment
Share on other sites

Jag använder inte IPV6 om det inte ligger dolt någonstans i operativet som Cecilia tror.

Jag provade med att avaktivera de drivrutiner som larmade enligt ovan men det hjälpte inte. Vad gäller vad som ipconfig/all visar så är det väl så att man inte ska visa det i ett publikt forum. Är det något särskilt du vill veta? Jag har vidare för mig att jag hade ett liknade fel för länge sedan, jag tror att jag fick "Apro exception" och det hjälpte också då med att inaktivera/aktivera COM-porten. Kan detta vara till någon hjälp?

 

/Tomas

 

Jag tittade på info om COM-porten mha msinfo32 och under upptagen stod det 'nej' men lik förargligt så påstår programmet för visning av serieportsdata att det är upptaget!

 

/Tomas

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...