Just nu i M3-nätverket
Gå till innehåll
jbo

Hemnätverk (Windows XP Pro SP3) – bara åt ena hållet!

Rekommendera Poster

Att konfigurera ett nätverk med hjälp av guiden ”Konfigurera ett hemnätverk eller litet kontorsnätverk” brukar sällan erbjuda några större bekymmer.

Nu har jag dock stött på ett par märkligheter:

 

 

Mitt nätverk och dess konfiguration i korthet:

”Nätverket” för just den här konfigurationen består av endast två datorer: en stationär (socket 775 C2D) och en bärbar (Lenovo T61p). Anslutningen sker via en router (Netgear DG834 ver. 4) där hemnätverket är tillåtet (maximalt 254 IP-nummer).

 

Mjukvarubrandvägg på det bägge datorerna vid installationen är vanliga Windowsbrandväggen.

Inställningarna i resp. brandvägg är identiska (Allänt, Undantag och Avancerat) bortsett naturligtvis från de applikationer som endast finns på resp. dator.

 

Konfigurationen av nätverket görs exakt lika dant på bägge datorerna och till punk och pricka efter anvisningarna i guiden. Det enda som skiljer är det som skall skilja – d.v.s. datornamn (endast bokstäver och siffror, inga blanksteg eller andra tecken) och beskrivning på respektive dator.

 

 

Situationen:

När installationen är klar, datorerna har rebootat sker kontaktförsök.

Att nå den stationära (P43) från den bärbara (T61p) går bra. Alla utdelade resurser dyker upp och kan användas.

 

Problemet är att nå den bärbara (T61p) från den stationära (P43). Det går helt enkelt inte. Ibland dyker den inte alls upp i Utforskaren (Mina nätverksplatser).

”Mina nätverksplatser” kan som bekant visa nätverksresurserna på två sett:

1: Antingen som utdelade mappar på roten i ”Mina nätverksplatser”.

2: Eller som datorer under roten för namnet för nätverket i fråga. I det här exemplet ”Jobbnet”.

 

För det mesta dyker alltså inga delade resurser (mappar) från ”T61p” upp under punkt 1 ovan.

Men ibland, märkligt nog, kan de plötsligt göra det. Det gör dock ingen skillnad, för när så sker, och jag klickar på resursen i fråga, följer först c:a en minuts väntetid och sedan kommer meddelandet i fönstret: ”Mina nätverksplatser”:

”Jobbnet är inte tillgänglig. Kanske har du inte behörighet att använda den här resursen. Be serverns administratör om hjälp.

Listan över servrar i den här arbetsgruppen är för tillfället inte tillgänglig.”

 

Alt. Byts sista meningen istället till:

”Nätverkssökvägen kan inte hittas.”

 

Försöker man att gå via steg 2 – att lokalisera själva datorn i stället (där man i alla fall så gott som alltid finner att det finns en dator vid namn ”T61p” i nätverket) händer samma sak följt av samma meddelande: det är bara första ordet ”Jobbnet” som byts ut mot två backslash och datornamnet (”\\T61p”) och så följer alltså samma meddelande som ovan (andra meningen som i undre citatet ovan).

 

Ett antal ominstallationer, omstarter och kallstarter har gjorts. Dock utan att något av ovan förändras.

(Att pinga datorena från resp. kommandotolk är inga problem.)

 

Sammanfattningsvis: Av någon anledning fungerar mitt nätverk bara åt ena hållet.

 

 

Fråga:

Vad göra härnäst för att komma åt resurserna på den bärbara från den stationära?

Tacksam för alla svar!

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Har du testat att helt stänga av brandväggen (och även Windows Defender)?

 

Jag kan ex.vis inte ha brandväggen aktiverad (varken ZoneAlarm eller Windows egen, testat alla tänkbara varianter, betrodd och på tillåt - fungerar inte oavsett).

Är dessa funktioner avstängda fungerar hemmanätverket dock direkt.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Har du testat att helt stänga av brandväggen (och även Windows Defender)?

 

Jag kan ex.vis inte ha brandväggen aktiverad (varken ZoneAlarm eller Windows egen, testat alla tänkbara varianter, betrodd och på tillåt - fungerar inte oavsett).

Är dessa funktioner avstängda fungerar hemmanätverket dock direkt.

Tack för svar!

Jovisst, jag har provat att helt stänga ned Windows brandvägg. Tyvärr löser det inte problemet (mer än att det i ett fall - jag har testat fram och tillbaka rätt mycket med "på och av" av brandväggen) - då det i alla fall hjälpte till att överhuvudtaget få upp ikonerna för den bärbara datorn (som dator - några mappar har än så länge aldrig dykt upp).

 

Windows Defender? Har inget sådant program installerat - eller på min lista ("Lägg till och ta bort program").

Känner faktiskt inte till den applikationen överhuvudtaget.

 

Använder dock Comodo (brandvägg) för bägge de nämnda datorerna i normalfallet. Comodo är dock helt avstängt på bägge burkarna under hela det ovan beskrivna scenariot.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Här kommer några olika saker att kolla upp:

 

Det underlättar om det är samma användarnamn med samma lösenord på alla datorerna (och lösenordet ska inte vara tomt).

 

Kolla upp enligt sidan

http://support.microsoft.com/default.aspx?scid=kb%3Bsv%3B318030

 

Läs flora50s guide: http://web.comhem.se/~u19125457/network.html

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Brandväggar i routrar (modem) brukar endast påverka förbindelsen till/från internet och inte bry sig om vad som händer mellan dess olika LAN-portar.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Prova att ansluta datorerna med mac adress. Öppna kommandotolken (cmd). Skriv in "ipconfig/all". Anteckna fysisk adress för den trådlös och ethernet anslutning. Det är mac adressen. Gå in i routern och leta rätt på var man skriver in mac adresser. Vet inte var den finns på netgear routrar men står väl i manualen. Skriv in mac adressen för bägge datorerna och godkänn.

 

Nackdelen med att göra så här, är att man måste skriva in mac adressen för varje dator, som ska ansluta till routern. Men det brukar lösa problem liknande du har. Det ger också en viss säkerhet. Kanske inte lika bra som wap2, men om någon har kunskap och vill, så kan de ta sig in i vilken router som helst.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

@ Cecilia, Lighthouse & vertpre!

 

Stort tack för ert engagemang! :thumbsup:

Många intressanta råd och mycket bra länkar (lite så jag :blush: av att jag missade de mest uppenbara - tack Cecilia för att du var finkänslig nog att inte påpeka det :) )

 

För tillfället har min mage besök av någon ondsint liten samling mikrober med det lustiga resultatet är att hela systemet går på lågfart och man får vara glad om man hålla mer än en redig tanke åt gången i huvudet...

 

Skall hursomhelst snarast gå igenom länkar och tips och låter er veta hur det gått så snart jag testat igenom det hela.

 

Och tack igen för att ni tog er tid (måste säga att detta forum aldrig någonsin stått svaret skyldigt - blir alltid lika glad och imponerad av både kunnandet och viljan att hjälpa till här :) )!!

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Hej!

Bägge maskinerna måste vara medlemmar i samma arbetsgrupp för att det skall fungera. Användarid och lösenord behövs inte om maskinerna saknar detta, det primära är arbetsgruppen (workgroup).

// Jari

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Hej!

Bägge maskinerna måste vara medlemmar i samma arbetsgrupp för att det skall fungera. Användarid och lösenord behövs inte om maskinerna saknar detta, det primära är arbetsgruppen (workgroup).

// Jari

 

Visst är det så. Och det kriteriet har alltid varit uppfyllt - d.v.s. till punkt och pricka för namnet på arbetsgruppen.

När det gälller användar-ID och lösenord:

Den bärbara har lösenordsinloggning.

Det har däremot inte den stationära.

Det lustiga i det sammanhanget är att, de få gånger under den här processen med att försöka få ordning på nätverket, är det endast när jag vill nå en resurs från den bärbara till den stationära som jag avkrävs ID och lösen.

 

Kan även påpeka en annan mindre skillnad datorerna emellan:

På den bärbara listas alla resurser under rubriken "Internet".

På den stationära hamnar merparten under samma rubrik, men ett par mappar hamnar under rubriken "Lokalt nätverk".

Konfigurationen för nätverket är, som redan tidigare nämnts, identisk.

 

 

Kan också nämna att jag hunnit bocka av de flesta av de punkter som finns på de länkar som jag fick av Cecilia. Hittills ingen framgång.

Testade även Lighethouse's tips. Samma dystra resultat.

Ett tag var det t.o.m. värre - då fungerade det inte heller att nå resurser på den stationära från den bärbara. Efter mycket testande återställde jag ordningen till den som ursprungligen är beskriven här (om intresse finns kan jag lägga upp en detaljerad beskrivning på hela processen - somligt lär man sig en hel del av, bl.a. att utnyttja möjligheten att "Starta om" ”Computer Browser” [Datorhantering > Tjänster] - det var det som löste problemet med att återfå kopplingen mellan bärbar och stationär som nämndes ovan).

 

Återkommer igen. Förhoppningsvis med en lösning. Tänkte försöka lösa det i Windows först och använda alternativet med router och MAC-adresser sist, om det behövs men kanske också för att se hur det fungerar.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Det lustiga i det sammanhanget är att, de få gånger under den här processen med att försöka få ordning på nätverket, är det endast när jag vill nå en resurs från den bärbara till den stationära som jag avkrävs ID och lösen.
Då skulle ju jag pröva med att införa ett lösenord (eventuellt för ett nytt konto) på den stationära eftersom inloggning utan lösenord över nätverk inte är tillåten, så vitt jag minns.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Då skulle ju jag pröva med att införa ett lösenord (eventuellt för ett nytt konto) på den stationära eftersom inloggning utan lösenord över nätverk inte är tillåten, så vitt jag minns.

Precis min åsikt (även om jag tycker att det är lustigt att inloggningskravet kom från en maskin som inte konfigurerats för inloggning som jag nämnde ovan) och det som blev nästa steg på listan.

Dessvärre hjälpte det inte. Oavsett jag använde samma eller olika lösenord (användarnamn har jag aldrig rört [finns ingen sådan möjlighet] - det borde väl vara samma som datornamnet?).

Situationen är som innan - med tillägget att den stationära överhuvudtaget inte verkar etablera någon verklig kontakt med den bärbara.

Mappar dyker visserligen upp under "Mina nätverksplatser" - men de går lika lite att nå därifrån som från ”Visa datorer i arbetsgruppen” och felmeddelandena är desamma som tidigare (med slutraden ”...Nätverkssökvägen kan inte hittas.”).

Delar jag ut nya resurser (mappar) på den bärbara visas dessa dock inte på den stationära (oavsett uppdatering [F5], omstart, etc. - provade faktiskt med att lägga in hela nätverket från början också).

 

Att nå den stationära från den bärbara går dock fortfarande bra.

 

Ser ut som jag nu tömt de flesta alternativ som finns i Windows (skall ta en genomgång till när jag får möjlighet igen - det tar tiiiiid att göra sån't här om man vill göra det ordentligt med loggar för allt). När Windows är uttömt återstår väl inget annat än att testa de förslag med MAC-adresserna på routersidan som vertpre förslog - såvitt ingen annan har något annat att föreslå... (tycker att det BORDE gå att lösa i Windows)....

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Datornamn och kontonamn behöver inte alls vara samma. Vad kontonamnet är borde du se där man hanterar konton i Kontrollpanelen. Jag kommer inte ihåg vad det heter i XP men i Vista heter det Användarkonton.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Datornamn och kontonamn behöver inte alls vara samma. Vad kontonamnet är borde du se där man hanterar konton i Kontrollpanelen. Jag kommer inte ihåg vad det heter i XP men i Vista heter det Användarkonton.

 

Du har så rätt Cecilia. Och det är samma namn i XP som i Vista.

Vi får hoppas att jag kommer att få anledning att använda dessa uppgifter. Som det är nu så får jag inte ens upp någon inloggningsruta i den stationära när jag försöker nå den bärbara.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Hej

 

Fick du ordning på nätverket?

Hej!

När det gäller att hitta en konfiguration i XP: Nära nog icke. Trots att jag lagt ner åtskilligt med tid. Följt i princip alla de råd som finns i trådar som länkats här.

Det lilla framsteg jag gjort är att jag nu kan se resurserna på den bärbara när jag söker dem från den stationära.

Det som åstadkom den förändringen var:

 

I Egenskaper för ”Anslutning till lokalt nätverk” > Allmänt, lade jag till ”NWLink IPX/SPX/NetBIOS Compatible Transport Protocol” (via ”Installera” och ”Protokoll”) på bägge datorerna.

 

Resultat:

Bärbar > Stationär: Fungerar felfritt.

 

Stationär > Bärbar - Söker resurser via ”Mina Nätverksplatser”: Ett litet dröjsmål, sedan: Tom ruta. Inget visas.

Väljer istället: ”Visa datorer i arbetsgruppen”: Ett långt dröjsmål (runt 10 sekunder): För första gången (på länge) kommer jag så långt att jag kan se resurserna – de bägge datorerna i nätverket.

Klickar mig vidare för att komma till de utdelade resurserna (mappar). Lika lång väntan. Sedan dyker de upp.

Väljer en av dem. Mycket lång väntan (inget gott tecken), sedan meddelandet:

"\\datorn\mapppen är inte tillgänglig.... ....Det finns inte tillräckligt med utrymme på servern för att utföra detta kommando.

Sista raden var ett tag sedan jag såg. Ombyte förnöjer. Man hoppas att det kan ge någon ny ledtråd.

Gör dock ett nytt försök men från en annan mapp: Samma meddelande men med den numer välbekanta slutraden: ”Nätverkssökvägen kan inte hittas”.

 

tja, det där ger en liten inblick i hur det brukar se ut…..

 

Att pinga burkarna är inga problem (även "ipconig /all" stämmer bra om man jämför de bägge maskinerna). Har även kollat nätverkskablarna ytterligare en gång (samt växlat dem mellan maskinerna).

 

Det mesta pekar på mjukvarusidan. Förmodligen något som inte är som det skall med konfigureringen av protokolldelen (det var ju det tilldelade protokollet ovan som gjorde skillnaden)?

 

Inställningarna för "restrictanonymous" i registret nämns i Microsoft Support.

De är som de skall i mitt register (värde = 0).

Vad man kan fundera över är om inställningarna för ”restrictanonymoussam” är som de skall (värde = 1).

 

Enligt ”burceb” på sysopt är detta (värde = 1 för ”restrictanonymoussam”) INTE OK. Det skall till och med handla om ett virus han länkar till Symantec där man kan klicka sig vidare till en beskrivning av detta och sidan med åtgärder

 

”Ol’Tunsafun” synes i sitt svar på ”bruceb” hålla med och anser att TS skall göra följande inställningar i XP-registret:

 

Set restrictanonymous to "0"

Set restrictanonymoussam to "0"

and set everyoneincludesanonymous to "1"

 

Några poster ner påstår ”Ol’Tunsafun” dock att default settings för ovanstående nycklar skall vara:

 

restrictanonymous="0"

restrictanonymoussam="1"

everyoneincludesanonymous="0"

 

Han anger ingen källa men levererar brasklappen att dessa uppgifter är omtvistade i.o.m. att de två senare värdena inte används när det första är satt till ”0”.

 

Till detta skall man lägga säkerhetsaspekter (som jag är dåligt insatt i) och utifrån dessa ges helt andra riktlinjer i t.ex. PC-mag.com

 

Risken att detta drar iväg till oändliga varianter (utan att lösa problemet) börjar kännas som något att ta med i beräkningarna.

Är dock nyfiken till naturen och ogillar att släppa problem olösta - menar då att lösa det i XP (väntar med att ändra på routersidan tills jag helt tömt möjligheterna i XP [kommer ju att gagna andra som har samma problem} - eller blir tvungen för att jag bara måste ha nätverket igång bums).

 

Vore tacksam för kommentarer som rör registerinställningarna.

Samt varje annat tips som kan vara användbart i detta läge.

 

Edit.

Angående det virus som nämns ovan:

Gjorde en snabb samt en djup skanning med Avast (där alla parametrar i djuptestet är satta till högsta och noggrannaste prioritet).

Resulat: Inga infekterade filer.

Sökte även i "Sök" på "dabber" utan att få någon träff.

Redigerad av jbo

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Jag måste säga att jag beundrar din beslutsamhet. Det är en gedigen research du har gjort. Varför inte testa med mac adresser, bara för att se om det fungerar. Sedan kan du ju gå tillbaka och fortsätta på den andra vägen. Det tar ingen tid att göra inställningarna.

 

När det gäller ändringar i registret, så kan jag för lite för att börja laborera.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Jag måste säga att jag beundrar din beslutsamhet. Det är en gedigen research du har gjort.

Har nog ändå bara skrapat på ytan.

 

Varför inte testa med mac adresser, bara för att se om det fungerar. Sedan kan du ju gå tillbaka och fortsätta på den andra vägen. Det tar ingen tid att göra inställningarna.

Jodå, tanken har nog slagit mig så det ligger nära till hands.

I min Netgear har jag förövrigt redan gjort en sådan, eller kanske en liknande sådan, tilldelning för min NAS (FreeNAS som är den tredje datorn tilltänkt att införliva i nätverket), då jag reserverat ett särskilt IP till den som är knutet till dess MAC-adress.

Dessa inställningar görs i Netgear under ”LAN Setup” under rubriken ”Adress Reservation” och är ett enkelt ingrepp som följaktligen innebär att man reserverar en viss IP-adress knutet till en viss MAC-adress (och som man lämpligen namnger med resp. datornamn). Är det detta du menar när du föreslår tilldelning med MAC-adresser?

Något annat tillvägagångssätt känner jag inte till. Tipsa gärna om det är något annat du avsåg med ditt råd.

 

När det gäller ändringar i registret, så kan jag för lite för att börja laborera.

Men du, och andra, kanske kan kolla vad era värden är på dessa nyklar?

Adressen i registret är alltså: <HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa>

Vore intressant att jämföra.

(Kan f.ö. meddela att de ändringar av dessa värden, enligt rekommendationerna ovan, inte ledde till några förändringar när jag nyligen testade.)

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Hej, kom just att tänka på en sak. Jag har utgått ifrån att bägge datorerna är anslutna trådlöst. Det kanske inte stämmer?

 

Hur som helst. Tittade på en manual för DG834(finns ju flera versioner). Inställningen fanns i "Wireless settings" och "Setup Access List". Ip adress behövs inte skrivas in.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Hej, kom just att tänka på en sak. Jag har utgått ifrån att bägge datorerna är anslutna trådlöst. Det kanske inte stämmer?

 

Hur som helst. Tittade på en manual för DG834(finns ju flera versioner). Inställningen fanns i "Wireless settings" och "Setup Access List". Ip adress behövs inte skrivas in.

Tack för omtanken!

Nej, jag ansluter med kabel (nämner det ett par gånger i tråden). Men, ändå, var det det sättet att ansluta med MAC-adress som jag beskrev ovan som du avsåg med ditt tips tidigare?

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Tack för omtanken!

Men, ändå, var det det sättet att ansluta med MAC-adress som jag beskrev ovan som du avsåg med ditt tips tidigare?

 

Ja, och för trådlöst under Wireless Settings.

 

Men du, och andra, kanske kan kolla vad era värden är på dessa nyklar?

Adressen i registret är alltså: <HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa>

Vore intressant att jämföra.

 

Så här ser det ut hos mig

post-36233-0-21585200-1292924982_thumb.jpg

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Ja, och för trådlöst under Wireless Settings.

 

Tack! Då var den delen klar.

 

Ja, och för trådlöst under Wireless Settings.

Så här ser det ut hos mig

 

Tack för infon! Ser ut som om du kör Vista eller W7.

Så här ser det ut hos mig i XP Pro (för de två tidigare nycklarna är värdena alltså identiska, men sedan skiljer det ju en del - lär väl delvis bero på skillnaden av OS):

post-44543-0-92643800-1292951052_thumb.jpg

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Tack för poängen. Jag har både XP Home och Vista installerat. Så här ser det ut i XP.

 

Bara lite nyfiken. Kan du ansluta den bärbara trådlöst och se om det fungerar?

post-36233-0-05472000-1292964473_thumb.jpg

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Tack för poängen. Jag har både XP Home och Vista installerat. Så här ser det ut i XP.

 

Bara lite nyfiken. Kan du ansluta den bärbara trådlöst och se om det fungerar?

 

Ingen orsak.

XP Home och XP Pro är ju väldigt lika i dessa två jämförelser.

 

Och jodå, jag kan ansluta trådlöst om jag har något trådlöst öppet nätverk i närheten, vilket sällan är fallet i.o.m. att jag själv inte äger något sådant.

Senaste gången jag var ansluten trådlöst var i förra veckan då jag loggade in på Stockholms Statsbibliotek öppna nätverk, en gratistjänst för alla som skaffar ett lånekort. Ett bra ställe med många platser (vissa tider på dygnet) att i lugn och ro kunna slå sig ned och plugga, eller annat, med full tillgång till Internet.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×
×
  • Skapa nytt...