Just nu i M3-nätverket
Jump to content

RAID-volym försvunnen efter omstart


Shabbadang

Recommended Posts

Hej!

Har haft krångel med hårddiskar nu ett tag, men trodde att jag löst dem sedan igår, men det fortsätter att krångla. Konfigurationen just nu är:

C: 70 GB WD Raptor

D: 2 st Samsung 1TB i RAID1

 

Jag har kört Samsungs diagnosikprogram på D: och får svaret att de är felfria. Vid ett tillfälle fick jag dock ett fel på en av diskarna, men programemt lagar väl skadade sektorer förmodar jag.

 

De senaste veckorna har RAID-volymen krånglat så att jag fått återställa den. Det har stått Degraded i bios. Men denna gång så började det som vanligt med något felmeddelande från Adobe Acrobat (Jag jobbade med att titta på olika PDF-filer) och grafiken började svartna, bokstäver förll bort här och där. Felmeddelandet rörde minnet men eftersom det inte gick att fortsätta arbeta så startade jag om datorn. Efter omstarten så ligger diskarna var för sig och i Intel Matrix Storage Manager så står det inget om någon RAID-volym. jag får alltså inte ens möjlighet att bygga upp den igen. Det finns inte ett spår av RAID, inte i BIOS heller. Var lagras informationen om RAID? Finns det något på hårddiskarna eller är det bara i BIOS? Och hur kan det bara försvinna? Tyder det på dåligt batteri på moderkortet? (ASUS P5B deluxe). Finns det någon annan ide om vad som kan vara felet?

 

Tacksam för all hjälp.

Link to comment
Share on other sites

Informationen om RAID finns huvudsakligen på diskarna. I BIOS CMOS-minne finns information om RAID-nivå och ingående diskar. Att informationen försvunnit från BIOS kan bero på dåligt batteri. Eftersom du haft RAID1 så går det att bygga upp den igen då allt data finns på båda diskarna.

 

Fysiska fel på en disk går inte att reparera med mjukvara. Diskarna har ett antal reservsektorer, som kan ersätta skadade sektorer.

 

Dina problem kan bero på fel i RAM-minnet så kör Memtest86+ över natten för att kontrollera.

Link to comment
Share on other sites

Informationen om RAID finns huvudsakligen på diskarna. I BIOS CMOS-minne finns information om RAID-nivå och ingående diskar. Att informationen försvunnit från BIOS kan bero på dåligt batteri. Eftersom du haft RAID1 så går det att bygga upp den igen då allt data finns på båda diskarna.

 

Fysiska fel på en disk går inte att reparera med mjukvara. Diskarna har ett antal reservsektorer, som kan ersätta skadade sektorer.

 

Dina problem kan bero på fel i RAM-minnet så kör Memtest86+ över natten för att kontrollera.

 

OK, kanske dags då att byta batteri. Men betyder det att RAID-volymen kommer att försvinna igen när jag plockar ur batteriet? Jag håller på att bygga upp den igen i Windows via Intel Matrix Storage Console, och det verkar gå bra. Moderkortet är lite drygt tre år så det stämmer nog med att batteriet kan börja vara slut.

 

Förut när det har krånglat med RAID så har det i alla fall stått under startprocessen att volymen varit Degraded, men nu stod det helt enkelt Non RAID disk på bägge. Och hur kan den informationen som ligger på diskarna om detta bara försvinna? Märkligt.

 

När jag körde Samsungs disktest EStools med fullständigt genomsökande av ytan så fick jag ett felmeddelande på en av diskarna med servicekoden AJ41 RAM Error, så det kanske var relaterat till minnet, eller kan det vara diskens cacheminne som avses? Har sedan kört det långa testet igen på samma disk, men aldrig fått något felmeddelande igen. Jag gissar att det var en del krångel med glappande sladdar också. SATA-kablarna sitter ju inte stenhårt direkt och det var en del strul med sådant ett tag, att vissa sladdar höll på att lossna. (Fattar inte hur de kan göra en sådan dålig standard, men har sett att det finns sladdar med clips som sitter fast bättre.)

 

Ska köra minnestestet inatt så får vi se om det är något fel där. Tack för tipset.

Link to comment
Share on other sites

Brukar BIOS även glömma klockan? Om inte är det nog inte BIOS-batteriet.

 

Degraded RAID ringer en varningsklocka för mig. Indikerar att något är fel på arrayen och då troligen att ena hårddisken inte fungerar av endera anledningen. Något som definitivt bör undersökas omgående.

 

Felkoden du ger hittar jag inget om men eftersom det är EStools som givit den kan man anta att det är hårddisken som har problem.

 

Jag skulle testa följande

  • Kontrollera kablaget, framförallt eftersom du haft problem förut.
  • Köpa en ny hårddisk och introducera denna i arrayen och se om den går att bygga upp igen. RAID1 är ju redundant och om du ersätter den bråkande disken bör den kunna byggas upp igen om det nu inte är som så att även den andra disken i arrayen har skadats. Om nu inte hårddisken är skadad är det inte fel att ha tre diskar i en RAID1 array...

Link to comment
Share on other sites

Brukar BIOS även glömma klockan? Om inte är det nog inte BIOS-batteriet.

 

Degraded RAID ringer en varningsklocka för mig. Indikerar att något är fel på arrayen och då troligen att ena hårddisken inte fungerar av endera anledningen. Något som definitivt bör undersökas omgående.

 

Felkoden du ger hittar jag inget om men eftersom det är EStools som givit den kan man anta att det är hårddisken som har problem.

 

Jag skulle testa följande

  • Kontrollera kablaget, framförallt eftersom du haft problem förut.
  • Köpa en ny hårddisk och introducera denna i arrayen och se om den går att bygga upp igen. RAID1 är ju redundant och om du ersätter den bråkande disken bör den kunna byggas upp igen om det nu inte är som så att även den andra disken i arrayen har skadats. Om nu inte hårddisken är skadad är det inte fel att ha tre diskar i en RAID1 array...

Jag byggde upp volymen igen och nu verkar det felfritt! Har kollat av disken igen i EStools och får nu inget felmeddelande. Kanske satt den dåligt i kablaget då när jag fick felkoden? Man vet aldrig. Har också kört Memtest fullt ut och inget fel på minnet. Kanske kan allt trubbel tillskrivas glappa kablar?

 

En större förändring jag gjorde i samband med det här trasslet är att jag plockade bort en RAID-volym med två 500GB diskar. Jag uppfattade det som att nätagget på 520 W inte riktigt klarade av att hantera 5 diskar; det blev väldigt långa starttider innan alla diskarna drog igång. Och det tog även väldigt lång tid att stänga av datorn, eftersom alla diskarna skulle dra igång för att spara ner ramminnet i viloläget. Fick ofta vänta 20-30 sekunder från klick på startknappen/stäng av tills att dialogen var uppe. Det där är helt borta nu. Kanske kan det vara dålig strömförsörjning som har skadat diskarna för att de inte har gått igång tillräckligt snabbt?

 

PS klockan går som den ska, så jag låter batteriet sitta ett tag till.

Link to comment
Share on other sites

fem diskar? 520 W?

Vet ej....

 

I sig drar ju inte hårddiskar så värst mycket ström. Kan det vara som max kanske kring 10 W? Riktigt snabba diskar (Raptor) kanske drar mer? Men det gäller ju att nätagget kan ge den effekt till diskarna på den lina det är anslutna till.

 

men om systemet fungerar bättre med två färre diskar kanske det är där problemet legat. Sedan ska sägas, de RAID-kretsar som finns på många moderkort idag lär inte vara de bästa som finns och mycket av arbetet med RAID-funktionerna ska ske via mjukvara för dessa.

Link to comment
Share on other sites

fem diskar? 520 W?

Vet ej....

 

I sig drar ju inte hårddiskar så värst mycket ström. Kan det vara som max kanske kring 10 W? Riktigt snabba diskar (Raptor) kanske drar mer? Men det gäller ju att nätagget kan ge den effekt till diskarna på den lina det är anslutna till.

 

men om systemet fungerar bättre med två färre diskar kanske det är där problemet legat. Sedan ska sägas, de RAID-kretsar som finns på många moderkort idag lär inte vara de bästa som finns och mycket av arbetet med RAID-funktionerna ska ske via mjukvara för dessa.

Ja, jag gissar att det är en kombination av för klent nätagg och glappa kontakter. Förresten lina – du menar att det finns begränsad effekt på varje tåt som kommer ur nätagget? Ja, då kan det förstås vara där begränsningen sitter. Hade 3 diskar på en lina (inkl. Raptor) och 2 på en annan. Fast man frågar sig varför inte 520 W skulle räcka, men det handlar väl om toppbelastning som den inte fixat, då diskarna drar igång. Läste att en disk drar 15 W när den surrar igång. Aggregatet är ett Corsair och kostade en hyfsad slant, men troligen ska man lägga mer pengar och ha ett överdimensionerat nätagg om man vill köra fler diskar.

Tror inte det ska vara moderkortets konstruktion dock eftersom detta skulle vara ett av de bättre Asuskorten, då jag köpte det.

Link to comment
Share on other sites

Hårddiskar plockar väl energi från både 5 V och 12 V linan om jag minns rätt? 12 V borde vara för motorn som driver det hela och 5 V för elektroniken kan jag gissa. (kanske någon vet?)

Du får väl ta en titt på ditt nätagg och se vad det klarar av att genererar över de olika linorna samt tänka över vad du har för övriga delar i datorn.

 

Som sagt, i sig borde inte fem hårddiskar vara något problem kan jag tycka. räknar vi med maxeffekt på 20 W var när de arbetar blir det iofs 100 W som max. Frågan är dock vilken lina de drar effekten från. Har nätagget sex kontakter för SATA diskar borde det klara sex SATA-diskar.

Vad har du för grafikkort? Det och processorn är ju annars det som drar mest energi.

 

 

det jag menade med moderkortets RAID är att de inte är de snabbaste av jag hört. Dvs mycket aktivitet över flera RAID-arrayen kan gå långsamt om man jämför med ett dedikerat RAID-kort. Läst om, ej testat själv.

 

 

Som sagt, om datorn är stabilare nu och inte tappar RAID-arrayen då kan vi vet varför.

Link to comment
Share on other sites

Hårddiskar plockar väl energi från både 5 V och 12 V linan om jag minns rätt? 12 V borde vara för motorn som driver det hela och 5 V för elektroniken kan jag gissa. (kanske någon vet?)

Du får väl ta en titt på ditt nätagg och se vad det klarar av att genererar över de olika linorna samt tänka över vad du har för övriga delar i datorn.

 

Som sagt, i sig borde inte fem hårddiskar vara något problem kan jag tycka. räknar vi med maxeffekt på 20 W var när de arbetar blir det iofs 100 W som max. Frågan är dock vilken lina de drar effekten från. Har nätagget sex kontakter för SATA diskar borde det klara sex SATA-diskar.

Vad har du för grafikkort? Det och processorn är ju annars det som drar mest energi.

 

 

det jag menade med moderkortets RAID är att de inte är de snabbaste av jag hört. Dvs mycket aktivitet över flera RAID-arrayen kan gå långsamt om man jämför med ett dedikerat RAID-kort. Läst om, ej testat själv.

 

 

Som sagt, om datorn är stabilare nu och inte tappar RAID-arrayen då kan vi vet varför.

 

Grafikkortet är ett silent GeForce 7600 GS, sedan har jag tre 12 cm fläktar också, men de drar väl minimalt när de står på lägsta hastighet.

 

Nu har jag emellertid börjat fundera om åtminstone inte en del av problemen är mjukvarurelaterade. Jag vet inte om jag nämnde att i vissa lägen så tar minnet slut (jag har 3 GB RAM) och skärmbilden börjar vittra sönder, bokstäverns försvinner och jag får felmeddelande om att det inte finns minne tillräckligt för att spara en enkel Word-fil ens. Det inträffade nyss och datorn hängde sig i pricip. Dessförinnan noterade jag att det var mycket aktivitet i min Dropbox, som är ett slags FTP-program som automatiskt synkar en mapp på datorn med andra mappar hos andra användare, du känner säkert till det, det verkar ha blivit populärt på senare tid. Hos mig sammanfaller problemen faktiskt i tid med att jag installerade det och fick en mapp utdelad av en kollega, där han lägger en massa filer som tilhör projektet. Jag googlade på dropbox+memory+problem och fick en massa träffar. Det verkar alltså kunna finnas någon minnesläcka i programmet:

http://forums.dropbox.com/topic.php?id=17939

http://www.dropbox.com/help/144

http://www.macheist.com/forums/viewtopic.php?id=15588

 

Nu har jag tagit bort Dropbox från autostarten och så får vi se vad som händer när jag kör utan den.

 

Tidigare har jag kopplat bortfallet av bokstäver till typsnittshanteraren som lägger genvägar i Windows fontmapp till den plats där typsnitten lagras, D:, och om då D: börjar krångla så kan förstås inte typsnitten visas direkt. Men dels har jag lagt de vanligaste typsnitten i Windows fontmapp direkt och dels så har jag inga problem den D: just för tillfället, så det må ju vara något annat.

Link to comment
Share on other sites

Undras ifall problemen är relaterade. Vore intressant om du kan ta en skärmdump av datorn när "bokstäverna vittrar sönder".

 

Dropbox bekant men inte använt så mycket och har inte sett några minnesproblem. Har den installerad men ej att den autostartar. Men varför skulle Dropbox behöva så mycket minne? Det kan man undra. En liten klient med ett avtryck på några 100 kB borde räcka kan jag tycka!

Minnesläckor är inte kul

 

GF 7600 GS är ingen stor stömslukare, det borde finnas gott om utrymme för hårddiskar.

Nä, jag vet inte riktigt och kan bara önska dig lycka till.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...