Just nu i M3-nätverket
Jump to content

Startar om och startar om och startar om....


fr-dr-k

Recommended Posts

Kör Win Xp på en stationär dator som fungerar fint med undantag för att den är mcyket svår att få igång. Den startar om och startar om och startar om. Hinner olika långt varje gång, ibland hinner den börja ladda OS:et ibland inte. Ibland piper det till när den startar om ibland inte. Ibland fryser den och står och piper.
Ibland (rätt ofta) får jag upp en meny där jag kan välja olika alternativ för att starta datorn. "Starta Windows normalt" fungerar max en gång av tjugo medan olika varianter av "Starta datorn i felsäkert läge" fungerar varje gång...

Som sagt, när jag väl fått igång datorn så fungerar den bra (med undantag från ljudet som är väldigt frånvarande men det får jag ta som ett senare problem).

Tacksam för tips!

/fr-dr-k

Link to comment
Share on other sites

Det finns massor som kan vara fel. Filsystemet/disken kan vara på väg att ge upp på vissa delar där uppstartskritiska filer ligger så att om disken lyckas läsa går det bra och går det inte så misslyckas det.

Det kan vara annat hårdvarufel som är intermittent. Dåligt nätaggregat, dåliga kondensatorer på moderkortet kring processorn etc. Mer om hur man identifierar dåliga kondensatorer kan du läsa om och se bilder på http://www.badcaps.net/pages.php?vid=5

Det kan även vara drivrutiner/antivirus/brandvägg etc. som strular till uppstarten. I dessa fall brukar dock man kunna komma väldigt långt i uppstarten varje gång. Kraschar det redan då första Windows logotypen dyker upp på svart bakgrund så är det troligen inte det.

Det kan också vara minnesfel men då borde rimligen inte datorn funka fint om den väl lyckas boota och felsäkert läge borde inte heller funka varje gång.

När du lyckas boota datorn nästa gång (eller i felsäkert läge) ta kopia på allt du har av värde på hårddisken. Jag skulle sedan prova att installera om Windows och se till att göra en grundlig felsökning av hårddisken med något verktyg. Check disk som kommer med Windows funkar. Man måste se till att kontrollera ytan genom att välja alternativet att försöka rädda skadade sektorer. Denna felsökning tar riktigt lång tid om det finns fel på disken. Det kan ta över ett dygn om du har en disk på 500GB men är det få fel så går det snabbare men det tar fortfarande många timmar och till en början verkar det inte hända någonting innan första ynka procenten passerats.

Kanske har någon annan något bättre förslag på åtgärd innan ominstallation. Har man ingen annan hårdvara att testa med så har inte jag några bra tips så här på andra sidan av Internet.

Link to comment
Share on other sites

Jag tror mest på nätaggregatet eller moderkortskondensatorerna, lite beroende på hur gammal datorn är och om man har stoppat in mer hårdvara under tiden eller uppgraderat grafikkort.

För att testa hårddisken så är det säkrare med det testprogram som tillverkaren av den har på sin webbplats. Om du inte vet vilken tillverkare det är av hårddisken så kan man ofta få fram det genom att titta i Enhetshanteraren (högerklick på Den här datorn - Hantera), där brukar det stå åtminstone ett artikelnummer för hårddisken som man kan googla på för att få fram tillverkaren.
Det är oftare lättare att gå via sidan http://www.tacktech.com/display.cfm?ttid=287 för att hitta testprogrammet än att leta på tillverkarens webbplats.

Link to comment
Share on other sites

Tack för tipsen!

Datorn har snart fem år på nacken.
Nätaggregatet är precis bytt.
Processorfläkten är bytt.
Grafikkortet är inte bytt.
Operativsystemet är nyligen ominstallerat.
Har upptäckt att boot.ini saknas. Kan det ha något med saken att göra?

Brukar nästan aldrig stänga av datorn men nu när den varit avstängd i ett dygn så skriker grafikkortsfläkten när jag startar (men den snurrar). Den fläkten är inte ens ett år.

Backup tas varje natt till extern HD på all data som jag är rädd om.

Link to comment
Share on other sites

Det som får mig att tro att det inte är hårdvarurelaterat är att det utan undantag går att starta datorn varje gång jag väljer någon form av felsäkert läge. Eller tänker jag fel där? Finns det hårdvara som inaktiveras vid felsäkert läge? Hårddisken måste ju vara med i spelet hur som helst...

Link to comment
Share on other sites

I felsäkert läge så är det färre drivrutiner som startas vilket gör att en del hårdvara inte kommer igång samt att grafiken körs med en mycket enkel drivrutin vilket gör att grafikkortet drar mindre ström. Med ett 5 år gammalt moderkort så är det lämpligt att kolla kondensatorerna som JoAr skrev.

Link to comment
Share on other sites

Ok, samtliga kondensatorer på moderkortet kontrollerade. Alla ser friska ut.

Har för mig att man kan starta ngn form av loggning vid boot så att man i efterhand kan se vart bootningen haltar. Uppenbarligen är det ju något av det som är inaktiverat vid felsäkert läge som ställer till problem.

Link to comment
Share on other sites

Var kan man läsa vad som är intaktiverat vid felsäkert läge eller någon form av jämförelse mellan normal start och felsäkert läge?

Link to comment
Share on other sites

det är inte så att det finns flera uppstarter i samma logg?

Är du säker på att det nya nätaggregatet kan leverera tillräckligt med ström på 12V?

Link to comment
Share on other sites

det är inte så att det finns flera uppstarter i samma logg?

Är du säker på att det nya nätaggregatet kan leverera tillräckligt med ström på 12V?


Ja, enligt Speedfan så levererar den tillräckligt med ström på både 12 och 5 V. Har även kört nätagget en tid innan det här felet dök upp.

Har laddat hem ett diagnosverktyg för hårddisken. Provade först med en windowsvariant men då får jag felmeddelandet att "administratören inte tillåter den typen av installation" eller något liknande, kommer inte ihåg exakt. Jag är dock inloggad som admin så jag antar att det är något som är spärrat när man är i felsäkert läge (går det att komma förbi?).
Provade då med att ladda hem en DOS-version av diagnosverktyget i form av en ISO-fil som jag brännde på en annan dator. Den går dock inte att köra! Går att boota från den skivan men när den startar kommer det upp en text som säger att det saknas en fil på skivan...

Har kört fast rejält här nu, tacksam för alla tips!
Link to comment
Share on other sites

Med SpeedFan så kan du inte se att det levereras tillräckligt med ström just under uppstarten. Du har ju inga problem när datorn väl är igång och SpeedFan kan läsa av spänningsnivåerna.

Det är inte alla installationer som fungerar i felsäkert läge. När det gäller ISO-filen så kan det ha blivit något fel vid nedladdningen.

Link to comment
Share on other sites

Med SpeedFan så kan du inte se att det levereras tillräckligt med ström just under uppstarten. Du har ju inga problem när datorn väl är igång och SpeedFan kan läsa av spänningsnivåerna.

Det är inte alla installationer som fungerar i felsäkert läge. När det gäller ISO-filen så kan det ha blivit något fel vid nedladdningen.


Vad gäller strömmen så borde inte det ställa till problem även vid uppstart av felsäkert läge?

Ska prova att ladda ner och bränna om ISO-filen igen.
Link to comment
Share on other sites

Har nu provat att ladda ner och bränna om ISO-filen till diagnosskivan. Samma fel igen. Den klagar över att den saknar en fil med licenstext. När jag matar in skivan i en annan dator och tittar på vad som finns på den så finns just den filen som efterfrågas på just den plats den ska vara...

Link to comment
Share on other sites

Provade att göra en sk "Clean boot" och fick då en blåskärm med detta meddelande:

"An error..... bla. bla. bla.....
DRIVER_IRQL_NOT_LESS_OR_EQUAL

If this.... bla. bla. bla.

*** STOP: 0x000000D1 (0x00000174, 0x0000007, 0x000000001, 0xF749C9FC)

*** atapi.sys - Address F749C9FC base at F749A000, DateStamp 4802539d"

Link to comment
Share on other sites

Vet inte vad du menar med Clean boot.

atapi.sys är en grundläggande drivrutin i Windows för hantering av hårddiskar och CD/DVD-enheter, i alla fall verkar det så vid lite googling. Om man har Daemon Tools eller Alcohol 12% installerat så verkar det vara ganska vanligt att man får problem med atapi.sys.

Link to comment
Share on other sites

Vet inte vad du menar med Clean boot.

atapi.sys är en grundläggande drivrutin i Windows för hantering av hårddiskar och CD/DVD-enheter, i alla fall verkar det så vid lite googling. Om man har Daemon Tools eller Alcohol 12% installerat så verkar det vara ganska vanligt att man får problem med atapi.sys.


Clean boot: http://support.microsoft.com/kb/310353

Ska prova att koppla bort mina CD-enheter (en och en) samt prova att avinstallera Daemon Tools (som jag iofs har haft länge utan problem tidigare men man vet ju aldrig...).
Link to comment
Share on other sites

Tack, felsäkert läge alltså. Ett enklare sätt att komma till felsäkert läge är att trycka F8 upprepade gånger under uppstarten och välja felsäkert i menyn som då kommer fram.

Link to comment
Share on other sites

Stort flin Problemet löst!

En kollega tipsade om att koppla ur CD-spelaren när han hörde att atapi.sys nämndes på blåskärmen. Det räckte för att datorn skulle hoppa igång som vanligt!

Jippi! Dans
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...