Just nu i M3-nätverket
Jump to content

Får ej rätt bredbandshastighet


Dosenius

Recommended Posts

Hej!

 

Jag laddade ner TPTest efter inlägg i PC För Alla tidigare i höst. Jag abonnerar på 8 Mbit, men fick till min förskräckelse endast ut 0,3 Mbit. Jag ringde naturligtvis till ComHem och klagade och de försökte hjälpa mig, men inget fungerade. Häromdagen var en bekant förbi och av nyfikenhet bad jag honom prova min anslutning med sin dator. Han fick naturligtvis ut 7,6 Mbit. Jag har nu provat att stänga av alla program jag har i autostarten om det är någon mjukvara som ligger och begränsar (mig veterligen har jag inte installerat något dylikt), men utan resultat. Nätverkskortet ska hålla för upp till 10Mbit.

Är det någon som har en idé om vad det kan vara för problem?

 

Link to comment
Share on other sites

Mikael Andersson

 

Testa att ändra lite i registret. Vad har du för OS? Du kan ju skaffa ett nytt gigabitnätverkskort kostar bara 200-350kr Comhem kör ju med 100Mb och du med 10Mb.

 

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

TcpWindowSize

Nyckel: Tcpip\Parameters

Värdetyp: REG_DWORD - Antal byte

Giltigt intervall: 0 - 0xFFFF (513920)(1027840)(2055680)

Standard: Det minsta av 0xFFFF

eller

(Det största av fyra gånger den maximala TCP-datastorleken i nätverket

eller

8192 avrundat uppåt till en jämn multipel av nätverkets TCP-datastorlek.)

Standardvärdet är 8760 för Ethernet.

Beskrivning: Den här parametern avgör TCP-mottagningsfönstrets maximala storlek på datorn. Mottagningsfönstret anger hur många byte en sändare kan överföra utan att ta emot en bekräftelse. I allmänhet förbättrar stora mottagningsfönster prestanda vid överföring i nätverk med höga värden för (fördröjning x bandbredd). För högsta effektivitet måste mottagningsfönstret vara en jämn multipel av TCP-MSS (Maximum Segment Size).

 

Increase Internet Download Connections

 

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings

MaxConnectionsPer1_0Server Setting for Value Data: [0000000a]

MaxConnectionsPerServer Setting for Value Data: [0000000a]

 

http://www.speedguide.net/analyzer.php?DATA_OFFSET=40&TCP_Options_string=020405b401030305&IP_MTU_DISCOVER=1&WIN=64240&RWIN=2055680&MSS=1460&SCALE=5&TTL=116&TSOPT=0&SACK_PERM=0&IP_TOS=0&IP=83.251.100.8&timestamp=1162231803

 

Link to comment
Share on other sites

  • 11 months later...

Ett gammalt svar, men jag undrar om detta tips inte syns på alla datorer.

Jag har två stationära och en laptop, bara ena går via lina de andra trådlöst och det är bara på den via kabel jag kan se TcpipWindowSize

 

Min hastighet kommer bara upp till ca 39% av bandbredden på 100Mbit/s

 

Verkar inte vara rätt inställt enligt speedguide, men hur ska man som lekman kunna begripa vad man ska ändra.

 

Frågorna är alltså skall detta finnas på varje dator?

Ska det vara inställt lika på varje dator?

Finns det någon guide hur man ställer in?

 

 

Link to comment
Share on other sites

Mikael Andersson

Dosenius Har ditt problem lösts sig, vad var felet?

TcpWindowSize ska synas/ändras på varje dator. Vilken dator kommer upp i 39%, kan någon komma upp i 100%. De trådlösa lär ju aldrig komma upp 100Mbps om du inte har det nya 802.11n förstås. Jag tror att du har 802.11g som högst och då är maximum 54mbps.

Om en dator kommer upp i 100Mbps så är det inte fel på modemet sätt kabeln från modemt i varje dator och testa hastigheten. Om du sätter alla datorer i samma rum blir det trådlösa snabbare och bättre kontakt då?

http://www.speedguide.net/read_articles.php?id=157 trådlöst är inget bra :( men 802.11n är förhoppningsvis bättre

 

Link to comment
Share on other sites

Saken är den att jag tidigare hade BBB, i juli blev vi tvångsanslutna till Tele2 som tog över ansvaret, med utlovad samma hastighet 100Mbit/s.

Det började direkt krångla (detta var även nytt för tele2) tappar signalen och det går segt. De skyllde på min router så jag köpte en ny Bielkin, går fortfarande segt och tappar kontakten rätt vad det är, även när jag kör kabel.

 

Jag sitter vid datorn som går med kabel via routern och den kommer upp i 39%bandbredd, de trådlösa är ibland bättre , ibland sämre.

Tcp ligger i snitt upp på 9Mbit/s och ner 36, UDP på upp 11Mbit ner 23 Mbit.

 

Enligt Tele2 så kan man inte mäta så snabba anslutningar med tptest utan jag fick gå till undermapp på sunet och hämta stora filer, då låg nedladdningen på 1Mbit/s och gick jag direkt från vägg till dator kom jag upp i 1.6Mbit/s.

När jag pingar så får jag i snitt 12ms, vilket tele2 anser inte är deras fel att jag har seg svarstid, alltså gör det inget mer.

 

Efter ytterligare klagomål, ska de komma hit i morgon och kolla allting, men de påstår att felet kan ligga hos mig och mina inställningar och då kan det ju bli dyrt.

 

Så jag är mest fundersam över om det kan knasa sig så mycket för att inställningar är fel. Det är ju inget som man normalt sett håller på att mixtrar med själv.

 

Oftast när jag hämtar hem något från nätet oavsett vad och var så kommer jag aldrig upp till 1Mbit/s

 

Det är oftast bara denna dator som går jämt, de andra används sällan samtidigt.

Nu när jag kollade så såg jag inte TcpWindowSize på de andra datorerna, men det gick visserligen trådlöst om det spelar någon roll.

 

Har försökt läsa länken du gav, problemet är nog att jag inget förstår av vad som menas, teknisk engelska är inte direkt mitt område :-).

 

Just nu säger min speedtest

« SpeedGuide.net TCP Analyzer Results »

Tested on: 10.09.2007 09:57

IP address: 83.191.xxx.xxx

 

TCP options string: 020405b401030305

MSS: 1460

MTU: 1500

TCP Window: 2055680 (multiple of MSS)

RWIN Scaling: 5

Unscaled RWIN : 64240

Reccomended RWINs: 64240, 128480, 256960, 513920

BDP limit (200ms): 82227kbps (10278KBytes/s)

BDP limit (500ms): 32891kbps (4111KBytes/s)

MTU Discovery: ON

TTL: 116

Timestamps: OFF

SACKs: OFF

IP ToS: 00000000 (0)

 

 

 

Link to comment
Share on other sites

"De skyllde på min router"

Har du testat med att koppla in datorn direkt utan router? I varje fall om routern kostade kring 500 kronor så är det ju stor risk för att den inte klarar av en överföring med högre hastighet än du får.

 

"cp ligger i snitt upp på 9Mbit/s och ner 36, UDP på upp 11Mbit ner 23 Mbit."

Stora skillnader mellan UDP och TCP kan bero på att man har någon okänt program (spionprogram) i datorn som använder internet. Vad har du för brandvägg?

 

Link to comment
Share on other sites

Mikael Andersson

Om det gick bra innan bytte av bredbandsleverantör och sedan gick det sämre efter byttet då är det ju deras problem hoppas bara att du inte ändrat något i registret eftersom du inte förstår så kan leverantören komma och kolla på din dator hur mycket de vill klart det är deras problem om du inte gjort några ändringar.

Har du TPtest 5.02 så kan du testa alla uppkopplingar som är snabbare än 100kbit/s upptill 100Mbit/s. När du testar så kör utan router eller trådlöstnätverk, alltså kabeln direkt in i datorn du testar sen kan du skicka testet till din leverantör och kopiera in det hit om du vill.

http://www.tptest.se/lista_artiklar.asp?lngCategoryId=1308

http://www.tptest.se/mallar/sv/artikel.asp?lngCategoryId=1315&lngArticleId=1886

[inlägget ändrat 2007-10-09 17:17:25 av Mikael Andersson]

Link to comment
Share on other sites

Jag har testat flera gånger både med och utan router, det har oftast inte gjort några större skillnader.

Problemen har som sagt varit sedan Tele2 tog över och från början funkade det inte heller direkt från vägg, men sedan fixade de sig sa de och la över resterande problem på mig.

 

Jag köpte en Belkin wireless G Plus

enligt försäljaren var den bra

http://catalog.belkin.com/IWCatProductPage.process?Product_Id=179477

 

N tekniken är väl inte utbyggd än, så det får komma senare. Innan hade jag en D-Link men den ville inte funka med Tele2.

 

Jag tror inte jag har något spionprogram, inget visar på det iaf. Jag kör med F-secure Internet security och brukar vara vaksam med allt jag hämtar hem.

 

 

Link to comment
Share on other sites

Mikael Andersson

 

Om du inte har gjort ändringar i regedit så kan jag bara se att det är deras problem att se till att du får dina 100Mb. Har du frågat grannarna låna ett modem så det inte är fel på modemet. Jag har ett modem som är konstigt ger bara lite fart, kanske ditt modem är kast som mitt ena.

 

Link to comment
Share on other sites

Jag kan inte hitta någon specifikation av Belkin-routerns throughput.

 

Kolla igenom vad som är godkänt i brandväggen en extra gång.

 

Link to comment
Share on other sites

Först tack för att ni tar er tid att svara, jag försöker begripa så mycket som möjligt innan teknikerna kommer imorgon, så de inte kollrar bort mig totalt :-)

 

Jag hade inga problem med BBB, det kanske inte gick i 100Mbit/s, vilket det sällan kommer upp till, men jag upplevde inget sirap som nu. Det går snabbare hos sonen som bara har 8Mbit/s.

 

Nej jag har inte ändrat i registren, bara tagit skärmdumpar.

 

Har kört åtskilliga tptest3 med och utan router, skillnaden har inte varit så stor.

Körde tp5 nu och då blev det lite mer skillnad.

 

Via router med kabel

TCP nedströms : 32.66 Mbit/s

 

TCP uppströms : 9.56 Mbit/s

 

UDP nedströms : 11.78 Mbit/s

 

UDP uppströms : 11.42 Mbit/s

 

Med kabel direkt från vägg till dator blev det

 

TCP nedströms : 40.18 Mbit/s

 

TCP uppströms : 9.44 Mbit/s

 

UDP nedströms : 25.13 Mbit/s

 

UDP uppströms : 11.37 Mbit/s

 

Om det spelar någon roll så var ingen av de andra datorerna aktiva eller igång under mätningen.

 

 

 

Link to comment
Share on other sites

 

Glömde

bandbredden med router 39.32Mbit/s

utan router 52.67Mbit/s

 

Grannarna har bara köpt 10Mbit som vi kunde välja som alternativ, så det är nog inte jämförbart, sedan kör de nog bara direkt i vägg.

 

skämsigt att säga men jag vet inte vad som menas med throughput.

 

Men jag ska köra en extra gång med spionkoll. Men eftersom det blir dåliga resultat även på min bärbara som jag knappt har några program i alls så tvivlar jag på att det är något spionprogram som ställer till det.

 

 

 

Link to comment
Share on other sites

Inte behöver du skämmas för att du inte vet vad throughput är, det är samma sak som överföringshastighet, max hastighet som routern kan hantera när den ska föra över data från internet-sidan till dator-sidan (eller tvärtom).

 

Det var väldigt ovanligt att TCP-hastigheten är högre än UDP-hastigheten.

 

Link to comment
Share on other sites

 

Hej,

Ursäkta att jag inte svarat, jag åkte på ryggskott igår och har svårt att röra mig.

Jag blev inte klokare, teknikerna testade TP test3 med sin dator och kabel direkt i vägg och kom upp till 98Mbit/s nedströms. Med min laptop blev det drygt 80.

Vi testade även mina kablar så det höll sig till ungefär samma värden.

Detta bevisade för dem att det fungerar i jacket, men för mig bevisar det också att det svajar väldigt mycket eftersom jag har åtskilliga skärmdumpar som visar det.

Det är nästan så jag tror att de mixtrat med ledningen när de skulle hit.

Jag ska följa upp detta ett par dagar för att kolla, men har lite svårt att göra det med ryggskottet.

 

Mot Sunet blev det drygt 2MB i nedladdning, vilket tydligen motsvarade 30Mbit, han sa att man inte kan komma upp så mycket mer på enskild nedladdning. Om jag däremot testar flera nedladdningar så kan de tillsammans komma upp i närmare 100Mbit/s.

Det var inte heller bra att mäta mot Sunet då de inte hade den kapaciteten, men det är ju det ställe de själva använder för mätning nedströms.

(jag begriper inget)

Sen påtalade han att det faktiskt inte var så många som tillät/erbjöd 100Mbit, därav kan jag inte heller få det när jag laddar ner, är man dessutom många på samma ställe så blir det segt.

 

Routern tar bort en del i hastighet vilket jag ska kolla om det går att ändra någonstans.

I övrigt tycks jag få nöja mig med att, visst de säljer 100Mbit, men att man sedan kan utnyttja det är en annan sak. Huvudsaken är tydligen att det finns någon mätpunkt ( inte surfning och nyttjande)som kan uppvisa hastighet som ligger i närheten av vad som utlovats.

 

 

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...