Just nu i M3-nätverket
Jump to content

Går inte att installera winXP


Lurking-Ghost

Recommended Posts

Lurking-Ghost

 

Jag har fått ett underligt problem i samband med att jag har köpt en ny disk.

 

Av en slump upptäckte jag att jag inte kan installera Windows XP på den nya disken som är en WD3200SE Caviar. Problemet uppkommer om disken har blivit formaterad och har filsystem.

 

När man försöker boota med WinXP skivan så kommer den till "Datorns maskinvarukonfiguration kontrolleras..." och strax efter det så blir det helt svart på skärmen och inget händer.

Tar man bort partionen och låter disken vara oformaterad, ja då funkar det perfekt.

 

Installerar jag WinXP, och försöker boota igen med skivan så funkar det inte. Vilket innebär stora problem i framtiden om man skulle behöva boota från skivan.

 

Jag har letat på WDs hemsida efter information, besökt microsofts knowledge base utan resultat.

Dragit bort alla diskar och enheter förutom moderkort, hårddisk, 1 cd enhet och grafikkort, för att verkligen utesluta att det inte är någon annan del som spökar.

 

Datorns BIOS känner igen disken också, och visar rätt kapacitet (320 GB).

Mina misstankar ligger mot att disken är så stor, men jag är inte säker, då jag inte hittar relevant information.

 

Är det någon här som känner till vad problemet kan vara ?

 

Link to comment
Share on other sites

MagicalBengt

Hm. Erfarenheten säger:

1) Uppdatera BIOS till senaste. Jag vet inte vad du har för moderkort, men jag har varit med om att korten identifierat en Satadisk korrekt utan att kunna hantera den korrekt med en gammal biosversion.

 

2) Prova att sätt disken i en annan konfiguration d.v.s byt port eller bygla om ifall den är IDE.

 

3) På mitt ASUSmoderkort fanns extra IDEportar (inte bara de vanliga 2). Jag kopplade min CD-enhet till en av dem och försökte installera WinXP på min WD2500KS. Installationsprogrammet hängde sig gång på gång. Det visade sig att de extra portarna krävde drivrutiner som laddas i windows och att det inte gick att installera från dem (även om installationsprogrammet startade). Ett byte av kabel till de ordinarie IDEportarna löste problemet den gången.

 

Biosupdate är mitt intiutiva tips. Glöm inte att läsa säkerhetsföreskrifterna med biosflashing noga, jag tar inte ansvar för vad du hittar på om du missar en backup =). Lycka till!

 

[inlägget ändrat 2006-08-01 11:08:46 av MagicalBengt]

Link to comment
Share on other sites

Lurking-Ghost

1. Bios är av den senaste. Dell Bios REVA06 från 2003.

Har uppdaterat den då, och har kollat om det finns nyare, men icke.

 

2.Har bara 2 IDE portar på moderkortet.

IDE Kanal 1 för hårddiskarna, IDE kanal 2 för CD rom enheterna. Har även provat att bygla till Master, etc etc. Har inte hjälpt. Det enda som löser problemet är att starta med en helt oformaterad disk, eller med WD:s Data Life verktyg.

 

 

Jag har börjat komma lite på spåren något som heter DDO Dynamic Drive Overlay. Det verkar som den kan spöka, jag använde WD:s Data Life verktyg för att sätta upp filsystem och partionera disken för windows XP SP2. Då funkade det att installera.

Nu håller jag på och installerar XP, och skall därefter testa att formatera om utan att använda Data Life och se vad som händer.

 

Backups har jag gott om :) Har även färdig XP disk som jag kan använda om jag inte lyckas.. Så jag kommer inte springa efter dig om något går snett ;)

 

 

 

 

 

 

Link to comment
Share on other sites

MagicalBengt

Aha. Gott att du har backups och andra möjligheter. Då blir problemet intressant och inte en krisartad kamp mot klockan som kan inträffa vid vältimade haverier.

 

Det är välkänt att Windows XP har uselt stöd för SATA i installationen och även en del speciella disk/IDE kombinationer, vissa controllers är värre än andra. Således kan det ligga något i att komma runt viss typ av diskaccess (som att skapa filsystem och partitionera) från xpinstall genom att använda WD:s diskverktyg. Fick göra likande med en Maxtor Satadisk i höstas.

 

Link to comment
Share on other sites

Lurking-Ghost

Har testat nu att formatera med windows installationsprogram, och det funkade inte att installera om windows efteråt.

 

Så uppenbarligen är det något lurt.

 

Har försökt att se hur jag kan använda Data Life i framtiden för att exempelvis editera en partion, men inte en annan. Tyvärr så går det inte, så du kan tänka dig vad problemet blir om jag har 2 partioner en på 290 Gb och en på 30 Gb.

 

Som det ser ut nu, verkar det inte finnas någon annan lösning än att jag lägger den nya disken som en lagringsenhet, vilket är otroligt synd då den är dubbelt så snabb som 80 Gigaren som satt innan och 3 gånger så snabb som 100 gigaren är (orginaldisken som följde med datorn).

 

Tråkigt att jag var så eftertänksam och köpte återigen WD då jag är säker på att det har fungerat förr... Men icke sa nicke.. Alltid är det något nytt problem.

 

Skall försöka ett par kombinationer till, sen får de va. Får lägga in den som en masslagringsdisk och låta det vara så.

 

 

Link to comment
Share on other sites

MagicalBengt

Hm, nått är lurt som sagt. Om problemet gäller att editera partitioner är alltid Symantec Partitionmagic ett hett tips. Det finns nog vissa options att köra direkt från CD som kan behövas när man ska installera OS. Annars finns det ju Ultimate BootCD http://www.ultimatebootcd.com/download.html

 

Där finns en del partitioneringsverktyg har jag för mig som även klarar större diskar och NTFS. Gott att du har en lösning nu iallafall, om du hittar det egentliga problemet och en lösning så är jag intresserad av att lägga den på minnet! =)

 

Link to comment
Share on other sites

Lurking-Ghost

 

Tack så jättemycket :D

 

Har kollat om det går att förbereda disken med DLT och sedan installera winXP och därefter formatera och installera om XP, och den funkar. Men då får man INTE ta bort partionen, gör man det så funkar det inte.. Så det verkar som något XP gör med enheten inte riktigt fungerar med dess egen installation.

 

Nu har jag ett svårt beslut att fatta. Men tack vare länken som jag fick av dig så kan jag fortsätta experimentera och se vilka lösningar jag har.. När jag har hittat en bra lösning så lägger jag upp den här..

 

Jag vill iaf att den nya disken skall vara primär windows disk, då den är snabbast, och tystast av de övriga två WD diskar jag har.

 

Detta skall bli intressant.

 

Link to comment
Share on other sites

Lurking-Ghost

 

Jag har äntligen lokaliserat vad problemet beror på exakt. Och jag kan endast se att det är Windows XP installationsprogram som inte är kombitabelt med Windows XP diskhantering.

 

Jag tog en titt på hur DLT satte upp disken, 1 Primär partion och en utökad partion.

Och försökte göra samma sak med diskhanteraren. Gjorde en primär partion, därefter en utökad partion och därefter en logisk partion.

Funkade inte då heller. Så uppenbarligen är det något windows gör.

Normalt har jag alltid primära partioner på alla 4 diskarna.

 

Jag sätter denna nya disk som en extra lagringsenhet i datorn och låter det vara så. Lägger växlingsfilen på den och på så sätt drar jag nytta av den högre hastigheten på disken.

Synd att windows inte kan hantera så stora diskar i installationsprogrammet.

 

Link to comment
Share on other sites

MagicalBengt

Hm, intressant. Det kanske är läge att maila Microsoft och fråga. Om man orkar ta sig igenom supportjungeln vill säga. Att WinXP installationen inte har stöd för så stora diskar är inget jag hört tidigare och det verkar lite underligt. Men men, du verkar har ringat in problemet och jag har nog inget förslag förutom Microsoft att gå vidare på. Det verkar ju som om det är mjukvaran som är problemet.

 

Intressant läsning dock, om du skulle råka hitta mer info eller få svar från annan support så vore det kul att läsa här!

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...