Just nu i M3-nätverket
Gå till innehåll
HARS

fnuttar i echo

Rekommendera Poster

nu går det trögt igen...

har har jag ju en massa fnuttar i det som jag skriver ut med echo, och det gilas inte... hur ska jag skriva för att få det att funka?

 

PureCoverage run:<br>

<?php if ("yes" == $row["pucov_exekv"]) {

 

 

echo( "<INPUT TYPE="RADIO" NAME="pucov_exekv" VALUE="yes" CHECKED> <INPUT TYPE="RADIO" NAME="pucov_exekv" VALUE="no">" ); //den här raden gnälls det på

 

} else {

 

echo( "<INPUT TYPE="RADIO" NAME="pucov_exekv" VALUE="yes"> <INPUT TYPE="RADIO" NAME="pucov_exekv" VALUE="no" CHECKED>" );

 

} ?>

 

det bör väl vara dubbelfnuttarna so ställer till det, eller? tacksam för hjälp!

 

/Måns

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

För att skriva ut dubbelfnuttar, skriv \"

Exempel:

echo "<input type=\"radio\" name=\"ja\" value=\"ja\" checked>"

 

- Henrik

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

När du startar en textsträn med " så avslutas den med ". Så när du skriver

"<INPUT TYPE="RADIO"...";

så avslutas textsträngen vid " innan RADIO. PHP fattar inte vad RADIO är och klagar. Men om du skriver

echo( '<INPUT TYPE="RADIO" NAME="pucov_exekv" VALUE="yes" CHECKED> <INPUT TYPE="RADIO" NAME="pucov_exekv" VALUE="no">' );

Dvs enkelfnuttar ' så hanteras ej " som avslut av sträng.

 

Eller så kanske man kan göra som Zirius föreslår.

 

 

 

__________________________________________________

blueluna

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Eller oxå avslutar du php koden med ?> och skriver ut det som vanligt i HTML utan echo.

 

Sedan börjar du skriva php igen efter att ha startat det med <?

 

-Bj

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

eller så kan man helt enkelt byta ut alla dubbelfnuttar i html koden till enkelfnuttar, tex såhär: <INPUT TYPE='RADIO' NAME='pucov_exekv' VALUE='yes' CHECKED>

 

det går oxå bra, och ibland behöver man inte ha fnuttar alls, fast då kanske det inte funkar så bra med gammla browsers, men men...

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

tack till er alla! fick tips om den lösning som bjorn föreslog, så jag körde med det å det funkade ju galant. tackar!

 

 

 

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×
×
  • Skapa nytt...