Just nu i M3-nätverket
Jump to content

Excel


Znorkel72

Recommended Posts

Jag håller på att skapa ett räknngsformulär, där jag använder funktionen "ANTALV" för att räkna ihop antalet värden i vissa celler, men jag upptäckte att den även tolkar ett mellanslag som ett värde, eftersom inte mellanslaget syns i mina ögon så kan jag lätt bli lurad eftersom den räknar med det som ett värde. Hur gör jag för att den endast ska räkna "synliga" värden

Link to comment
Share on other sites

Den enklaste varianten är att räkna bort alla celler som är=mellanslag.

=ANTALV(A1:A6)-ANTAL.OM(A1:A6;" ")

 

Det här sättet har en del uppenbara brister. Som exempel så räknas en cell med 2 mellanslag ...

 

Woops, kollade just hjälpen. Det räcker att du tar bort v:et.

=ANTAL(A1:A6)

gör det du vill.

Det är väl helt logiskt?

Antal räknar bara sifror

Antal_värden räktar allt.

 

Om du kommer på logiken i det där kan du väl förklara för mig.

/Manus

 

Link to comment
Share on other sites

Tack för det svaret, funkar perfekt. Nu kommer nästa del i mitt problem.I cell B5-P5 kan man fylla i siffror, cell S5 1 siffra och Cell T5 ska känna av om S5 finns i B5-P5. =EXAKT(B5:P5;S5) funkar inte

 

 

Link to comment
Share on other sites

Det här borde fungera (finns förmodligen ett enklare sätt):

=ANTAL.OM(B5:P5;S5)

Eller, lite plottrigare:

=OM(ANTAL.OM(B5:P5;S5)>0;"Ja";"Nej")

 

/M

(som fortfarande inte förstår logiken bakom Antal och Antalv)

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...