Just nu i M3-nätverket
Gå till innehåll
happyfejs

Ändra teckenuppsättning endast för några rader

Rekommendera Poster

Jag har några rader med japanska tecken som inte funkar eftersom jag har en utf8 uppsättning.

 

Japanska tecken går under shift_jis uppsättning

 

Kan man ändra det på endast de rader som ska vara japanska?

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

hmm, märkte att det inte funkade med shift_jis heller, nån som vet hur man visar japansk text och engelsk text på samma sida?

 

EDIT:funkar bra i Firefox men inte i andra webbläsare som IE och Chrome

Redigerad av happyfejs

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Det är väl bara att köra på? B)

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">
<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<meta http-equiv="Content-Language" content="sv,en,ja">
</head>

<body>
<h1>Olika språk</h1>
<p>Normalt sätt är texten på denna sida på svenska</p>
<p>Vissa ord är dock japanska: <span lang="ja">私はガラスを食べられます。それは私を傷つけません。</span></p>
<p>Andra ord kan vara på engelska: <span lang="en">The quick brown fox jumps over the lazy dog</span></p>
</body>
</html>

 

Läsvärt:

http://www.w3.org/TR...l4/charset.html

http://www.w3.org/TR...ct/dirlang.html

http://sv.wikipedia.org/wiki/ISO_3166

Redigerad av Cluster
Lagt till länkar

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Löste problemet genom att göra alla knappar till grafik istället, inte hållbart men tillfälligt :)

 

Tack för hjälpen ändå

Redigerad av happyfejs

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Yes, då ser du dem bra.. Hur kommer det sig att det inte funkar i Chrome då? Verkar inte som det funkar på Mac heller :S

 

http://www.google.fi/search?sourceid=chrome&ie=UTF-8&q=%E3%81%B2%E3%82%89%E3%81%8C%E3%81%AA+or+%E5%B9%B3%E4%BB%AE%E5%90%8D Fungerar google på japanska i dina webbläsare då? Min dator <3 ser japanska out of the box både med Chrome och webbläsarn Rekonq, så jag undrar just om det kanske är fel på era operativsystem, om det krånglar. *ängel-smilie-här*

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×
×
  • Skapa nytt...