Just nu i M3-nätverket
Jump to content

å ä ö i Outlook Express 6.0


Hans  Peter

Recommended Posts

Sedan någon månad tillbaka är en del av mejlen som jag får i min inbox väldigt svårlästa :angry: eftersom å ä och ö inte är å ä ö.

Ett exempel:

"sÃ¥ att en bostadsrättsförening" ("så att en bostadsrättsförening" skall det egentligen stå).

Jag har WinXP SP3, IE8 och OE6. Finns det något att göra mot detta?

/hans peter

Link to comment
Share on other sites

Hej!

Har exakt samma problem med Windows Live Mail 2009 (vers.14.0.8117.0416) i mitt Windows 7 Pro 64 bit. Eftersom operativsystem och det separat nerladdade mailprogrammet är nytt för mig, så tog jag för givet att det var en liten bugg som snart skulle rättas till, men så har inte skett. Har t.o.m. rapporterat till Microsoft, men det kanske inte är ett tillräckligt intressant problem. För mig är det irriterande, för hela min adressbok med diverse anteckningar, fick redigeras om då programmet inte kunde handskas med å, ä, ö!

Sorry, jag hade ingen lösning på problemet, men kanske någon på Microsoft läser detta...

Link to comment
Share on other sites

Mailet är skrivet med teckenkodningen UTF-8 men visas med ISO-8859-1. Felet kan bero på bugg i avsändarens eller mottagarens e-postprogram. I mailens huvud skall anges vilken teckenkodning, som använts, men alla e-postprogram lägger inte in den informationen.

 

Det finns program för att byta teckenkodning. En förutsättning för att det skall lyckas är att alla använda tecknen ingår i båda teckenkodningarna. ISO-8859-1 till UTF-8 går alltid men tvärtom kan ge problem. UTF-8 innehåller de flesta tecken, som används på jorden medan ISO-8859-1 innehåller endast de latinska tecknen, som används i västeuropeiska språk.

Link to comment
Share on other sites

Hej!

Har exakt samma problem med Windows Live Mail 2009 (vers.14.0.8117.0416) i mitt Windows 7 Pro 64 bit. Eftersom operativsystem och det separat nerladdade mailprogrammet är nytt för mig, så tog jag för givet att det var en liten bugg som snart skulle rättas till, men så har inte skett. Har t.o.m. rapporterat till Microsoft, men det kanske inte är ett tillräckligt intressant problem. För mig är det irriterande, för hela min adressbok med diverse anteckningar, fick redigeras om då programmet inte kunde handskas med å, ä, ö!

Sorry, jag hade ingen lösning på problemet, men kanske någon på Microsoft läser detta...

 

Windows Live Mail 2011 finns utlagd som uppdatering på Windows Update,kolla där,

hoppas att det löser ditt problem...

Link to comment
Share on other sites

Tack Brynäsarn för tipset!

Hoppas problemen löser sig ja. Men jisses vad mycket "lullull"!

Suck..., man har ingen talan här. Begriper mig inte på Windows Update. Säger jag vill välja själv, att dom bara ska påminna mig. Men här dräller in både det ena och det andra, också sånt man inte behöver. Negligerar när jag tackar nej till vissa uppdateringar för att dom inte behövs. Nästa gång man kopplar upp sig så kommer dom ändå! Men det hör väl hemma i en annan tråd...

Link to comment
Share on other sites

Tack, fagerja! Du gav mig ett uppslag. Nu kan jag visserligen avhjälpa symptomen, men själva "sjukdomen" kvarstår .

1) Jag markerar mejlet som innehåller de felaktiga tecknen.

2) Klickar på Visa

3) Väljer Kodning/Fler/Unicode(UTF8)/

och så blir det plötsligt de rätta tecknen hela vägen. Och så får man göra med varje felaktigt mejl.

Än en gång tack!

/hans peter

 

PS. Mitt OE 6.0 är inställd på Västeuropeiska (Windows) vilket tydligen innebär att om avsänadarens mejl är kodad i UTF-8 visas det hos mig felaktigt. Är charset däremot lika med ISO-8859-1 eller inte angivet alls går det bra. Då reser sig genast frågan: Kan jag ställa in mitt OE 6.0 permanent på den annan teckenkod så att jag slipper problemet?

Link to comment
Share on other sites

Jag använder inte Windows så jag vet inte vilka inställningsmöjligheter det finns i OE 6.0. Men någon inställning finns inte som helt skulle lösa problemet då teckenkodningen inte alltid anges. Om det finns en auto inställning så skall rätt teckenkodning väljas automatiskt, men förutsätter att kodningen är angiven i mailets huvud eller är systemets standardkodning I västeuropa är ISO-8859-15 vanligast men i Sverige ISO-8859-1. Skillnaden mellan ISO-8859-1 och ISO-8859-15 är €-tecknet, som saknas i den äldre ISO-8859-1. Så länge som det finns e-postprogran, som inte alltid anger kodning i mailens huvud så kommer problemet att finnas. Eller alla övergår till UTF. Även då kan det uppstå problem på grund av att mottagarens system inte har alla tecken, som ingår i mailet.

Link to comment
Share on other sites

Tack för det utförliga svaret. Svarsmejlet som jag fick av dig nu från EFORUM var kodat i UTF-8 och således "felaktigt". Men nu vet jag ju hur man löser problemet manuellt.

/hans peter

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...