Just nu i M3-nätverket
Jump to content

Summa.Om (Två villkor)


AccessNybörjare

Recommended Posts

AccessNybörjare

Hej! Har problem med att skapa en formel som gör det jag vill.

 

Jag har tre kolumner i mitt Excelblad.

 

Kolumn 1 - Produktvärdekategorier [A1 A2 A3 A4 B1 B2 B3 C1 C2]

Kolumn 2 - Plockfrekvenskategorier [0 1 2 3 4 5 6 7 8]

Kolumn 3 - PlockAntal [Tal1 Tal2 Tal3 Tal4 Tal5 Tal6 Tal7 Tal8 Tal9]

 

Jag vill kunna summera antalet plockade produkter i Kolumn3 med villkoren att exempelvis Kolumn1="A1" och Kolumn2="1".

 

Något tips ?

 

Mvh Emma

Link to comment
Share on other sites

AccessNybörjare

Använd funktionen OCH() i villkoret.

 

 

Menar du såhär

 

=SUMMA.OM(C2:D10;OCH(C2:C10="A1";D2:D10="3");E2:E10)

 

(Fick det inte o funka riktigt).

 

Mvh Emma

Link to comment
Share on other sites

Använd funktionen OCH() i villkoret.

 

ja Gip, hur menar du då? Summa.om fungerar inte med flera villkor.

 

Om du har Excel 2007 finns Summa.OmF

Annars blir det till att ta till en matrisformel i stil med

=PRODUKTSUMMA((C2:C10=A1)*(D2:D10="3")*E2:E10)

Torde fungera som önskat. Dvs ställ upp villkor som evaluerar till SANT/FALSKT, multiplicera dessa med varandra och den kolumn du vill summera över.

Link to comment
Share on other sites

AccessNybörjare

ja Gip, hur menar du då? Summa.om fungerar inte med flera villkor.

 

Om du har Excel 2007 finns Summa.OmF

Annars blir det till att ta till en matrisformel i stil med

=PRODUKTSUMMA((C2:C10=A1)*(D2:D10="3")*E2:E10)

Torde fungera som önskat. Dvs ställ upp villkor som evaluerar till SANT/FALSKT, multiplicera dessa med varandra och den kolumn du vill summera över.

 

 

Tack så jättemycket Monshi! Fick det att funka! med produktsumma!

 

Mvh Emma

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...