Just nu i M3-nätverket
Gå till innehåll
Bor0

Scheduler kör inte kommando i bat fil

Rekommendera Poster

Bor0

Hej,

 

Jag har ett problem med ImageMagick och "convert".

ImageMagicks hemsida

 

ImageMagick fungerar som det ska men när jag ber scheduler köra viss kommando

så händer ingenting.

Kommandot stoppar jag i en ".bat" som körs av schedulern.

 

Kör jag ".bat" filen via cmd så fungerar det klockrent.

 

Vet någon vad kan detta vara?

Kontot jag kör med har alla behörigheter.

 

Ha det bra!

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Mikael63

via cmd, alltså att du först startar kommandotolken och därefter kör .bat?

 

Om du provar köra .bat direkt från utforskaren - vad händer då?

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Anjuna Moon

kontrollera händelseloggarna för tidpunkten som schedulern körde filen, särskild säkerhetsloggen.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Bor0

via cmd, alltså att du först startar kommandotolken och därefter kör .bat?

 

Om du provar köra .bat direkt från utforskaren - vad händer då?

 

Tack för snabbt svar.

 

Kör jag .bat filen via utförskaren så fungerar det!

 

 

Intressant :)

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Bor0

kontrollera händelseloggarna för tidpunkten som schedulern körde filen, särskild säkerhetsloggen.

 

Tack för snabba svaret.

 

Jag har kollat loggen men hittar ingenting som ser konstigt ut.

Själva "jobbet" körs en gång i minuten och ger inte ifrån sig några fel.

Under "History" för "jobbet" står det bara upprepat att det har körts

och slutförts utan problem.

 

Hmhm

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Bor0

ImageMagick kommandot jag körde nu var den enkla standard test kommandot

convert logo: D:\logo.gif

 

Jag gör det för att jag märkte att ImageMagick kommandot jag körde i ett annat jobb inte fungerade när jag körde det som ett schemalagt aktivitet.

I ett större sammanhang ska vissa ImageMagick kommando utföras tillsammans med annat kod och allt annat i jobbet fungerar förutom Imagemagick bitarna när det körs som schemalagt aktivitet.

 

Det fungerade inte även om kontot schemalagda aktiviteten är ett administratörskonto.

 

Det är Windows 2008 Server och SP2 som operativ.

 

Tackar för hjälpen!

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Mikael63

Är det just ImageMagick som inte fungerar schemalagd (och inte själva .bat) så kanske ex. IrfanView (och "command line options") kan utföra din åtgärd?

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Bor0

Är det just ImageMagick som inte fungerar schemalagd (och inte själva .bat) så kanske ex. IrfanView (och "command line options") kan utföra din åtgärd?

 

Tack alla för hjälpen!

 

Idag hittade jag orsaken till bekymret.

Sökvägen till imagemagick la jag in systemvariabeln "PATH" för att slippa tänka på sökvägen till convert.exe när olika kommandon ska köras.

 

Det fungerar klockrent så länge det inte körs som schemalagt aktivitet.

Vid körning som schemalagt aktivitet måste sökvägen till convert.exe specificeras

då systemvariabeln "PATH" inte verkar åtkomlig....

 

Har aldrig behövt göra det förut men nu på en Win2008 server var det nödvändigt.

 

Det var det :)

 

Ha det gott!

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×
×
  • Skapa nytt...