Just nu i M3-nätverket
Jump to content

vsftpd


kentinet

Recommended Posts

jag har vsftpd igång på min ubuntu server. jag vet inte om det är nåt med denna fil eller om det är routern som gör att det inte går att ansluta till den...det har ju funkat förr :angry: !! det jag vill ha och som det har varit tidigare är att man ska kunna ansluta anonymt utan lösen eller nåt...jag kan connecta till den men den vill att jag ska skriva in user och lösenord....ok jag gör detta men det går inte att komma in ändå...tidigare har det var så att vem som helst har kunnat ansluta in i ftp utan username och lösen.

 

finns det nån som kan säga om det är nåt fel på denna fil? om det inte är nåt fel på den så måste det vara routern....eller?

 

det som händer när jag ska försöka ansluta till den via firefox och ftp://ipnummer så får jag ett felmeddelande med en text och den texten är: 220 , japp det är det enda som står...

 

filen är vsftpd.conf

 

/K.


# The default compiled in settings are fairly paranoid. This sample file
# loosens things up a bit, to make the ftp daemon more usable.
# Please see vsftpd.conf.5 for all compiled in defaults.
#
# READ THIS: This example file is NOT an exhaustive list of vsftpd options.
# Please read the vsftpd.conf.5 manual page to get a full idea of vsftpd's
# capabilities.
#
#
# Run standalone?  vsftpd can run either from an inetd or as a standalone
# daemon started from an initscript.
listen=YES
#
# Run standalone with IPv6?
# Like the listen parameter, except vsftpd will listen on an IPv6 socket
# instead of an IPv4 one. This parameter and the listen parameter are mutually
# exclusive.
#listen_ipv6=YES
#
# Allow anonymous FTP? (Beware - allowed by default if you comment this out).
anonymous_enable=yes
anon_root=/utdelat
# Uncomment this to allow local users to log in.
local_enable=no
#
# Uncomment this to enable any form of FTP write command.
write_enable=yes
#
# Default umask for local users is 077. You may wish to change this to 022,
# if your users expect that (022 is used by most other ftpd's)
#local_umask=022
#
# Uncomment this to allow the anonymous FTP user to upload files. This only
# has an effect if the above global write enable is activated. Also, you will
# obviously need to create a directory writable by the FTP user.
#anon_upload_enable=YES
#
# Uncomment this if you want the anonymous FTP user to be able to create
# new directories.
#anon_mkdir_write_enable=YES
#
# Activate directory messages - messages given to remote users when they
# go into a certain directory.
dirmessage_enable=YES
#
# Activate logging of uploads/downloads.
xferlog_enable=YES
#
# Make sure PORT transfer connections originate from port 20 (ftp-data).

Link to comment
Share on other sites

220 är väl att servern är redo för ett nytt kommando från användaren...

 

http://en.wikipedia.org/wiki/List_of_FTP_server_return_codes

 

Har du några filer i /utdelat ?

 

tjena :)

 

japp jag har filer och mappar.

 

jag har kommit så långt att jag kan kontakta ftp servern och kommer åt den via Firefox/Chrome/IE...men, ett kommandot i .conf, anon_root=/utdelat (som jag haft tidigare och det har funkat) ställer till det nu. om jag lägger in den koden då kommer det att jag ska skriva in user och lösen fast jag har anonymous=YES och det funkar inte att skriva in nån user heller och inte blankt heller. men om jag inte har denna sträng så kommer jag in i en tom sida bara...och det är där som alla mappar egentligen skulle ha synats...

 

PS: koden ovan ser inte ut så där idag eftersom jag har fipplat med den, just nu är det original filen + strängen anon_root=/utdelat

 

 

www.kentinet.st

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...