Just nu i M3-nätverket
Jump to content

OCH-funktion i Excel


KaiserClaw

Recommended Posts

Hej!

 

Hur ska en korrekt OCH-funktion se ut?

 

Jag har ettor i A och B, funktionen jag vill skriva ska räkan antalet som uppfyller villkoret!

 

tex:

 

A B

1 1

1

1 1

1 1

 

Svar: 3

 

försöker med denna, vilken tydligen är väldigt fel:

 

=ANTAL.OM(A1:A4=1&B1:B4=1)

Link to comment
Share on other sites

antal.om fungera icke på det viset...

 

ANTAL.OM(område;villkor)

 

dvs

=ANTAL.Om(A1:A10;">1")

ger antalet celler med värde större än ett. Multipla villkor fungerar tyvärr inte med denna formel. Har du Excel 2007? Titta då istället på

=ANTAL.OMF(område1;villkor1;område2;villkor2....)

som kan hantera det du söker.

 

Om du inte har Excel 2007 finns det lite mer komplexa metoder att ta till för att få fram svaret, låt oss återkomma till det isåfall.

Link to comment
Share on other sites

antal.om fungera icke på det viset...

 

ANTAL.OM(område;villkor)

 

dvs

=ANTAL.Om(A1:A10;">1")

ger antalet celler med värde större än ett. Multipla villkor fungerar tyvärr inte med denna formel. Har du Excel 2007? Titta då istället på

=ANTAL.OMF(område1;villkor1;område2;villkor2....)

som kan hantera det du söker.

 

Om du inte har Excel 2007 finns det lite mer komplexa metoder att ta till för att få fram svaret, låt oss återkomma till det isåfall.

 

Tyvärr sitter jag med Excel 2003 och saknar just funktionen ANTAL.OMF..

 

Har totat ihop två funktioner (som fungerar var för sig, men såklart inte ihop):

 

=ANTAL.OM(B7:B700;">"&M1)

=ANTAL.OM(A:A;B1)

 

Hur ska jag gå till väga??

Link to comment
Share on other sites

Två sätt

Omständliga först:

Skriv in en jämförelse på varje rad och räkna sedan utfallet av denna jämförelse.

 

Lite svårare fast i sig samma sak, en matrisformel (fast kan matas in som en vanlig formel)

=PRODUKTSUMMA((A1:A4=1)*(B1:B4=1))

 

Hur denna fungerar?

den utför liknelsen elementvis och får kvar två vektor med sant/falskt i. SANT = 1, FALSKT = 0

därefter multipliceras de två vektorerna elementvis, kvar blir en vektor med 1/0 i som den sedan summerar.

Link to comment
Share on other sites

=ANTAL.OM(B7:B700;">"&M1) = 32

=ANTAL.OM(A:A;B1) = 8

 

Jag har lagt de olika funktionerna i G1 och H1..

 

Ska jag sedan ta =PRODUKTSUMMA((G1=1)*(H1=1)) ?

 

Kan tillägga att det är både tid och datum i de olika cellerna..

 

=ANTAL.OM(B7:B700;">"&M1) -> Kontrollerar om det skedde på eftermiddagen M1 = 12.00. I hela registret finns det 32 händelser som inträffade på eftermiddagen, fast på olika datum..

 

=ANTAL.OM(A:A;B1) kontrollerar hur många antal det finns av ett specifikt datum = 8 händelser

 

Svaret skall korrekt bli: 8 händelser inträffade totalt 2010-04-01, men det var bara en av händelserna som inträffade på eftermiddagen.

Link to comment
Share on other sites

Produktsummeformeln ersätter alltså dina antal.om. De behövs inte. Du kan ställa upp dina likheter inom Produktsummaformeln.

 

Det torde blir som:

=PRODUKTSUMMA((B7:B700>M1)*(A7:A700=B1))

Det går att lägga in fler liknelser i denna om du vill, bara en till *(villkor) i formeln.

 

med det sagt, det finns andra formler som kan fixa detta, titta om du vill på DSUMMA exempelvis.

Eller sätt upp en Pivottabell, de är eminenta på att lösa problem liknande detta.

 

Fast formeln ovan duger bra den med.

Link to comment
Share on other sites

=PRODUKTSUMMA((B7:B700>M1)*(A7:A700=B1))

 

Den satt som en hästspark i ansiktet! Perfa!

 

Tack så mycket för hjälpen! :)

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...