Just nu i M3-nätverket
Gå till innehåll
medimus

Problem att byta systemdisk (hårddisk till SSD)

Rekommendera Poster

medimus

Kan någon hjälpa mig hitta vad som blivit fel med detta? Snälla LÄS NOGA innan du kommer med svar, jag är så trött på enkla svar som inte är relevanta, man blir bara besviken!

 

Jag har köpt en SSD (Intel X-25M 80 Gb SATA) och skulle sätta in den som systemdisk (har ett moderkort ASUS P5B-E med 6 Sata, ingen raid eller annat konstigt). Jag har nu systemet (XP sp3) på en 50 Gb partition på en 320 Gb disk. Så här gjorde jag:

- Jag startade datorn med en dvd UBCD4Win för att inte låsa något på C:

- Via DriveImageXML gjorde jag en Drive to drive-kopia av C: till SSD efter att ha formaterat den. Kopian blev lika stor som originalet. Bytte enhetsbeteckning på gamla C: till Z: och gav SSD beteckningen C:

- Startade igen, nu med en live-cd med GParted, och tog bort boot-flaggan på gamla C:-partitionen och satte boot-flagga på SSD.

- Flyttade SSD till Sata 1 kabeln, tog bort gamla boot-disken tills vidare.

- Gick in i Bios och markerade SSD som startdisk.

 

Nu tycker jag att det borde gå att starta från SSD men det fungerar inte. Den börjar med att starta XP, men sedan står den först länge och tuggar med vad som ser ut som ett tomt skrivbord (det är grått utan bakgrundsbild), alltså inga ikoner eller annat, sedan blir det blått och står Windows XP, bilden "hackar till" ibland men där står det stilla.

 

Åter via dvd UBCD4Win kollar jag Diskhantering, och där står "nya C:", dvs SSD som Felfri (Aktiv) - men inte (System). Chkdsk på SSD:n visar några fel i index som jag korrigerar, men det hjälper inte. Nu har jag flyttat tillbaka alltihop och kör från gamla systemdisken igen, där det står Felfri (System) i Diskhantering (för övrigt hittas samma chkdsk-fel som det var på SSD ovan). SSD står som Felfri och går utmärkt att skriva och läsa från som icke boot-disk, fast vid en snabb jämförelse tar det dubbelt så lång tid att skriva till den som till en annan av hårddiskarna (jag hade trott tvärtom).

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Cluster
Postad (redigerade)

Jag gillar CloneZilla för att klona diskar.

http://clonezilla.org/

 

Ladda ned: http://clonezilla.org/download/sourceforge/stable/iso-zip-files.php

 

Instruktioner för Disk-to-disk: http://clonezilla.org/clonezilla-live/doc/fine-print.php?path=./03_Disk_to_disk_clone/00-prepare-clonezilla-live.doc#00-prepare-clonezilla-live.doc

 

Prova att göra en klon av din nuvarande windows-partition/-disk till din SSD. Koppla sedan bord din "gamla" disk helt och starta datorn med bara SSD:n inkopplad (ställ om i BIOS att boota från SSD:n).

Redigerad av Cluster
Lagt till länkar

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
medimus
Postad (redigerade)

Men det är ju precis vad jag beskriver att jag gjort i ursprungsinlägget, fast med ett annat verktyg än CloneZilla! En drive-to-drive kopia skapar också en exakt klon. Vad jag inte är säker på är om det inkluderar flaggor och liknande (boot-flag etc.)

 

Tillägg: Har tittat mer på CloneZilla och det verkar rätt avancerat men krångligt om man inte är van vid commandline kommandon. Men alternativet att uttryckligen få med bootsektorn verkar intressant. Tror jag ska testa ändå.

Redigerad av medimus

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
medimus

Fortsättning: Laddade hem CloneZilla.iso och startade från en bränd live-cd (inte den rutin som föreslås i tutorial där man laddar in programmen i internminnet). Gjorde sedan en kloning, men en sak skiljer sig från tutorial - jag kan inte göra en disk_to_local_disk klon, eftersom mitt XP ligger på en partition (50 Gb av en 320 Gb-disk), och SSD:n är 80 Gb. Jag valde istället part_to_local_part. Annars följde jag instruktionen men jag fick aldrig frågan "Do you want to clone the bootloader..."

 

Gjorde sedan enligt förslag, satte SSD som disk 1 och angav den som startdisk i BIOS. Fungerade inte alls. Kan det (och tidigare problem) ha att göra med att jag kopierar en start-partition, inte en hel disk??

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
medimus

Tack för tipsen, ska testa, men inte ikväll.

 

Några systemfrågor gällande XP och aktuellt problem:

- Måste bootdisken heta C:? I mitt bios (ASUS P5B-E) kan jag ju ange vilken disk jag vill starta från.

- Spelar det någon roll vilken SATA-kontakt bootdisken sitter på (jag kan som sagt ange vilken jag vill ska användas i bios)?

- Vad är betydelsen av boot-flaggan som jag (utan lycka) kunde ge min SSD och ta bort från gamla startpartitionen (via live-cd GParted)? Jag trodde det var just startsektorkoden som det handlade om, men det verkar inte så. Om det inte är fel i GParted.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
medimus

Installation av Återställningskonsolen och fixboot samt fixmbr på N: (som SSD:n just nu heter) gjorde inte att det gick att starta från den, i alla fall inte när den satt kvar på SATAkontakt 4 och fick behålla namnet N: (men jag angav den som bootdisk i bios). Hade det gjort skillnad om den satt på kontakt 1 och hette C:??

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
medimus

Jag får det fortfarande inte att fungera - upprepar mina frågor två hopp högre upp (om C:, Sata-kontakt och boot-flaggan).

 

Eller kan detta i boot.ini ställa till det?:

 

[boot loader]

timeout=5

default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS

 

Där hänvisas till partition (1), men när jag klonat har jag lagt bootpartitionen (50Gb) från gamla disken på hela den nya (80Gb). Skulle det hjälpa om det stod:

 

default=multi(0)disk(0)rdisk(0)partition(0)\WINDOWS

 

i boot.ini??

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Cecilia

Det är inte nödvändigt att Windows ligger på C:. Windows-disken kan vara ansluten till vilken SATA-kontakt som helst. Boot-flaggan har jag inte tillräckliga kunskaper om.

 

En standard boot.ini ser ut så här:

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect

http://support.microsoft.com/kb/289022

 

så rätt siffra efter partition är 1 för första partitionen. Om man bara har en partition så är det den första.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
medimus

Det fortsätter skita sig. Jag formaterade om SSD:n och gjorde en kopia via CloneZilla. När kloningen var slut kom några meddelanden:

 

"Try run grub install on disc sdc (SSD). The grub directory is NOT found ... Skip running grub install."

******

"Try to run partclone.ntfsfixboot for NTFS boot partition if it exists. Scanning partition(s): sdc1... The NTFS boot partition is NOT found or is not among the restored partition(s). Skip running partclone.ntfsfixboot."

 

Särskilt det sista låter ju som det kan förklara, men jag kan ju starta utan problem från sda (originalet till kopian) - det verkar som bootpartitionen inte klonas, men varför?

 

post-71878-1272821609,26_thumb.gif

 

När jag startar (anger SSD som startdisk men den går igång via hårddisken) och kollar diskhantering är det något märkligt, se skärmdump. Båda har namnet Ettan men hårddisken heter C: och är på 49,81 Gb både i övre och nedre bilden. SSD:n heter N: (som tidigare) men anges till exakt samma storlek som C: i bilden uppe (49,81 GB, 26,31 Gb ledigt), men i nedre bilden anges den korrekta storleken 74,53 Gb. Någon som fattar?

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Cecilia

Särskilt det sista låter ju som det kan förklara, men jag kan ju starta utan problem från sda (originalet till kopian) - det verkar som bootpartitionen inte klonas, men varför?

Det hänger väl ihop med att du inte klonar en hel hårddisk utan bara en partition, om jag förstod något tidigare inlägg rätt.

 

Du bör väl följa dessa instruktioner:

"Disk to disk clone

Description: Clone small disk to larger disk (e.g. 8 GB to 16 GB) (Step by step)"

på sidan http://clonezilla.org/clonezilla-live/doc/

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
medimus

Det hänger väl ihop med att du inte klonar en hel hårddisk utan bara en partition, om jag förstod något tidigare inlägg rätt.

 

Du bör väl följa dessa instruktioner:

"Disk to disk clone

Description: Clone small disk to larger disk (e.g. 8 GB to 16 GB) (Step by step)"

på sidan http://clonezilla.or...zilla-live/doc/

 

Jag använde just den beskrivningen, haken är bara att min gamla hårddisk är på 320 Gb (varav XP-partitionen jag klonar är 50 Gb) och den nya är på 80 Gb, så jag kan inte klona hela den gamla till den nya (inte "small disk to larger disk" alltså). Och även i den beskrivningen avslutas det faktiskt med felmeddelandet om "Try to run partclone.ntfsfixboot for NTFS boot partition ... " som jag fick!

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
medimus

Hittade lite intressant om enhetsbeteckningar (drive letters) på http://www.goodells.net/multiboot/partsigs.htm, bl.a. om att bootdisken nog ändå måste heta C: pga en mängd referenser i registret till just C:, och att det kan bli problem om man gett den nya disken en enhetsbeteckning innan man klonat den, Windows kan då göra fel när den ger den nyskapade bootdisken sin beteckning även om man (som jag gjort) plockat bort gamla C: före omstart. Bra info - men fortfarande fungerar det inte. :(

 

Glömde skriva tidigare att jag uppgraderat SSD:ns bios, märkligt att den levereras med ett halvårsgammalt bios, nytt har funnits sedan före årsskiftet på IBM:s hemsida.

 

Jag har nu tagit bort beteckningen på SSD:n, startat om via cd GParted och gett den boot-flagga (vad det nu betyder), tagit bort gamla startdisken, via UBCD7Win (startcd med en mängd hjälpprogram) kollat och gjort en repararation av mbr på SSD:n, döpt den till C: och försökt starta om. Precis som i första beskrivningen: Segt segt försök att starta Win XP som slutar i att datorn står och tuggar vid startskärmen med Windows (innan Personliga inställningar...), skärmen blinkar till ibland men längre kommer det inte.

 

Jag ger upp, ska skriva till Dustin och fråga om det kan vara fel på disken, trots att den som "bi-disk" verkar fungera även vid hd-test. Men inte som startdisk, vilket var syftet. Jag har nu lagt ner mer timmar på att få igång den än jag skulle kunna vinna i kortare boot-tider på ett år! :thumbsdown:

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
medimus
Postad (redigerade)

Nu är hårddisken igång äntligen. Jag använde DriveImageXML igen (via UBCD4Win-cdn) men istället för disk-to-disk gjorde jag en image av gamla C: och sedan en restore till SSD:n. Då verkar det som bootsektorn och allt kom med och nu fungerar det, och hela kapaciteten finns där i diskmanagement.

 

Innan jag startade om hade jag tagit bort enhetsbeteckningen på SSD:n (den hamnade där tidigare när jag uppgraderade firmware och måste ha den synlig i Windows), och kopplat bort kabeln från gamla C: Jag angav SSD som bootdisk i bios och då fick den automatiskt beteckningen C: av WinXP. När jag sedan kopplade tillbaka gamla disken C+D: hade "gamla C" fått en annan ledig bokstav och det fungerar. När detta verkar stabilt tänkte jag ta bort gamla bootpartitionen och utvidga D:-partitionen till hela den gamla disken med GParted.

 

Men bytet till SSD var inte den revolution jag hade hoppats på, det tar nästan lika lång tid att starta datorn (en stationär med en hel del usb-enheter som ska initieras, vilket inte går fortare med snabbare disk, inte heller bios-rutinerna). Starta program går dock märkbart snabbare.

 

Tack ni som försökt hjälpa, särskilt Cecilia! :thumbsup:

Redigerad av medimus

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Tierra

Hej!

 

Jag har precis skaffat mig en Asus Eee PC 1201N. Den innehåller dock en hårddisk på 250 GB av S-ATA typ (5400 rpm). Denna skulle jag vilja byta ut mot en modern SSD disk på lika mycket utrymme. Min fråga är, går detta? och ifall det går, hur går man tillväga? vad ska man tänka på i sådana fall?

 

 

Tacksam för alla svar!

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
medimus
Postad (redigerade)

Hej!

 

Jag har precis skaffat mig en Asus Eee PC 1201N. Den innehåller dock en hårddisk på 250 GB av S-ATA typ (5400 rpm). Denna skulle jag vilja byta ut mot en modern SSD disk på lika mycket utrymme. Min fråga är, går detta? och ifall det går, hur går man tillväga? vad ska man tänka på i sådana fall?

 

 

Tacksam för alla svar!

 

Det går säkert bra, men det blir väldigt dyrt, billigaste 256 gigs hårddisken på Dustin ligger på 6795 kr, dyraste (och rimligtvis bättre/säkrare) över 14000! Är det värt så mycket pengar? Min 80 Gb hårddisk kostade knappt 2000 och går som ett spjut nu när jag väl lyckats flytta över operativet, men är inte så mycket snabbare som alla säger vid uppstart eftersom bios-funktionerna går med samma fart som tidigare (jag har flera hårddiskar och usb-enheter mm. som ska kopplas på). Att starta program går klart snabbare men jag undrar om 7000 eller mer för en hårddisk är prisvärt. Om något år kostar den väl hälften.

Redigerad av medimus

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Tierra

Det går säkert bra, men det blir väldigt dyrt, billigaste 256 gigs hårddisken på Dustin ligger på 6795 kr, dyraste (och rimligtvis bättre/säkrare) över 14000! Är det värt så mycket pengar? Min 80 Gb hårddisk kostade knappt 2000 och går som ett spjut nu när jag väl lyckats flytta över operativet, men är inte så mycket snabbare som alla säger vid uppstart eftersom bios-funktionerna går med samma fart som tidigare (jag har flera hårddiskar och usb-enheter mm. som ska kopplas på). Att starta program går klart snabbare men jag undrar om 7000 eller mer för en hårddisk är prisvärt. Om något år kostar den väl hälften.

 

Oj, den summan var ingen jag förväntade mig. Trodde hag hade läst någonstans att dem 250 GB SSD diskarna skulle kosta runt 2000 - 3000 kr. Antagligen var det just vad dem "skulle" kosta, möjligtvis missade jag vilket decennium dem syftade på. Ser nu att det är svindyrt, varav jag avstår från lösningen! Tack för hjälpen hur som helst!

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×
×
  • Skapa nytt...