Just nu i M3-nätverket
Jump to content

Datorn fastnar i BIOS


Orfeus

Recommended Posts

Jag har fått trassel med uppstart av min dator.

 

Jag kommer helt enkelt inte förbi BIOS-starten (tror jag), utan fastnar på vägen. För några dagar sedan så gav datorn ibland inte ifrån sig pipet precis när man tryckt på On/Off-knappen utan stängde av istället. Detta hände bara ibland. Nu startar den längre och hittar hårddiskar och så, men fastnar vid "Verifying DMI Pool Data" och kommer inte vidare. Det känns också (lite osäker) som att hela BIOS-rutinen innan dess går lite segare än vanligt.

 

Inte för att jag tror det har någon betydelse, men Windows är nyinstallerat för någon vecka sedan och då köpte jag också en ny hårddisk och kontroller-kort till den. Allt har dock fungerat perfekt fram till nu.

 

Jag har testat att köra på Fail-Safe mode i BIOS, men uppstarten funkar ändå inte.

 

Datorn är rätt gammal - ett hemmabygge från 2003. Moderkortet heter ABIT IS7-G - moderkort - ATX - i865PE och jag använder Windows XP Home.

 

 

Tacksam för svar!

Link to comment
Share on other sites

Har du kollat efter damm?

 

Titta efter hur kondensatorerna på moderkortet ser ut. De ser ut som små torn och ska vara platta och rena upptill och det ska inte ha läckt något nertill. Du kan se bilder på dåliga kondensatorer på http://www.badcaps.net/, http://www.badcaps.net/pages.php?vid=5 och http://techworld.idg.se/2.2524/1.123739

Link to comment
Share on other sites

Tack för svaret Cecilia

Det är inte mycket damm i datorn. Visserligen lite mer kring CPUn, men inte så mycket och datorn håller en bra tempratur. Kondensatorerna verkar också, vad jag kan se fina ut.

Link to comment
Share on other sites

Blir det någon förbättring om du tar ut hårddisken och kontrollerkortet?

Man skulle kunna tänka sig att strömförsörjningen inte riktigt orkar med.

Link to comment
Share on other sites

Tack för tipset,nu har jag nog lite mer koll på läget.

Jag började med att starta min gamla hårddisk från moderkortet och det funkade kanon och likaså den gamla från kontrollerkortet. Den nya har aldrig funkat från moderkortet. Om jag tänker rätt borde väl problemet antingen vara i nya hårddisken eller nån mjukvara precis efter bioset har startat.

Hur felsöker jag nu? Jag kommer ju åt mtt tidigare Windows från gamla disken,så jag kan ju felsöka därifrån.

Link to comment
Share on other sites

Har du installerat Windows på den nya hårddisken? Och det är när du försöker starta den Windows-installationen som det blir problem?

 

Du kan ju köra det testprogram som tillverkaren av den nya hårddisken har på sin webbplats.

Det är oftare lättare att gå via sidan http://www.tacktech.com/display.cfm?ttid=287 för att hitta testprogrammet än att leta på tillverkarens webbplats.

Link to comment
Share on other sites

Japp, det stämmer. Men det har fungerat fint fint fram till nu.

 

Tack för tipset med test-programmen, jag ska köra det när jag kommer hem.

 

Jag kanske skulle nämna det också att igår ikväll defragmenterade jag disken och sen var det nån liten uppdatering av Windows också (dessa uppdateringar blush.gif ), fast en uppdatering borde väl ligga senare i uppstarten än det absolut första som händer.

Nu körde jag disken från den gamla Windows installationen och därifrån funkade den fint - inga problem. Jag körde också en "felkoll", under egenskaper, men den vill ändå inte starta i uppstarten. Men datorn hittar ju disken där...

 

Well well - jag får testa felkollen och återkomma.

Link to comment
Share on other sites

Nu har jag testat testprogrammen, men tyvärr gick testet inget vidare. Det är som en DOS-ruta kommer upp och sen försvinner den. Och kollar man på Samsungs hemsida, så finns inget att ladda ner till min hårddisk, så jag vet inte om det finns något diagos-verktyg för min disk.

 

Kanske finns något alternativ för att kolla disken?

 

En liten annan teori - kan man köra Windows-skivan och testa att reparera Windows?

 

Det känns ju som att precis efter att det låser sig, att det är då uppstarten av Windows börjar. Så kanske är det något stul där som man kan fixa.

 

Eller kan man kontrollera msconfig på en annan disk än den Windows bootar ifrån?

Då kanske man skulle kunna "kontrollera startsökvägar" eller hitta nån annat som spökar i starten?

Link to comment
Share on other sites

Och kollar man på Samsungs hemsida, så finns inget att ladda ner till min hårddisk, så jag vet inte om det finns något diagos-verktyg för min disk.
Samsungs testprogram heter ES-Tool och man bränner det till en skiva som avbild/image i brännarprogrammet. Sedan startar man datorn från skivan.

 

En liten annan teori - kan man köra Windows-skivan och testa att reparera Windows?
Du kan pröva, se till att ha säkerhetskopior på viktiga filer först och ta ut den gamla hårddisken så att du inte råkar reparera fel Windows.

 

Eller kan man kontrollera msconfig på en annan disk än den Windows bootar ifrån?
Inte som jag känner till, men det är mycket möjligt.
Link to comment
Share on other sites

Nu har jag gjort scannern - No error!

Dock gjorde jag inte surface scannen, eftersom den skulle ta lång tid. Men skönt att disken verkar hel i varje fall :)

 

BIOSet verkar ju klaffa även till CDn och det är ju bra.

 

En fråga bara - MsConfig - jag är rätt osäker på hur Windows funkar. Är det trots allt det första som läses in? Kan man kolla nånstans att filen är hel och inte skadad eller nåt?

Link to comment
Share on other sites

Man behöver nog göra även Surface scan för att vara säker på att hårddisken fungerar ordentligt.

 

Det är mycket som händer i datorn innan inställningarna som man gör i msconfig används (själva msconfig-programmet körs inte alls). Jag kommer inte ihåg allt som görs och är inte riktigt säker på ordningen men något i den här stilen är det: Först så ska BIOS hitta hårddisken och dess Master Boot Record (MBR) som skickar vidare till några uppstartsfiler, t ex NTDLR och boot.ini är inblandade, sedan ska Windows söka igenom all hårdvara som finns i datorn och installera drivrutiner för det. Först när det är gjort så installeras olika tjänster (man kan ställa in dem i msconfig). Därefter visas välkomstskärmen och de program som du ser i msconfig - Autostart startas inte förrän du loggar in.

Link to comment
Share on other sites

Tack för hjälpen Cecilia!

 

Nu har jag kört scanningen och det disken funkade kanon - inget fel!

Det tog sina timmar men nu vet jag...

 

Nu har jag gjort en dum grej. Jag tänkte jag skulle uppdatera BIOS på kontrollerkortet, med förhoppningen att nåt var fel där och att allt skulle klaffa sen. Dock så hade jag mitt nya kontrollerkort och det som är på moderkortet på - jag tror det ena heter Silicon 3112A och det nya 3512A (dock osäker - är på jobbet nu).

Nu efter BIOS flashen heter båda 3112A, dock med olika versioner.

 

Hur dumt är detta på en skala och vad gör jag? Jag kommer numer bara in i Windows (med hjälp av min gamla hårddisk) på moderkortets kontrollerkort.

Link to comment
Share on other sites

Ledsen, men nu är det sådant som jag inte har en aning om :( . Förhoppningsvis finns det någon annan som vet något om BIOS och kontrollerkort för hårddiskar.

Link to comment
Share on other sites

Nej, man kan inte kunna allt. Men du verkar annars ha riktigt bra koll! :)

 

Nu har jag uppdaterat BIOS igen från dos. Var lite krångligt med det gick. Det som är mysko nu är att datorn startar bättre nu än innan, även om det fortfarande går åt skogen.

 

Nu kommer faktiskt Windows laddar (eller vad man nu säger) fönstret upp, men efter nånsekund kommer en blå-skärm upp med nåt meddelande och sen stängs datorn av. Tyvärr är bara blå-skärmen framme nån tiondels sekund eller nåt, så jag hinner inte läsa vad det står.

 

MEN - jag har testat checkdisk från dos och det går åt skogen:

"Volymen verkar innehålla ett eller flera oåterkalleliga problem". Dock funkar disken kanon om jag stoppar i den när Windows redan är laddat och checkdisk i Windows flyter utan problem.

 

Samma sak hände ju innan jag köpte det nya kontrollerkortet - då funkade också disken i Windows med inte vid uppstart.

 

Frågan är hur jag går vidare nu?

Link to comment
Share on other sites

Nu kommer faktiskt Windows laddar (eller vad man nu säger) fönstret upp, men efter nånsekund kommer en blå-skärm upp med nåt meddelande och sen stängs datorn av.
Se om du kan starta datorn i felsäkert läge (tryck F8 upprepade gånger under uppstarten och välj felsäkert läge i menyn).
Link to comment
Share on other sites

Tack för svaret! :)

 

Tyvärr, inget felsäkert läge eller gå tillbaka till senaste fungerande bla.bla fungerar.

Dock funkar ju disken perfekt om man startar den i Windows.

 

Nu har jag varit nere på en datoraffär och tänkte lämna in den. Dock tyckte killen att jag skulle testa att installera om Windows först, så det testade jag nyss. Då kom jag tillslut till en blåskärm med meddelandet:

 

"Ett fel uppstog och Windows har stängts för att börebyga problem med din dator.

Följande fel kan vara orsaken till problemet setupdd.sys

 

PAGE_FAULT_IN_NONPAGED_AREA.

 

[...]

 

Teknisk info

Stop 0X00000050

(0XE5137548, 0X00000000 0XF77BDF3e, 0X00000002

 

setupdd.sys - adress F77BDF3E base at F7799000 datestamp 3d6dd67f"

 

 

Så kan det gå. Inte ens Windows vill installeras. Nu tänkte jag prova att formatera disken i Windows och sen göra ett nytt försök...

 

Lite senare:

Nu har jag formaterat in disken i Windows och skulle installera från scratch. Men windows hittar inte hårddisken när man ska bocka för vilken disk/partion man ska installera windows på. Och trycker jag bara retur kommer en blå-skärm upp. Tusan - den åker nog in - det måste ju vara hårdvarufel.

Dock bytte jag PCI-port tidigare och jag såg på kortet att det finns byglar (heter det så?) på kontrollerkortet. Alltså att man kan ändå nån inställning genom att kortsluta kontakterna med nån liten grej. Kanske kan vara något. Måste skriva till supporten och fråga...

Link to comment
Share on other sites

  • 4 weeks later...

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...