Just nu i M3-nätverket
Jump to content

Hjälp med Excel-ark


Per-H

Recommended Posts

Hej

Amatör på excel och behöver hjälp med bifogad fil.

De gula fälten är det som jag vill ha ut

Jag kan göra det med medel funktionen men då måste jag markera varje värde för sig och det är ett himla klipp och klistrande. jag vill använda kolumnerna J och K för att göra mina urval för få medelvärdena samt ej ifyllda i kolumnerna D och E ignoreras i beräkningarna.

Jag har Excel 2000.

Hoppas någon fattar annars fråga på.:)

//Henrik

09ÅLDERSBESTÄMNING_ÄLGHN.xls

Link to comment
Share on other sites

Hej och välkommen till Eforum!

 

Detta är en av de absolut vanligaste frågorna i detta forum och det finns minst två vägar att gå (med förbehållet att jag inte helt kommer ihåg hur saker och ting fungerade i Excel 2000 ...)

  1. Skapa en Pivottabell från din tabell. Du kan då använda innehållet i både kolumn J och K som urval för medelvärdesberäkningar.
  2. Om du hellre vill göra dina egna formler är det PRODUKTSUMMA du ska titta på. T.ex. i D92:
    =PRODUKTSUMMA((J3:J88="t")*(D3:D88))/PRODUKTSUMMA((J3:J88="t")*(D3:D88<>"")*1)


    Denna formel summerar alla celler i D3:D88 där motsvarande cell i J-kolumnen är lika med "t". För ett medelvärde delas detta sedan med antalet celler i D som inte är tomma och där J innehåller "t".

Hälsningar

/Johan

 

P.S Om du söker på pivottabell eller produktsumma här hittar du många liknande frågeställningar. D.S

Link to comment
Share on other sites

Tackar tackar

 

alt 1 körde jag fast i skall prova ikväll igen

alt 2 kopierade in som du skrv men får värdefel i rutan vad göra?

 

MvhHenrik

Link to comment
Share on other sites

Pivottabeller kan vara lite svåra att komma underfund med, men är väldigt kraftfulla när man får kläm på dom.

 

Hmm ... PRODUKTSUMMA fungerar för mig, men kanske är det så att den funktionen inte finns/fanns i 2000. (Du kan alltid kolla i hjälpen om den finns eller inte.) Om inte får du ange formeln som en matrisformel (Det måste åtminstone ha funnits!):

=((J3:J88="t")*(D3:D88))/((J3:J88="t")*(D3:D88<>"")*1)

Skriv formeln och mata in den genom att trycka Ctrl+Shift+Enter. Du ska då få "måsvingar" {} runt formeln. Dessa indikerar att den ska beräknas som en matrisformel, vilket ger samma resultat som PRODUKTSUMMA.

 

Hälsningar

/Johan

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...