Just nu i M3-nätverket
Jump to content

Returnera ett tal beroende på olika inmatningar


NiclasMan

Recommended Posts

Hej Alla!

 

Denna fråga är säkert ganska enkel för Er som är bra på excel!

 

 

 

Jag ha nu suttit hele helgen och jag måste bli klar till imorgon så jag behöver verkligen Er hjälp.

 

Det jag vill lösa är en enkel beräkning som går ut på att jag skall få fram olika "tal" beroende på olika inmatningar i ett fält.

 

T.ex. om jag matar in siffran 1 i en cell så skall talet 5000 returneras i cellen bredvid, men om jag t.ex. slår in 2 istället så skall talet 6500 reutneras i cellen bredvid.

 

Jag har lyckats så långt att jag kan få max 1 villkor att fungera men inte fler.

 

Snälla hjälp mig!!!! Jag blir tokig snart.

 

Bästa söndagshälsningar

 

NIclas

 

 

Link to comment
Share on other sites

Hej,

 

Du kan nästla flera OM-satser, typ:

=OM(A1=1;5000;OM(A1=2;6500;""))

 

Beroende på vilken version av Excel du använder finns begränsningar på hur många OM-satser du kan nästla men oavsett det, om du har många alternativ skulle jag rekommendera en tabell där du använder LETARAD eller INDEX/PASSA för att slå upp värdet som ska returneras. Säg att du har en tabell i A5:B9 med fem alternativ, i så fall fungerar vilken som av följande formler:

=LETARAD(A1;A5:B9;2)

=INDEX(B5:B9;PASSA(A1;A5:A9;0))

 

Hälsningar

/Johan

Link to comment
Share on other sites

Hej,

 

Du kan nästla flera OM-satser, typ:

=OM(A1=1;5000;OM(A1=2;6500;""))

 

Beroende på vilken version av Excel du använder finns begränsningar på hur många OM-satser du kan nästla men oavsett det, om du har många alternativ skulle jag rekommendera en tabell där du använder LETARAD eller INDEX/PASSA för att slå upp värdet som ska returneras. Säg att du har en tabell i A5:B9 med fem alternativ, i så fall fungerar vilken som av följande formler:

=LETARAD(A1;A5:B9;2)

=INDEX(B5:B9;PASSA(A1;A5:A9;0))

 

Hälsningar

/Johan

 

Tack så hemskt mycket Johan! Du har räddat min morgondag!

Mvh

Niclas

Link to comment
Share on other sites

Tack så hemskt mycket Johan! Du har räddat min morgondag!

Mvh

Niclas

 

Om du alltid har jämna steg i inmatningen så kan du använda VÄLJ(INDEX;Värde1;Värde2;...).

Alltså i ditt fall =VÄLJ(A1;5000;6500).

 

/Pär B

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...