Just nu i M3-nätverket
Jump to content

SATA, AHCI, Native IDE, RAID?


Monshi

Recommended Posts

Bråkat lite med datorn efter ominstallation av Vista.

 

Dödat en RAID-array, ska köra som ensamma diskar nu. Läser i manualen och beslutar mig för att köra i RAID-AHCI-läge. Låter som det mest avancerade.

 

men då bråkar datorn, låser sig titt som tätt medan hårddisken/arna jobbar intensivt. Bra prestanda övrig tid men diskoperationer skickar en massa interrupts som tar upp till 20% av CPUn.

Bra prestanda på diskarna i övrigt, kopierar fil mellan dem i 65 MB/s. Prestandan blir lite mystisk dock, HD Tune ger ganska konstant nivå kring 70 MB/s. Ingen dip i slutet av disken.

 

Efter mycket om och men ställer jag om BIOS till Native IDE och se, då slutar diskarna bråka. Datorn tar inga pauser, inga interrupts.

HD Tune ger en mer normal graf där den i början av disken ger knappa 100 MB/s för att sjunka rejält mot slutet till en bit över 50 MB/s.

 

Frågan dyker då upp - hur ska man ställa in sina SATA-diskar egentligen?

Valen som finns är

Native Mode (default)

Legacy ID (låter inte bra)

SATA ->AHCI

RAID, dock ej i ngn array utan som singla diskar.

 

 

ed: En notering.

Gamla RAID0, medel 129MB/s, burst 139 MB/s

Samma disk fast ensam ger medel 85 MB/s, burst 128 MB/s.

Samma söktid, icke imponerande 13,6 ms

2*85 <> 129

Fattas ganska mycket...

 

 

/T

 

Even when we know we´ll never find the answers, we have to keep on asking questions.

 

 

[inlägget ändrat 2010-01-16 15:44:49 av Monshi]

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...