Just nu i M3-nätverket
Jump to content

Problem med ftp-server...


Kalle Dator1

Recommended Posts

I första försöket (med Firefox) får jag fram ftp-platsen utan innehåll, men med en option att gå till en högre katalog.
Finns det någon konfigurering i ftp-servern om vilken mapp som ska visas? Eller hur fungerar det?

 

Nästa försök resulterar i att webbsidan inte kan visas (Försöket avbryts !)
I Firefox? När det står "webbsidan" så verkar det ju som att det inte är FTP-protokollet som används.

 

Link to comment
Share on other sites

Uttryckte mig fel !

 

Naturligtvis är det den sida som kommer fram vid ftp-anropet, och den har då i adressfältet "ftp://..."'>ftp://..." !

 

Cecilia !

Med ftp-servern menar du väl i detta fall FileZilla, där en gällande arbetskatalog har angivits i setup. Arbetskatalogen innehåller en fil som testobjekt.

 

Lite tankeväckande - oklart till vilken nytta - är, att om jag byter ut "ftp://..." mot "http://..(samma namn)", så kommer jag direkt till min hemsida.

 

Undras om inte Apache lägger beslag på anropet och sorterar bort "ftp://.." som ovidkommande... Detta trots att Apache är konfigurerad till specifik webbadress - men med samma IP-nr.

 

En titt i Apache's local-host-error-log visar ett antal försök med mitt eget IP-nr, som resulterat i "file does not exists". Men jag har ingen tidsreferens till mina tappra försök därvidlag...

 

(Tråkigt att det inte finns någon ftp-modul i Apache....)

 

FileZilla kanske inte får en ärlig chans att ta tag i anropet.... Bara en gissning !

 

När jag 100%-igt lyckas att nå FileZilla-servern med det interna IP-numret, är väl antagligen inte Apache inblandat alls... Eller...

 

/Kalle

 

Link to comment
Share on other sites

Undras om inte Apache lägger beslag på anropet och sorterar bort "ftp://.." som ovidkommande... Detta trots att Apache är konfigurerad till specifik webbadress - men med samma IP-nr.

 

Nej, Apache är konfigurerad till en specifik port, normalt 80. Skriver du ftp:// i webbläsaren så används port 21, om du inte anger något annat.

 

Skulle det kanske kunna ha med att det inte upprättas någon dataförbindelse? Om du kör passiv ftp så behöver klienten kunna ansluta på en port till. Du borde kunna ställa in portar för passiv ftp i ftp-servern och sedan öppna (dvs port-forwarda) dessa i brandväggen.

 

 

Link to comment
Share on other sites

Vi får väl som om Thomas Tydal dyker upp igen, för han kan det här bättre än jag.

 

Lite tankeväckande - oklart till vilken nytta - är, att om jag byter ut "ftp://..." mot "http://..(samma namn)", så kommer jag direkt till min hemsida.
Menar du att du fortfarande skriver :21 på slutet?

Låter ju konstigt att Apache skulle svara på port 21.

 

En titt i Apache's local-host-error-log visar ett antal försök med mitt eget IP-nr, som resulterat i "file does not exists". Men jag har ingen tidsreferens till mina tappra försök därvidlag...
Kolla om där blir nya rader när du håller på med dina FTP-försök.

 

När jag 100%-igt lyckas att nå FileZilla-servern med det interna IP-numret, är väl antagligen inte Apache inblandat alls.
Så borde det vara.

 

Link to comment
Share on other sites

Thomas !

 

I routern (D-Link DIR-100):

 

Port 80 är forwarded för Apache 1 och port 443 för Apache2 (ett upplåtet utrymme)

 

För Utor 1 ("Filhantering" [no comments !}) har jag port 55797 - 63977

 

Jag har port forward portarna 20 - 21 för FileZilla Server...(passiv mode !)

 

That's all...

 

Allesammans med IP-adress 192.168.0.123 (Server-PC) !

 

 

Cecilia !

 

Skriver inte ":21" på slutet av ftp-adressen ! Kan endast göras med ett IP-nr. Försöker jag med en namnadress så försvinner ":21" illa kvickt och resulterar i samma sak.

 

Nej - det blir inga nya rader i error-loggen vid färska försök !

 

Undrar om det har betydelse i vilken ordning de olika objekten står i routerns Portforwarding...

 

Om t ex FileZilla skulle stå som första objekt... Långsökt och tveksamt - men dummare sakernas tillstånd har ju förekommit...

 

Link to comment
Share on other sites

Jag har port forward portarna 20 - 21 för FileZilla Server...(passiv mode !)

 

Port 20 används för active mode, men du vill med största sannolikhet köra passive mode...

 

Gå till "Passve mode settings" på inställningarna på FileZilla-servern. Där ska du ange din "external address", i ditt fall din noip-adress. Här finns också en "port range", alltså ett antal portar. Dessa portar måste du port forwarda i routern.

 

 

[inlägget ändrat 2009-11-26 15:18:46 av Thomas Tydal]

Link to comment
Share on other sites

Jag har sneglat på den biten i "passive mode setting" . Men avstått p g a att jag har en dynamisk DNS !

 

Men kanske jag har lite missförstått texten i settingen ! ?

Där står att det tar en viss tid innan en ev felaktig IP-adress har rättats till.

Står också att man kan skriva in sin adress, i mitt fall den adress som ju börjar med "ftp://..."

 

Däremot port range.... Ställer mig både tveksam och frågande !

 

Du menar kanske den range som anges längst ned, vilket väl är alla befintliga portar. Det skulle betyda att jag lämnar fältet vidöppet och utan begränsningar !

 

Någon annan port range anges inte....

 

Link to comment
Share on other sites

Jag har sneglat på den biten i "passive mode setting" . Men avstått p g a att jag har en dynamisk DNS !

 

Problemet är att du har en router med NAT. Det innebär att datorn du har FileZilla Server på, och därmed även FileZilla, inte känner till din riktiga ip-adress. Men i och med att du använder dynamisk DNS så känner ju den till din riktiga ip-adress och därför bör du ange adressen som du får från dynamiska-dns-tjänsten.

 

i mitt fall den adress som ju börjar med "ftp://..."'>ftp://..."

 

Viktigt att hålla isär begreppen. En adress börjar inte med ftp://. Det som börjar med ftp:// är en URL. En URL innehåller visserligen en adress, men den innehåller annat också. En URL ser ut så här:

 

PROTOKOLL://adress:port/fil

 

Exempel:

 

//eforum.idg.se/default.asp

 

http är protokollet

eforum.idg.se är adressen

default.asp är filen som du vill hämta.

 

Du menar kanske den range som anges längst ned, vilket väl är alla befintliga portar. Det skulle betyda att jag lämnar fältet vidöppet och utan begränsningar !

 

Du kan ställa in vilken range du vill, men du måste öppna samma range i brandväggen, dvs port forwarda till ftp-servern. Det som port range talar om är vilka portar som FileZilla får använda, och är inte dessa öppna så kommer ju inte förbindelsen att kunna upprättas.

 

Den här brandväggshysterin som är har ju fått folk att tro att det är farligt att inte ha brandvägg eller att det är osäkert med en massa portar öppna, men så är det ju inte alls. Om du tar bort brandväggen eller öppnar alla portar så händer inget i och med det, utan för att det ska bli något osäkert så krävs det att det antingen finns ett serverprogram igång som har säkerhetshål eller att du har konfigurerat det fel. Har du inget serverprogram igång så har du heller inga portar öppna.

 

 

Link to comment
Share on other sites

Servern går "24/7" ! Hysterin fortsätter således med ovisshet om befintliga säkerhetshål !

 

---

 

T ex range 21 - 79 som exempel ?? 80 kan jag inte passera i routern - upptagen ! Ej heller någon av de andra satta portarna !

 

Och lägre än 21 lär det väl inte bli... Eller....

 

Provar med detsamma !

 

Nope ! Samma resultat.

 

Provar ändå med 1 - 79 ! Nope !

 

Samma portnummer i såväl Public port som i Private port (routern !) !! ??

 

 

 

Ska jag helt överge portnummer 21 i sammanhanget ? Sätta en range i något annat och högre ledigt spann ?

 

Link to comment
Share on other sites

Port range för passive mode har ingenting med den ursprungliga anslutningen till servern att göra. FTP använder normalt port 21 för att ansluta till servern, men filer och data skickas inte den vägen. Port 21 används bara som kontrollkanal, för att skicka kommandon. Datakanalen öppnas på en separat port. I active mode så är det ftp-servern som öppnar en förbindelse till klienten, men det funkar ju inte om klienten sitter bakom en brandvägg eller router, därför använder man normalt passive mode i dag.

 

Passive mode är att klienten öppnar en till förbindelse mot servern, på en annan port. Vilken port som ska användas kommer servern och klienten överens om på den redan öppnade kontrollkanalen. Det som du ställer in på passive mode port range i servern är alltså de portar som servern kan välja mellan att använda. Samtliga dessa portar måste förstås vara port forwardade i routern, annars går de ju inte att använda.

 

Du kan välja hur många eller hur få portar som helst, och du kan välja vilka som helst som är lediga. Är de upptagna kan du förvisso välja dem ändå (som port 80), men FileZilla kommer inte att kunna använda dem, för när FileZilla försöker får den ju bara felmeddelande med att porten redan används.

 

Minimum är dock att det finns en port för varje samtidig användare på servern.

 

Det normala är att man sätter dessa portar någonstans över port 1024.

 

 

Link to comment
Share on other sites

Må vara att jag kan sätta en vid range i FileZilla passive mode setting.

 

Men eftersom jag skulle sätta samma range i routern, som du menade, kan jag inte passera t ex port 80. Då säger routern ifrån att denna port redan används !

 

Men jag sätter alltså en range - inkluderande 1024 - i FileZilla och en täckande range - (innefattande 21 ?) - i routern....

 

Eller behöver jag inte alls ange port 21 i routern ? Och hur är det med Private resp. Public port där ?

 

 

Det finns också en General setting i FileZilla, där en port range ska sättas ! Gäller samma sak där, eller ska där sättas port 21 ?

 

Har nu testat med General setting = range för passiv mode

Även med General setting = 21

 

I routern med 1024 - 2048 på såväl Public som Private

 

Slutsats:

 

Jag har världens tjurigaste router tillika FileZilla-Server !! De är omutbara ! Eller vad tycks ?

 

/Kalle

 

 

Tillägg:

 

Kom att tänka på att jag inte låtit Norton Internet Security hänga med i portkarusellen. Därför ställde jag om NIS till att öppna alla portar såväl in- som utgående för FileZilla Server....

 

Hjälpte det ? Neej !

 

/Kalle

[inlägget ändrat 2009-11-26 18:11:03 av VideoKalle]

Link to comment
Share on other sites

Hittills har mina ansträngningar varit begränsade till att från en dator i mitt eget nätverk få access med en internetadress (URL) till en ftp-site via FileZilla Server på en annan dator i nätverket.

 

Försöken har skett, dels genom FileZilla Client och dels genom endera av webbläsarna Internet Explorer resp. Mozilla FireFox.

I inget av dessa försök har full tillgång uppnåtts.

 

Med Mozilla har jag visserligen delvis kommit fram till den arbetskatalog, som är utsatt genom FileZilla Server, men inte lyckats få tillgång till innehållet i form av en testfil.

Bara en option att gå till en högre katalognivå, vilket inte heller är möjligt, annat än till en påbyggnad av sökvägen med "..\" .

Vid uppdatering av sidan, visas småningom meddelande om att anslutningsförsöket avbryts p g a att "ftp-servern inte kan nås"

 

Internet Explorer meddelar bara "Sidan kan ej visas !...."

 

När jag på samma dator anropar serverdatorns interna IP-nummer, har jag omedelbart full tillgång till den sökta arbetskatalogen, i såväl FileZilla Client som Mozilla FireFox och Internet Explorer.

 

Router-inställningarna har varierats med olika portinställningar, men utan förändrat resultat !

 

Har gått igenom Norton Internet Security's loggar i samband med försök över internet med URL. Men ingenting tyder på att NIS har spärrat eller blockerat försöken att nå servern "utifrån" !

 

Nästa vecka ska jag gå in i ett "skarpt" läge, då jag har tillgång till ett mobilt bredband och på detta sätt kan jobba helt utifrån annan internetanslutning...

Då lär jag få veta om problemet är isolerat till access från datorer inom det egna nätverket via internet-URL till server inom samma nätverk.

 

Kvarstår problemet med tillgången till ftp-servern, kommer jag att sakna de möjligheter jag vill uppnå, att kontinuerligt kunna ladda upp filer till servern, som backup !

 

/Kalle

 

Link to comment
Share on other sites

Med Mozilla har jag visserligen delvis kommit fram till den arbetskatalog, som är utsatt genom FileZilla Server, men inte lyckats få tillgång till innehållet i form av en testfil.

 

Ja, då är det datakanalen som den inte lyckas upprätta. På kontrollkanalen (port 21) så loggar du in, men för att sedan överföra data (exempelvis filer eller listan över filer i katalogen) så upprättas en datakanal. I passiv FTP så upprättas den på någon av de portar du ställt på Passive mode port range. Har du port forwardat dessa portar till ftp-servern?

 

 

Link to comment
Share on other sites

Hej !

 

Portarna i FileZilla Server, respektive D-Link Router är satta enligt bifogade bilder.

 

Körningsresultat i Mozilla enligt bild "Mozilla" !

 

Resultatet i FileZilla Client som tidigare, nämligen en total oförmåga att ansluta till servern !

 

[bild bifogad 2009-11-27 13:17:48 av VideoKalle]

[bild bifogad 2009-11-27 13:18:21 av VideoKalle]

[bild raderad 2009-11-27 13:21:32 av VideoKalle]

[bild bifogad 2009-11-27 13:25:53 av VideoKalle]

[bild bifogad 2009-11-27 13:26:17 av VideoKalle]

1173040_thumb.jpg

Link to comment
Share on other sites

Eftersom man tydligen bara kan skicka en enda bild per inlägg, så skickar jag väl den andra här:

 

[bild bifogad 2009-11-27 13:29:54 av VideoKalle]

1173045_thumb.jpg

Link to comment
Share on other sites

I portforwarding-bilden så har du skrivit in att den publika porten 450 ska kopplas till den privata porten 21, det byter att utifrån internet ska man inte använda port 21 i ftp-klientprogrammet utan 450. Jag föreslår att du ändrar 450 till 21 (för kontrollkanalen) samt inför en ny regel om att port 54000-55000 öppnas till samma interna portar (för datakanaler).

 

I Passive mode settings så anger du "custom port range" till 54000-55000 också. I samma bild så tror jag att det ska vara den externa IP-adressen till routern du ska ange och inte den lokala IP-adressen.

 

Link to comment
Share on other sites

Besked från FileZilla Client:

 

"Status: Slår upp adressen för xxxx.no-ip.org

Status: Ansluter till ....IP-nr...

Status: Försöket att ansluta till "ETIMEDOUT - Connection attempt timed out" misslyckades.

Fel: Kunde inte ansluta till servern

Status: Väntar på att försöka igen...

Status: Slår upp adressen...."

 

Ingen skillnad i vare sig Mozilla eller i Internet Explorer mot tidigare...

 

 

Har nu två regler i routerns port forwarding för FileZilla Server

 

FileZilla Server Public port = 21 ~ 21

192.168.0.123 Private port = 21 ~ 21

 

FileZilla Server Public port = 54000 ~ 55000

192.168.0.123 Private port = 54000 ~ 55000

 

I FileZilla Server

Passive mode setting: Det externa Ip-numret och 54000 - 55000

 

Link to comment
Share on other sites

Tomas & Cecilia !

 

Hittade på denna länk:

 

http://wiki.filezilla-project.org/Network_Configuration

 

nedanstående förklarande text till mina och säkert också andras problem med FileZilla Server. Cecilia hade ju också denna erfarenhet !

 

"

Setting up FileZilla Server

 

Setting up the server is very similar to setting up the client, the main difference is that the roles of active and passive mode are reversed.

 

One common mistake done especially from users with NAT routers is the way they test the server. If you are within your local network, you can only test using the local IP address of the server. Using the external address from the inside will probably fail. Basically one of the following could happen if you try to connect using the external address from the inside:

 

* It surprisingly works

* Router blocks access to its own external address from the inside as possible attack

* Router forwards connection to your ISP which then blocks it as possible attack

 

Even if that works, there is no guarantee an external user can really connect to your server and transfer files. The only reliable way is to connect to your server from an external system outside of your LAN.

"

 

M v h

 

/Kalle

 

Link to comment
Share on other sites

Hej !

 

Har nu fått bekräftat att det fungerar bra med uppkopplingen mellan FileZilla Client och -Server, via extern anslutning...

Det som syntes omöjligt att inifrån samma nätverk anropa den externa ftp-adressen, tar nu ungefär tre sekunder att koppla upp från extern dator !

 

Med vänlig hälsning

 

/Kalle

 

Link to comment
Share on other sites

Har nu fått bekräftat att det fungerar bra med uppkopplingen mellan FileZilla Client och -Server, via extern anslutning...
Kul! :thumbsup:

 

Det som syntes omöjligt att inifrån samma nätverk anropa den externa ftp-adressen
Min erfarenhet också. Det är den lokala IP-adressen man får använda.

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...