Just nu i M3-nätverket
Gå till innehåll
ulrslo

Blir tokig....

Rekommendera Poster

...jättetacksam om någon kan hitta vad som är fel på min sida www.zimzalabim.se.

 

När man klickar på startsida och bläddrar ner lite så på något sätt delas sidan och överdelen "skjuts ut" åt höger.

Klicka några gånger fram och tillbaka och det brukar uppstå.

 

Jättetacksam om någon kan råda mig, kan inte hitta vad som är fel!

 

Ulrika

 

Tråden flyttad från ASP & VBScript av moderator

 

[inlägget ändrat 2009-08-23 18:25:46 av Cluster]

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Hej!

Nu har jag felsökt mer och mer men kan inte hitta vad det är.

Det blir inte fel i Firefox, utan bara i Explorer?!

 

Jag bifogar en skärmdump på felet.

 

När jag klickar på startsida blir allt normalt, men så fort jag flyttar musen därifrån så uppstår förskjutningen ni ser på bilden.

 

Jättetacksam för hjälp!

 

Ulrika

 

[bild bifogad 2009-09-04 21:33:29 av ulrslo]

1158814_thumb.jpg

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Det finns en del buggar i IE6 som gör att sidor visas felaktigt. Bland annat finns det en som gör att marginalerna dubblas. Det kanske är det du har råkat ut för... Ett sätt att kringgå det är att sätta display: inline; på den div som flyttar på sig för mycket.

 

I övrigt hade du en väldig massa fel i xhtml-koden. Det är ju inte otänkbart att något av det kan bidra till att sidan visas konstigt. Du kan få din hemsida undersökt på nedanstående adress så du ser vilka fel det är:

http://validator.w3.org/

 

Eller ännu bättre, installera tillägget "Web Developer" i Firefox som innehåller många praktiska finesser, bland annat genväg till att kontrollera koden.

 

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Stort tack!

Jag vet att det är mycket fel, tyvärr, jag är inte så bra på detta...

Men har försökt så gott jag kan :-)

 

Det konstiga är att sidan fungerat ett år och detta uppstått nu!

 

Hälsningar Ulrika

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Äntligen har jag fått igenom min förstasida, inga fel, yes!

Har många sidor kvar att gå igenom...

Men ett steg rätt...

Däremot hjälpte inte det med mitt problem ovan, inte heller hjälpte det att lägga till inline.

Någon som har någon annan bra idé?

 

Ulrika

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser
Äntligen har jag fått igenom min förstasida, inga fel, yes

...

Däremot hjälpte inte det med mitt problem ovan

Bara för att du får sidan att validera så innebär inte det att sidan kommer att fungera som du tänkt dig.

Man kan ju skriva css- och html-syntaxerna helt rätt men man kanske använder dem fel gentemot varandra.

 

Ett tips är att "plocka bort" allt utom grundelarna och få rätt på det.

Bygg sedan vidare, bit för bit, och kontrollera när felet uppstår.

 

[inlägget ändrat 2009-09-05 16:14:59 av Micke_skane]

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Hej igen!

Har upptäckt något intressant

http://www.zimzalabim.se'>http://www.zimzalabim.se är egentligen http://www.slottner.net/zimzalabim/main.asp'>http://www.slottner.net/zimzalabim/main.asp

 

skriver jag http://www.slottner.net/zimzalabim/main.asp så fungerar det, det är alltså när jag skriver http://www.zimzalabim.se som felet uppstår?

 

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Skapa ett konto eller logga in för att kommentera

Du måste vara medlem för att kunna kommentera

Skapa ett konto

Skapa ett nytt konto på vårt forum. Det är lätt!

Registrera ett nytt konto

Logga in

Redan medlem? Logga in här.

Logga in nu



×
×
  • Skapa nytt...